ZynAddSubFx version

Is it possible to switch from the installed ZynAddSubFx (Fusion V 3.05) to the current ZynAddSubFx (V 3.06)? I am working with version 3.06 on my desktop computer and the presets I created myself are not fully compatible. I don’t necessarily need the nicer gui from Zyn-fusion.

ZynAddSubFX is installed from repository. If you want the last version in zynthian, you should uninstall the current installed version and download & install the latest version. There is an install recipe for this, so you could try and hopefully, it will work. You should try:

apt remove zynaddsubfx
$ZYNTHIAN_RECIPE_DIR/install_zynaddsubfx.sh

If it doesn’t work, you always could reinstall the repo version with:

apt install zynaddsubfx

Good luck … and keep us informed about your progress!

3 Likes

Thanks for pointing me in the right direction. I have no experience with debian, I use a PI4 - could the file zynaddsubfx_3.0.6-5_armhf.deb fit?

1 Like

Yes, this should be the right file.
After deinstallation of zynaddsubfx you can do:

dpkg -i <filename.deb>

1 Like

Yes, if the dependencies are OK.
Where did you get this file? From what repo?

Regards

Found the package here:

https://packages.debian.org/bookworm/armhf/zynaddsubfx

1 Like

zynaddsubfx_3.0.6-5_armhf.deb copied to /home/pi/

and tried to install with:
sudo apt install /home/pi/zynaddsubfx_3.0.6-5_armhf.deb

results in:
Note, selecting ‘zynaddsubfx’ instead of ‘/home/pi/zynaddsubfx_3.0.6-5_armhf.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zynaddsubfx : Depends: zynaddsubfx-data but it is not going to be installed
Depends: libc6 (>= 2.34) but 2.28-10+rpt2+rpi1+deb10u2 is to be installed
Depends: libgcc-s1 (>= 3.5) but it is not installable
Depends: libmxml1 (>= 3.3.1) but 2.12-2 is to be installed
Depends: libstdc++6 (>= 11) but 8.3.0-6+rpi1 is to be installed
E: Unable to correct problems, you have held broken packages.

That’ll probably be why we’re not using the latest zynaddsubfx. The distro we use is too old to support the dependencies. Maybe wait for the 64bit zynthian os?

1 Like

Thanks @Baggypants, that seems to be the problem. I still have to be patient and wait for 64bit.

1 Like