Zynscreen lagging and SPI timeouts

From a while now I’ve been experiencing lags and audio cutouts when interacting with the touchscreen. It wasn’t a problem since I didn’t use it much, but now it’s become quite the hassle since I’ve tried to use it for sooperlooper.
The weird part is that originally it was working perfectly.

I’m running the latest image and version of the stable branch

These are the messages I’m seeing in dmesg:

[  236.169243] ads7846 spi0.1: SPI transfer timed out
[  236.169270] spi_master spi0: failed to transfer one message from queue
[  236.169281] ads7846 spi0.1: spi_sync --> -110
[  236.389249] fb_ili9486 spi0.0: SPI transfer timed out
[  236.684436] spi_master spi0: failed to transfer one message from queue
[  236.684454] fb_ili9486 spi0.0: fbtft_update_display: write_vmem failed to update display buffer

Hi @Pastitas , have you tried with a standard RaspiOs SD Card. Maybe it’s hardware related.

Yeah, after fiddling around with the cabling i’m sure this seems to be a problem with the cables themselves. I guess I’ll have to re-make my ribbons

1 Like

Hi @Pastitas !

Do you have the standard ribbon included with the official kit? In such a case, we could send you a replacement.


1 Like

No, it was self made but after fiddling with the cable It has become obvious that that’s the problem. Thanks!

1 Like