ZynSeq User Guide V5?

The current guide is not adopted to V5 - and I did not quite figure out some things.

A first step would be to copy the wikipage and start editing-in the differences. I’d be happy to help, but need a wiki account.

PS: The pianoroll is wrecking my nerves: every time I enter a longer note all following notes are of the same length. And changing that means long-pressing #4 and dialing… Maybe use F1-4 to change note length??

1 Like

Pattern editor workflow needs some improvements. I also find frustrating the way note duration is managed.
Perhaps we could do some brainstorming …


And once the Arranger was used, I cannot easily get back to piano roll but have to long-press. And way to “switch off” the arranger?

And the Arranger somehow disturbs my patterns, they loose their group colour and content wenn accessed from ZynPad and only play in the Arranger not in ZynPad.

It would help a lot if I could leave the arranger alone and simply have chains of pattern in ZynPad. (I think of the worklflow of my Novation Circuit Tracks)

1 Like

You are right, @mager33 . Sequencer workflows must be improved. We are working on it .

Best regards!

1 Like

Hi @mager33 !

I just pushed some improvements to the sequencer in the testing branch. It improves duration & velocity editing among others.

+ Fix and improve note's parameter edition, specially ehn changing duration & velocity.
+ Now, when editing a note duration/velocity, only this note is modifieded, but the "default" velocity & duration remains unchanged.
+ Changing the "default" velocity/duration is now acomplished by editing an empty cell.
+ Also, the velocity indicator now shows the selected note's velocity. If an empty cell is selected, then the default velocity is shown.

Please, change to testing branch and test.

More improvements in the way :wink:



I’m running with just a touch screen and mouse, and am wondering if theres a way to access the menu in the pattern editor with these input methods? A short press on the upper left heading/menu returns to the sequencer main screen (ie 4x4 grid). A bold press or a long press returns to the main zynthian menu.

Am wondering if either a bold press or a long press on the heading is supposed to bring up the pattern editor menu?

Using the pattern editor with just the touch display is really sub-optimal.
Anyway, did you try to enable display buttons and touch control from the webconf’s UI options?


1 Like

I normally use a mouse for input on the pattern editor, which has worked fairly well for me. I checked that display buttons and touch control and they were both enabled and behaving normally in other places. No buttons were appearing along the bottom of the screen in the pattern editor.

In earlier stable releases a bold press in the upper left of the screen in the pattern editor would bring up the editor’s menu but now, with the latest stable release (2308) it brings up the overall zynthian main menu, as does a long press. Unless I’m missing something it looks like there’s no longer a way of invoking the pattern editor menu just with touch/mouse input.


Switched all parts from “stable” to “testing” and now it does not boot any more “ERROR: Exit 1 IP”, but now Wifi connection. Do I have to re-flash the image?

Either that or connect to ip and troubleshoot the log in the webconfig.

All my zynthians have rotaries and control-less interface is normally less tested.
Anyway, i will take a look.



OK! I’ve good news for touch-only users. I just made some changes that should solve some of the recent issues with the touch interface:

  • When “onscreen buttons” are enabled, a new “Back Button” is added in the top left. All screens have this buttons except the mixer. This button is equivalent to the back switch. Short click to go back, bold click to jump to the mixer.


  • Clicking on the topbar now is equivalent to the “OPT” button in the V5. It opens the options menu, that is contextual. If you click twice, you will be in the Main Menu. Clicking bold will jump to the Admin menu.


These changes are pushed to the “testing” branch, not yet in “stable”.

Yes. There is a problem when bold-touching pads in zynpad. I’m working on it.

[EDIT] OK! It’s solved. It was the “bold-touch” time that was too high[/EDIT]



If only I had thought of adding a button to the topbar… :smile: :wink: :stuck_out_tongue_winking_eye:


Touche :grin:

1 Like

I’ve switched to testing branch and updated and all is working again with just touch interface :grinning:

Thanks for making these tweaks! I kinda like the back “button” in the top left as a solution.


I can only login using SSH. but I am stuck (not knowing enough linux). Where are the logs? How to trigger updates manually?

Everything can be done by the webconf

But if you have ssh access you can look at the logs by running ‘journalctl’

webconf is dead, big red “ERROR” on screen… ok, so much hassle, will flash the image and start again

You can update from command line with this command:


You can get the UI logs with:

journalctl -u zynthian -n 200

and webconf logs:

journalctl -u zynthian-webconf -n 200



How to try the neew seq? Respository zynthian-ui? (switching all to testing killed my zynthian)

1 Like