ZynStep is released!

I use keyboard mapping for the encoders which works well. Are there similar MIDI mapping for encoders?

[Edit] From the wiki here are the MIDI mappings for the encoders:

54 BACK_UP F#3


Oh thanx! I did not knew that!

Awesome @riban !

This is amazing, I’ll try to test it against my pyramid and will surely provide feedback

Awesome work @riban, we all owe you a beer, some fine wine, or some fine tea or chocolate if you don’t fancy the alcoholic beverages


Amazing, thank you!

1 Like

Bravo ! Special big up for the detailed documentation !



I have discovered a significant issue. Sequences with multiple tracks do not play correctly. Until this is resolved please avoid adding tracks to sequences (in arranger). I have added this to the next sprint which I am planning to submit for testing this weekend but this fix may warrent fast track to main branch as a hot-fix. I will let you know of progress.

Nothing is perfect!

[Edit] Good news: I traced this bug and it will be fixed in the next release of zynstep.


Hi riban,
you’re working so hard and I love you for that.

But I have to report a collission at note commands

ZynStep makes a lot of fun during corona-times! Thanx for that!
:star_struck: :crazy_face: :+1:

Thanks @Micki . Would you mind putting this in the issue tracker so that it can be properly triaged and assigned? I don’t think it is a sequencer issue and is probably @jofemodo 's area to look at.


done, thanx :rainbow:

Hi didn’t want to file a bug report yet because I don’t know if it’s just me.

In the wiki it says that on the pattern view, by setting a midi input channel, you can input notes on the cursor with any midi controller that inputs that channel into zynthian, but, when i set the channel, It ignores the midi messages.

The keyboard works fine in any channel and can play sounds in zynthian in various channels (multi timbral mode) and it seems that the midi input setting does not save, as when i click it again it’s in none again.
I’ve tried:

  • Setting the same midi channel as the current midi instrument
  • Setting any other channel
  • Setting a different channel that’s not taken by any instrument and is different to the current midi instrument

None of it yielded any different behavior, this also makes it impossible for me to ‘live input’ notes.

I have the feeling it might be something on my end as this seems like a very usually used feature, but If it is a bug I’ll file a bug report straight away.

Okay, in a struck of genius I tried to use the midi input feature WITHOUT CLOSING THE MENU

and it just works…
Sorry for the noise, I’ll leave this here for my own shaming, maybe the entry in the wiki could use a bit of clarification (i am willing to document this minute difference)

There is a simple way of casting your shame from the battlements . . .


Sorry @Pastitas but I don’t understand. As soon as you set the MIDI Input Channel then MIDI input will start to set notes in the pattern editor whether the menu is showing or not.

Okay, that was what I understood at first, but I don’t seem to be able to get that to work

When I close the menu the midi input channel seems to be unset (maybe the change does not get stored).
I am running the latest version of the master branch of everything, so that’s why I don’t understand this behavior.

I am running this:


zyncoder: master (ef24e0e)
zynthian-ui: master (7084709)
zynthian-sys: master (cdbb0e9)
zynthian-data: master (8c0cdf8)
zynthian-webconf: master (25b1ace)

and it seems to work okay. I have noticed that reopening the menu will clear the channel but other than that it seems to work as described.

Hi @zynthianers!

I just commited a little change to the MIDI router that i’m pretty sure you will like. From today, the stepseq and the MIDI recorder are excluded from the “Active MIDI channel” feature. This means that you can use the stepseq while you are in “Stage Mode” and you don’t need to change to “Multi-timbral” mode for using stepseq. In fact we can go a step forward …

@riban , what do you think about using the “active channel” as the “input channel” for the pattern editor? So we can remove this option from the menu …
In fact, when you enter the pattern editor, the “active channel” should be changed to the MIDI channel assigned to the selected pattern. I would like to test this workflow to see if it’s comfortable and intuitive (development branch, of course!). If this workflow probes to be OK, we should think a better name for the “Stage Mode” … again :grin:

While i’m sure all this has a lot of sense for the stepseq, i have doubts regarding the MIDI recorder, and i probably will restore the old behaviour for it. But first, i would like to listen your thoughts…


1 Like

Hmmm! This may answer my question… what is Active MIDI channel? I was reviewing the router code and was confused by it. I will have a play later and feedback. (Fixing a shed today so a bit busy - I shouldn’t really be here!!!)

@jofemodo when do you think you might merge the last sprint. There is some really good fixes and enhancements in there. Maybe you are waiting until we have a testing branch… :wink: .

1 Like

The “Active MIDI channel” is the selected layer’s MIDI channel. When in “stage mode”, all incoming MIDI messages are translated to this MIDI channel. What i did is excluding StepSeq’s MIDI output from this translation.

Sorry. I will do it ASAP (or in other words, my body wont lay on a bed until it’s merged :sweat_smile:)



I am not convinced this is a good idea but I may have misunderstood Active Channel. A user may wish to use a particular keyboard to enter notes into the step sequencer whilst using different controllers for other purposes. This workflow requires the sequencer to see just one MIDI channel. Pattern Editor’s input channel defines which MIDI channel it is listening to. It has no impact on what channel/s the pattern may eventually play out to.