Zynthian Buster Raspberry 4 test

It still not working, but perhaps we could generate the presets on the first boot, with something like:

cd $ZYNTHIAN_PLUGINS_SRC_DIR/helm/builds/linux/LV2
make ttl_generator
./lv2_ttl_generator $ZYNTHIAN_PLUGINS_DIR/lv2/helm.lv2/helm.so
cp -a *.ttl $ZYNTHIAN_PLUGINS_DIR/lv2/helm.lv2

It should be a lot faster than re-building helm.

I will try this on monday but if someone want to try before … :wink:


I make the change but I miss to make the script executable, I try to tell git to do the chmod, but it’s not working.

git update-index --chmod=+x filename.sh

OK guys!

I improved the script for also generating TTLs for the DISTHRO ports plugins, that also failed to generate in the emulated environment, so i can re-enable the DISTHRO plugins build again.

Tomorrow will see … :wink:



BTW, nightly build is green :wink:


OK! Yerterday’s build failed but today’s one is green again and it should fix the problem with Helm presets.

The time for “ARUK Buster RC-1” is coming … :wink:



OK! Yerterday’s build failed but today’s one is green again and it should fix the problem with Helm presets.

The time for “ARUK Buster RC-1” is coming … :wink:



I have a custom Zynthian up and running, and had put of using a Buster image for months due to a problem with using my Hifiberry Digi+. Yesterday I spent a few hours and managed to solve it :slight_smile:

Jackd initialises alsa in a different way on Buster to how it worked on Stretch. We have to now explicitly tell jack to set up a 16-bit connection with -S parameter to stop it defaulting to 32-bit, which caused wild static distortion from the Digi+'s digital outs.

There’s a good chance this affects the other ‘digi’ boards in the webconf.

Also, we can use the machine name of the boards in the parameters on the rare occasion that they are not at hw:0 (i.e. hw:sndrpihifiberry). Very occasionally my USB controllers take over hw:0 and the digi+ ends up on a different index.

Pull request here:

Looking forward to the new image :heart_eyes:


Hi @zynthianers!

We have a serious candidate to “Aruk Buster RC-1”:


All the engines should be working, also Wifi, etc.
If some of you could test it a little bit and everything is OK-enough, i will rename the file to RC-1 :wink:


1 Like

I have a pi 4 with 2gb ram. Is there anything in particular I can test with this image for you?

You could test the “problematic” engines:

  • Dexed
  • Aeolus
  • TAL-NoiseMaker
  • Helm

Also Wifi subsystem has been a focus of problems with Buster.

And everything else …

  • snapshots: save/restore (test that audio routing is correctly restored, specially in multi-layer setups with several effects)

  • MIDI-learning: some issues with setBfree has been fixed recently. Test that MIDI-learning (CCs & programs) is correctly restored with snapshots.

  • External USB-drive feature: It’s been recently added and should be tested. See this thread:


Thanks a lot!!


Hi @zynthianers!

I’ve been testing a little bit the latest SD-image from the nightly builds (currently is broken again) and i think is good-enough for being the RC1. So i renamed the file like that:


Please, do your testing :wink:

Hopefully, the nightly build system will be fixed in the next days …



Hi @zynthianers!

Nightly builds are working again. Today’s build is green and it includes some improvements and fixes, like:

  • fixed mod-ttymidi
  • improved MOD-UI, including zynthian router MIDI ports that allow to process MIDI data before sending to zynthian core layers
  • new CUIAs; play/stop Audio/MIDI tracks, including keybidings and MIDI bindings (note-on & standard system transport messages)
  • etc.

You can download from here:



1 Like

My AudioInjector Raspi4 setup doesn’t start up.
I have to investigate further.

The issue is solved with 10-09

1 Like
1 Like

Hi @jofemodo,

2019-09-24-zynthianos-buster-lite-1.0.0-RC1 is running since yesterday. Next test at night in the rehearsal room.

Regards, Holger


Tested: 2019-10-15-zynthianos-buster-lite-1.0.0

I’m having a problem with the newer Buster images, something that I’ve only seen before when I’d forget to remove my Beatstep Pro from the USB on first boot :yum:

Looks like the Jack server is unable to start - the screen flashes black each time Zynthian tries to start - and unlike the earlier releases the webconf interface isn’t starting so I can’t got to zynthian.local and select my custom settings for my unusual kit.

I can still SSH in.

My custom setup:
Pi 4 / Hifiberry Digi / Waveshare 4 / Mcp23017 Extra (custom INT pins)

Previously working on 2019-09-24-zynthianos-buster-lite-1.0.0-RC1

Log below:

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
Current Operating System: Linux zynthian 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l
Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:01:74:C9 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 05 June 2019  12:49:54PM
xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support) 
Current version of pixman: 0.36.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 15 09:15:27 2019
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
INFO:root:Wiring Layout MCP23017_ZynScreen
DEBUG:root:ZYNCODER A: [102, 105, 110, 113]
DEBUG:root:ZYNCODER B: [101, 104, 109, 112]
DEBUG:root:SWITCHES layout: [100, 103, 108, 111, 106, 107, 114, 115]
DEBUG:root:ENABLED_MIDI_OUT = ['ttymidi:MIDI_out']
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
libjackpeak failed to start jack client: 17
/zynthian/config/img/zynthian_logo_error_ip.png is 320x240 PNG image, color type RGB_ALPHA, 8 bit, file gamma 0.4546
 PNG file: /zynthian/config/img/zynthian_logo_error_ip.png - Application must supply a known background gamma
  Zooming image by 133%...done
didn't find evidence of prior run.
  Building XImage...done

This image is not “green”, my friend.
Unless you want to get involved deeply in development/solving problems, you should only test “green” images.

i will try to add a mark or something, but until then, please check that image is green in jenkins before downloading:



Understood. I did try the green image but was seeing the same error earlier… must have still had my USB device plugged in. It’s working now :expressionless:

Thanks @jofemodo :+1: