Zynthian changes all Soundfonts in multiple FluidSynth Instances

Hello,

first of all: HI, I’m new to this game and been using Zynthian for about 2 weeks now. It’s a great concept and a worthy successor to the V-Machine, which I’ve been using a lot. So thank all of you for making this possible, I’ll try my best to contribute, where I can.

After having issues with login failures and vanishing MOD-UI presets, I did a fresh install of [ZynthianOS “Aruk Buster” RC-1]. And then updated from the Zynthian with “Update Software”. After a restart or two, I was presented with the new preset system, which is awesome.

I am using the v3 Kit.

Current installed versions:

Now here’s the Issue for me:

  1. ( minor )
    Does the new system recognize identical Soundfonts? Because renaming an already installed Soundfont and uploading it again failed. Non installed Soundfonts work just fine when uploading.

  2. ( major )
    I have setup the following:

First Layer 1#FS: MY/Soundfont1_Grand-Piano -> Audio to mod-monitor ->MIDI Channel1
Second Layer 2#FS: MY/Soundfont2_E-Piano -> Audio to mod-monitor ->MIDI Channel cloned from 1
Third Layer 3#ZY: Companion/Metal Tines -> Audio to system -> MIDI Channel 3
Fourth Layer, Mod-UI: MD SomePedalboard

I have routed in such a way, that I have Grand-Piano on the left audio channel and E-Piano on the right audio channel, which is done in MOD-GUI. Piano goes straght to mixer, E-piano goes to external analog gear and the to the mixer.

Now: if I get the soundfonts right, it works. but after rebooting, both FluidSynth instances always play the same Soundfont, although they are both displayed correctly (see above). When I try to change one of them, both get the new selected Soundfont. Only sometimes it works. It is really confusing and a show stopper for me. Even more strange: after changing to Grand-Piano, the reading is now:

2#FS > MY/Soundfont1_E-Piano/Soundfont2_Grand-Piano

as if the Grand was a preset of the E-Piano, which it isn’t. Trying to reupload ended in 1. (see above).

So, what do you need to know (logs, etc.) to resolve this issue?

Regards!

2 Likes

Could you attach the snapshot?

Thanks,

Thank you!

Certainly,
but I guess I have to use

ssh root@zynthian.local

to download the snapshot from Zynthian?
When I try to do this I get this nasty message, which makes me feel unconfortable:

Also the IP is actually out of the range of my network 192.254.66.11, should be within 192.168.0.1XX.
(But I admit I always have had trouble with networks)

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: POSSIBLE DNS SPOOFING DETECTED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
The ECDSA host key for zynthian.local has changed,
and the key for the corresponding IP address fe80::3e1b:dd4a:f9f8:4bf8%en0
is unknown. This could either mean that
DNS SPOOFING is happening or the IP address for the host
and its host key have changed at the same time.
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:+u5qOCT9EewtXrT5HE8qfNDF62UmPosCoDXRnFw053A.
Please contact your system administrator.
Add correct host key in /Users/XXXX/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /Users/XXXX/.ssh/known_hosts:5
ECDSA host key for zynthian.local has changed and you have requested strict checking.
Host key verification failed.

Is my security compromised?

Sorry for asking, but which path do the snapshots reside in, once this is resolved? I know I’ve read it somewhere, but forgot.

Cheers!

You can get the snapshots from the webconf, using the browser.

Regarding the SSH access, don’t worry about it. You have to delete the “known_hosts” file or use a ssh option for avoiding the error. Google will help you … :wink:

Regards,

Ok, here it goes:

snapshots.zip (10.3 KB)

Maybe it’s worth mentioning: When I eventually REMOVE ALL LAYERS, the Zynthian is busy endlessly. When I (rudely) remove power and boot up, the loaded snapshot is miraculously working.

  • Please Ignore Snapshot 006
  • Snapshot 007 is the one that worked, when I first made that layer setup and saved it
  • Snapshot 008 is the one that works, when I boot up from a hard power cylce

Hope this helps.

Cheers,

Have you had time to peek into this? It would be a real time saver. Because everytime I try a new Soundfont, I have to load the snapshot beforehand…

Cheers,

I’m pretty sure that the issue is related to MOD-UI. Using audio routing to MOD-UI is not well tested and probably raise problems when restoring from snapshot, specially if it’s done on startup.

I will try to improve it, but MOD-UI is a wild beast and it’s designed to run standalone, ruling the system, and don’t like to be a single part of the whole system :wink:

Regards,

I hate to disagree, but MOD-UI seems to have nothing to do with it. It happens with no MOD-UI layer at all. I’ve noticed sth. wich could be helpful:

using fluidsynth 2.09, I created to layers:
1#FS > MY/mygrandpiano
2#FS > MY/myrhodes

This works. Now I want to load a clavinet into 1#FS, which is inside FluidR3 GM.
What happens is:

1#FS > FluidR3 GM/Clavinet
2#FS > FluidR3 GM/1stPatchInSoundfont:YamahaGrand

what Zynhtian shows me is:

1#FS > FluidR3 GM/Clavinet
2#FS > FluidR3 MY/myrhodes/myrhodes

The MY/myrhodes Sounds just vanishes. It is also the first (and only preset) in it’s soundfont.

So if I want to load different soundfonts, I always have to start from scrath, which is a bit cumbersome, to say the least.

Can I assist with more logfiles? I desperatly want to get this solved… :slight_smile:

1 Like

Please, send me the soundfonts you uploaded to zynthian …

OK! I have it …
Man, you have to explain better this kind of issues: The simplest way of reproducing the error, with a minimum number of steps … BTW, your last message is OK and i could find the problem in 2 minutes …

Let me fix it … :wink:

I tested with several soundfonts and found out they all exhibit the same behaviour. So you should be able to pick two random soundonfts and get the result.

As my piano soundfonts are quite large (136MB and 80MB), I used these two, and it’s the same behaviour:

Thank you so much!

I’ll try in the future! :innocent:

OK! It’s fixed!

Simply update and test …

2 Likes

U R my HERO :star_struck:

This is working now and I must be the happiest guy in town now! Soooo much apreciated.

Cheers!

2 Likes