Zynthian Faster

this fixes it

/zynthian/zynthian-sys/scripts/recipes# ./install_lv2_lilv.sh

And the build is ???
Raspbian GNU/Linux 10 (buster)
Build Date: ???

3 Likes

OK! I will try to fix the update code.

Anyway, we have a new green build (buster):

https://os.zynthian.org/2020-02-28-zynthianos-buster-lite-1.0.0.zip

I’ve not tested yet, but it should include all the new changes :wink:

Regards,

1 Like

Excellent. Ithe os pageis a little confusing as to precisely what is andisnt a clean build. We’ll it is to me anyway

OK, here’s what I’ve done.

I flashed a Zynthian image backup from 19 January 2020 to my SD card. I powered on my Zynthian and connected to the WiFi. I selected Update Software in the Zynthian UI. After the obligatory scrolling text, the screen turned all white. The Zynthian UI was gone.

I rebooted the Zynthian over SSH, but the screen was still white. I tried running update_zynthian.sh, and I got the error everybody’s been talking about:

Traceback (most recent call last):
  File "./zynthian_lv2.py", line 28, in <module>
    import lilv
ModuleNotFoundError: No module named 'lilv'

(At this point, the screen was still white.)

Then I ran the script that @mheidt mentioned…

…and ran update_zynthian.sh again. This time, the screen showed the Zynthian UI, but I still got the error message:

Traceback (most recent call last):
  File "./zynthian_lv2.py", line 28, in <module>
    import lilv
ModuleNotFoundError: No module named 'lilv'

Hope this helps. I’ll look into it more tomorrow.

That’s weird. My build from Januar-15 worked. Only an early build had issues.
But let the install_lv2_lilv be the last action.
The update seems to delete it again.

1 Like

I ran install_lv2_lilv.sh, rebooted, restored from backup, and… I can load my snapshots again!!! :partying_face:

@mheidt In gratitude of your help, allow me to :face_with_monocle: you…

ZynAddSubFX > Cormi Sound > Delicato 03

3 Likes
cd /zynthian/zynthian-sys
git log -1 --pretty='%H'
991a37d330f007111b6411b8feab8dc4da942b32

I’m pre-update…

You might like this one a little better which shows how far back you are from the latest.

cd /zynthian/zynthian-sys
git fetch
git branch -vv
* master 991a37d [origin/master: behind 13] Fix banks declaration on amsynth TTL.
1 Like

Hello,

I just updated. Problem while trying to add an affect layer:

I can select any LV2 plugin then I see the usual logo animation but the screen to select a channel or a preset never appear. I can just push “back” button to return to main menu.

The effect layer doesn’t seem to be created (audio can’t be routed to it).

Any clue ?

Is the webconf running? If not, read the solution in this thread. It might be related

Yes webconf is running. And I updated from webconf. I saved the logs if it can be usefull later…

I also tryed

Not fixed yet.

And I am downloading latest build (5 hours left with my poor connection to internet)
But I will try it only if other solutions don’t work.

Hi @zynthianers!

Those having problems with the last update … could you try updating again?

Thanks!

1 Like

Nice … it’s added to the sound demos now :wink:

the machine I had troubles with updates successfully. But I haven’t updated twice after I ran the script.
Let’s see if other peoplewill be successfully.

I hope having solved the confusion problem with zynthinOS download page :wink:

1 Like

For me it didnt solve the problem. But I also did some other things which might have broken it again. For example I switched from master to faster repository for some time and than switched back. I also did an sudo apt update. Now I am flashing the old original rc3 image again.

I just updated.

Everything is way faster.

As of now everything works.

1 Like

Use the latest buster

A post was split to a new topic: Raffo is broken

Hi,

I just updated.

Still not able able to create an effect layer.
I have a v2 kit with aruk RC3, I think I’ll move to buster as advised by mheidt.

1 Like

Which one do you mean? Buster RC1 or the latest from 29th February?