Zynthian OS 2308 image - not working for my Raspberry pi 4

I tried flashing this to a 128GB memory card.

My setup:
Raspberry PI4 4GB
official power supply
128 GB amazon basics SC micro card
HDMI to mini HDMI cable
LG external screen
Generic mouse and keyboard.
Simple aluminum heat sink with no fan.
No hats, no DACs.

Here are details of the issue. I flashed the image onto the SD card and put it into my Raspberry Pi after sometime it started, and the LEDs on the Raspberry Pi started to blink. The red light was stable and the green light kept on blinking showing that there is activity. On the HDMI screen I saw a blank screen there was no logo or any kind of splash screen it booted into a into a terminal that looks similar to the following image

After this it kept on blanking out and then going back to this image. I understood that this is some sort of rebooting behavior that is going on to install things in the back ground (I do not understand why this would be since it is a ready made image) and allowed it to happen after some time however I notice that there is no progress. something funny happened that the terminal name changed from “zynthian” to “raspberry pi” login as you can see in the screen earlier.

web-config tool doesn’t work. Raspberry pi does not have open ports on LAN. I nmaped the IP. Since the PI works with other Images I think the issue is limited to this particular zynthian image.

Am I supposed to do here? it’s been one hour and there has been no progress on the Pi. Is there a stable image that I can use? I want to try it on the pi before committing long time to this project.

Hi @trixon !!

Welcome to zynthian land. I hope you find the answers you need and after getting your zynthian to work a lot of fun!

Could you tell the exact image filename did you use? You should be using this one:


How did you burn the SD card? Could you explain the procedure you followed?

Zynthian webconf works out-the-box, so it’s quite strange the behaviour you describe. Also, if you are using a HDMI display, you should see the zynthian splash screen when booting for first time and reach the UI after the first boot process that takes some minutes.


Solved the Issue by using the “2023-06-03-zynthianos-stable-2306.zip” image instead and updating that from the PI.

Noobs please download this image https://os.zynthian.org/2023-06-03-zynthianos-stable-2306.zip if you have the same issues as me.

" 2023-08-25-zynthianos-stable-2308.zip " was the image I used.

Steps I followed

  1. Download the latest “zynthianos-last-stable.zip” from this page https://os.zynthian.org/
  2. Use “Ethcer” to burn the img to SD card. Later I tried the “Raspberry Pi Imager”
  3. insert into raspberry Pi and plug it in.
  4. wait for any UI stuff

In the my successful attempt i just changed the IMG file. May be something is broken with that image file.

1 Like

You should be using the https://os.zynthian.org/zynthianos-last-stable.zip link to download the latest image that should work fine. If there is a problem with this then we should fix it, not recommend using older images. Did you try to download the latest stable image and flash it a second time? If not then it could be that your first attempt failed to complete for some reason.

yes that’s what I initially use and expected to work. but it did not work for me so that’s why I started this thread. Its very frustrating for newbies to get involved when there is nothing happening.

1 Like

Absolutely and there rae lots of people here ready to help. Did you try to download and flash the latest image more than once or could it be that your first attempt was corrupted?

1 Like

I have exactly the same problem with the latest stable image. I have not tried any previous versions but the problem is exactly as trixon describes it. I checked MD5 and is ok and used etcher to flash it to micro-sd card with verification and everything was ok…
I tried to used it on a rpi 400. If someone found a solution would be glad to hear

1 Like

Welcome @lsdoc77!

There have been reports of failures with large capacity uSD cards. @lsdoc77, what size card did you use?

32gb and I verified the image after flashing it.

1 Like

@lsdoc77 you say that you tested on Pi400. Is that the only platform it fails on or did you also test on a RPi4? (There are other reports of Pi400 having issues and we don’t support that platform - although it should work!)

I have not tried it on rpi4 but I will check that too. For now I am reflusing the image. Also I want to say that I have been trying to download the image a couple of days and the md5 was not correct. I download a lot of things and I very rarely have this kind of problems… It’s strange

1 Like

That is interesting. I too seldom have failed downloads. Maybe this could explain why there have been a few reports of bad images recently. (The reports are generally about failed behaviour but we trace it to bad images after some diagnostics.)

1 Like

Ok , I reflushed the image and tried it on an rpi4. Same problem… I guess since md5 was correct there is no need to download it again… Can it be a problem with the image?

Hi @zynthianers!

I found the problem with the latest stable when booting with HDMI display. A “typo” in the auto-config script is preventing to detect the HDMI configuration and it defaults to V4 settings.

I’m fixing it and will update the image ASAP.


1 Like

I’m generating a SD image with the latest hot-fixes on stable and hope to release it in the next few hours.


1 Like

Hi @zynthianers!

I just uploaded a patched stable SD-image that fixes the “first-boot” issues and also the webconf login authentication error.


Those having a working stable don’t need to re-burn, simply update for getting the webconf fixes.

BTW, i’ve released a testing SD-image:




It is perhaps an experimental/interlocutory stage of the coming 64 bit stable… ? :alien: :slightly_smiling_face:

1 Like

Do you mean the 64 bit testing image?


It’s a work in progress and still needs some extra work. Also, we will jump to bookworm.
But you can try it if you like to be in the cutting edge. It’s 95% functional and “quite stable”, indeed! :wink:



It works really well on my minimal Zynthian. All that’s missing is the ability to calibrate the touchscreen (which however works perfectly) and the Zynthian logo at startup… But I’ve been using it for several weeks without any problems… Well done

Long time lurker, first time commenter
I feel like (maybe?) I’m experiencing something similar.
I flashed the last stable zip six times tonight. Would get to zynthian screen on my touchscreen and rasp pi 4, would change settings in zynthian.local, and nothing…in fact after my last attempt i left it plugged in and it’s sitting theref displaying “configuring your zynthian”… 6 hours i’ve been at this :') my partner thinks i’m on drugs.
I admit I know little to nothing about typing…command…prompts? or whatever the computer black magic most of you can do is called…but I was able to get to the terminal (also mystical to me) and i guess made it so i can no longer access zynthian.local…
I saw briefly something along the lines of “refusing to connect”
it’s super late and i can’t stomach using etcher another time tonight, so i figure i’ll re-do it in the morning and ask what I can do when i do and am able to access the terminal again…
:frowning: I’m in shreds, man. Would anyone be able to help? I have been afraid to ask because i’m not super familiar with your morse code (I mean this in the most endearing way)