Zynthian Scope display set up

How did you get that waveform overlay on the Zynthian screen? Is that a live oscilloscope style view?

I’m busy writing a tutorial for this ! :smiley:

It’s actually demonstrated by Rolf in https://youtu.be/YVy0uN8mUS0

I’m using an Behringer UMC1820 but it will all work with just a zynthian on it’s own. To display any of the available audio in the zynth.

Just remember the PD scope is a destination for audio output from the other engines . .

You need to add the zynscope PD zip file
Zynscope.zip (2.0 KB)

via the Presets & Soundfonts section…

Then select it in the GUI under
NEW Special Layer…



Choose a MIDI channel cos you need to, it doesn’t do too much, but humour the interface … . .

choose the directory you put it in … You did put it in the generative directory didn’t you …?


The odds are it’s the only one so it will probably autoselect . . .

and this gives you the controls that you can use to position the scope position and size. . . .

and the actual scope … :smiley:

But you wont have any audio … :frowning:

To sort this out you need to select the output of engines you want to appear in the scope to PD …

So select the engines you want . . .

Notice I’ve changed zynth’s here to a working audio in on the zynthian connected to my UMC1820 . . .

The audio is coming in via the UMC-1820 channels 5 & 6 from a small UA-3D connected to my desktop Raspberry Pi

I’ve built an audio input on layer 2 that takes the Output form the UMA-1820 channel 5 & 6 using an Audio FX Layer & the gain module.

and by selecting audio out to PD 1 you get audio on the scope …!!

That’s actually Steely Dan… :smiley:


I thought I recognised it :wink: .

1 Like

Wasn’t there some one who used to recognise music by simply looking at the grooves ?

After installing Zynthscope, an update must be made and set window size and position in main.

I just added zynscope, put it in a new chain and then routed some audio from another chain via the “send audio to” option. However, I cannot see any audio coming in zynscope. Actually, it does not show any scope at all. I see that this thread is quite old, so I guess that I am missing something?

If you have novnc enabled, you will need disable it for the scope to display on the Zynthian screen.

1 Like

wyleu - Did you ever write a tutorial as a separate document, or is it the step by step instructions that I see above in the forum?

I did try searching on ‘zynscope tutorial’ and didn’t find anything other than this topic.

Well this thread will probably pick up those involved! Firstly much praise to @ronsum for opening up the possibility of this tool on the zynth and providing our ever benevolent managerial team with another conceptual support headache!
As with most things, peculiar, it starts of in What’s known as the home menu (CTRL-1 Bold Press TL Encoder, layer)

We want New Special Chain…

To get to PureData… notice also that this is where the audio File Player also hangs out, more of this later…

And here you select my personal folder, we will come back to THAT later…

Where I keep the various bits of PureData I have collected… ( The radio station is very good)

So once you have loaded that against a MIDI channel, ( This can feel confusing but is part of the zynthian flow) you need to go back to the mixer where you should see something similar to the following…
(@ronsum are the parameters behaving correctly here? I don’t see them…)

Now as you can see I’ve got an Audio Player on chain 14 and the pure Data zynscope on channel 15 we need to actually get them talking and is not the Zynscope that selects it’s input, it’s the chain selects the zynscope as a destination…

So bold press on the Select Encoder ( CTRL-4) to get the Chain Options menu.

Where we select Audio Output,

and select the pure_data as a destination…

And when you now play the audio

Hey presto you have a playing scope…

Couple of obvious elements ho did I build the Pure data chris directory thingy and how did I get the file into it…?

Well that’s all webconf magic…

But the presets and soundfonts section of this is throwing a 500 . . .

The joys of the cutting edge…


Thank you very much!

You should see the zynscope parameters if you select the zynscope patch in the mixer. I have noticed the following unexpected behavior. If you change the X Postion or Y Position first, it will cause the scope’s Window Size to increase drastically. But if you change the Window Size parameter first, the size of the scope window will remain constant when you change the X/Y Position parameters. I’ll try to fix this in the next few days.