Zynthian with Viewsonic TD2220-2 and AudioBox iTwo

First experience,

Before investing into the Synthian hardware, I wanted to see how it works and if it’s suited for me. I’d probably only use it as a stompbox for synth.

Since I have a Raspberry Pi 3 model B, I thought I’d see if the software works. I put the latest .img on a 32Go SDHC. Plugged a Viewsonic TD2220-2 touch screen and USB mouse & keyboard. At first, I got a blank screen. I immediately understood that I had to activate the HDMI output but I didn’t understand how. Until I found out that you simply do it with a web browser to access to the Synthian interface. Reboot, the Viewsonic worked. Cool.

Next step was to use my AudioBox iTwo. Well, at first nothing. No sound and no MIDI. I used generic device, then I read in one topic that you need to use “dummies”. And now it works. Well for audio, both inputs and outputs without any configuration. But can’t seem to get the MIDI working correctly. I did put Limit USB speed to 12Mb/s.

Now I need to find out how the Synthian works to see what investment I should do for audio.

So I still need to maybe figure out how MIDI works. Don’t know if I will since I only want use the Synthian for audio processing. But then again, if a use MIDI, I won’t be using my AudioBox with the Synthian, I’ll probably get Zynaptik Module v3 & v4 with Case Connectors v4.1. So it’s probably in my case no use to get a brainstorm on making the MIDI work with my AudioBox.

I do have a few questions

For the audio module, I’ll probably stay with a HiFiBerry. Since I only need 6.35 unbalanced inputs and outputs, do I really the HifiBerry DAC+ADC STAGE ? Or would a DAC+ ADC or a DAC+ ADC Pro be enough ?

Will the last 2 HiFiBerry be comptible with the Synthia hardware? ZynScreen+Case Connectors+Controllers Connectors+ Zynaptik Module v3 & v4. Knowing that if this works together I’ll also solve my MIDI problem :slight_smile:

The SD card, is a SDHC good enough or do I need a higher speed? Are there brands to look after?

I’ll also see if the Pi 3 is good enough.

Not only am I a newbie but also a Noob to Raspberry, so be gentle with me :joy:

If someone can give me some advice, it’d be helpful :slight_smile:

Thanx in advance, Xavier

Well if you think you’re getting away with all that without submitting a :face_with_monocle: you’ve another thing coming . . .

People have ended up in the Pantomine for less. . .

Can you use the terminal feature . . .?

to run the command line command

aconnect -l ; That should say a little about the MIDI capabilities …

I’ve used zynthians both 3’s and 4’s with a whole combination of hifiberry cards, from the original Analogue Out only, via both amp boards and the modern in/out and haven’t had a problem. They just work. Nearly all the problems are generally about connectors and soldering :smiley:

The cases track the hardware generation. The really big change from the case perspective was the Pi3->Pi4 and there are a few examples on the site of what needed to be done to get that to work ( files, metal cutting etc ).
Look at the case diagrams carefully. :smiley:

Hopefully this all helps. . .

But forget the :face_with_monocle: at your peril …

1 Like

Well still got nothing from my AudioBox.

When I plugged in my Minilogue, finally, the blue m works like a charm. I also have a Neusonik iM/One which also works like a charm. Nice blue m

So my guess, I have a serious problem with the config of my AudioBox.

With aconncet -I I have only client 0 and client 14 for my AudioBox. I’ll have to dig more into the configuration.


Post the output from the aconnect -l and we will see if you can see anything…

Does iAudio Box appear in the MIDI log drop down options… ?

Ok so here is the midi log screen

And I aslo tried my Unitor8 and it works

So here is the terminal with aconnect -l

Tried my AudioBox with my Mac and it works…

In the end, it seems that my Pi 3 doesn’t recognize my AudioBox.


Looks like that’s the case. Perhaps it uses a special driver? Perhaps email tech support for the device

Some Presonus devices work with Linux. Basically they have to be class compliant. Post the output of lsusb.

ok, so at least it is listed :slight_smile:

root@zynthian://zynthian# lsusb
Bus 001 Device 007: ID 0fb8:1109 Wistron Corp.
Bus 001 Device 006: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 005: ID 194f:0403 PreSonus Audio Electronics, Inc.
Bus 001 Device 004: ID 1ea7:0064 SHARKOON Technologies GmbH
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

it seems that PreSonus can work with snd-usb-audio