Audio injector audio input working? [Solved?]

My Audio input on the Audio Injector card seems to have died.
Output is ok.

I’ve tried two different cards and both behave the same way. They certainly were working. . .

Is your bypass pedalboard kick switch in the circuit?

A emphatically no. Cos I can play fluidsynth using a midi keyboard.

I was just grasping at straws because I noticed your bypass switch wiring diagram didn’t show ground connections.

Grounds are allommoned around the switch.

Well the audioinjector that was spectacularly failing in zynthian-pedal.local works when transplanted to zynthian-alm.local

Ive tried another audio-injector zero and that fails in zynthian-pedal.local as well.

So I suspect the build.
Not sure how to go about testing the input side of an audio injector. Could this be another effect like the renaming of the hdmi & rpi-internal ports?

THere is a slight diffference in the reported aplay -L outputs.

I thought you were having problems with audio input. You seem to have shown list of output devices.

I’m just dumping anything that seems relevant.
It’s one of those it should work but doesnt issues.

I suspect that if I update the zynthian-alm.local machine it will probably stop working as well.
It’s probably occurred around the time we offered the mono options for inputs but I know I had that all working.

Presumably, being unix there is a file I should be able to pipe the aufdio in to… ? not sure I;m sure I’d have to kill off jack first to get it working, but at least I now know I’ve not killed the cards.

One for @MrBroccoli perhaps. I reckon his audioinjector should work in a 3…
I wonder if its Pi4 versus Pi3 …?

Does the input appear as a JACK source and is it routed? You could install and run patchage or just run jack_lsp -c to show all jack ports and their connections.

jack_lsp.txt (2.9 KB)

Okay - looks like a routing issue. system:capture_1 and system:capture_2 are not routed. Have you tried reasserting the Audio FX-Layer, i.e. remove layer then add the audio layer? There have been issues in the past (mentioned by @Baggypants) where routing is lost during updates. I did notice there is some compatibility code around this in the auto-router to attempt to reduce the risk of this but defo worth a try. If that fails, try starting in debug mode as there is a bit of logging in auto router.

I think I’ve tried most things I can think of, certainly removed the audio in components and rebuilt it with the sane result. It’s been so dead on the audio in side that, as I said, I thought I’d killed the cards.

Okay - I reckon you need to gather debug logs as you add an audio layer.

debug_whilst_loading_audio_mixer.txt (24.1 KB)

And it’s magically started working !!! :smiley:

Glad to have been of assistance :blush:


All I can think of was that I cleared down the default setting, and stored it with no layers attached.

I’m even more amazed that i wasn’t challenged for a :face_with_monocle:

So here is one.


Hi again! @wyleu I have almost finished mine.

BUT… I think I have a problem similar to yours. I’ve tried before my Audio Injector Zero soundcard (with a RPi3) with no issues, inputs and outputs were working properly.

But now, after managing to put everything inside a small box, and using a RPi4 with a new SD and new Zynthian image, everything’s working except the audio input. No sound. I have tried with the audio recorder, with the MOD UI and even turning aubionotes on. Nothing. Checked wiring again with a multimeter but it seems to be ok.

I followed this too:

Do you remember how did solve your problem with it?

That’s why I still haven’t posted my Zynthian to the success cases… but I’m preparing a slightly complex cover playing all the instrument with my Zynthian… Coming soon.

Thank you everyone!

1 Like

Alsamixer is your staring point. There is a capture setting and this needs to be enabled. Also make sure you can select the injector card inalsamixer
I’ll try to generate some pictures…