Audio-recorder problems: noise/gaps in recordings [SOLVED!]

#1

Probably you already have noted (i know some of you did it) that our beloved audio-recorder is not working as expected. Noise and audio gaps are present in recordings, and it’s the same if you use the internal SD card or a USB pendrive.

I’m trying to find a solution and any help is welcome :wink:

  1. I’ve opened an issue in the jack_capture repository:

    https://github.com/kmatheussen/jack_capture/issues/26

    The author has answered and give some suggestions, although not a solution… yet! :wink:

  2. Although SD-card write-speed shouldn’t be the problem, i’ve found this:

    https://www.jeffgeerling.com/blog/2016/how-overclock-microsd-card-reader-on-raspberry-pi-3

    perhaps some of you can test it and see if it improves or solves the problem. Anyway, it’s interesting enough for sharing the info :wink:

Regards,

0 Likes

#2

Can’t get it running at the moment, zynthian-sys: master (df30a0d)

seems to hang on stop recording, continual scrolling zynth logo,

from ui log…
– Logs begin at Fri 2019-03-22 10:36:31 GMT. –
Mar 22 10:36:35 zynthian-nord startx[589]: (++) from command line, (!!) notice, (II) informational,
Mar 22 10:36:35 zynthian-nord startx[589]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Mar 22 10:36:35 zynthian-nord startx[589]: (==) Log file: “/var/log/Xorg.0.log”, Time: Fri Mar 22 10:36:35 2019
Mar 22 10:36:35 zynthian-nord startx[589]: (==) Using config directory: “/etc/X11/xorg.conf.d”
Mar 22 10:36:35 zynthian-nord startx[589]: (==) Using system config directory “/usr/share/X11/xorg.conf.d”
Mar 22 10:36:37 zynthian-nord startx[589]: WARNING:root:Using default ENABLED MIDI FB ports
Mar 22 10:36:50 zynthian-nord startx[589]: ZynMidiRouter: MIDI filter get_mf_arrow_to => Not Closed Path or it’s too long!
Mar 22 10:36:50 zynthian-nord startx[589]: ZynMidiRouter: MIDI filter get_mf_arrow_to => Not Closed Path or it’s too long!
Mar 22 10:36:50 zynthian-nord startx[589]: ZynMidiRouter: MIDI filter get_mf_arrow_to => Not Closed Path or it’s too long!
Mar 22 10:36:50 zynthian-nord startx[589]: ZynMidiRouter: MIDI filter get_mf_arrow_to => Not Closed Path or it’s too long!

But these are on startup. Neither of my MIDI tty ports on the two machines I’ve got to the above version seem to be working either. . . .

Rebuild time.

0 Likes

#3

Hi @zynthianers!

The problem with audio recording is solved now. The auto-connector was causing the problem.

@wyleu!! Here is the audio that shows my words …

Just update and enjoy! :wink:

3 Likes

#4

Sorry - I am seeing this problem. Recording audio to internal uSD or external USB I get holes in the recording, short regular mutes of approx. 12ms (left channel - right is approx. 23ms) every couple of seconds. The mute length seems consistent. The recording is 44100 samples per second which comes out close to 512 (1024) samples (which probably relates to a frame or two). I believe I am using the latest version of Zynthian. I updated today and see the scrolling title bar and status bar record indicators which are new. (It might be a good idea to include a version in the UI somewhere.)

Clip of SFZ/Piano/LittleLizardPiano with mutes every couple of seconds:

(@wyleu - does this count as my inaugural audio sample?)

[EDIT] I did some giterypokery and now it is not poking holes in my audio so maybe I hadn’t quite done a good update. As you were…

0 Likes

#5

Sadly according to the ancient scrolls all renditions must be gap free. . . . .

Love to help you guv’ but rules is rules . . …

Have a fluid synth church bell . . .

Apparently you loose marks for not renaming the file and it still being called jack_capture . . … !

I know, I know, but who argues with ancient scrolls …?

0 Likes

Introduce yourself!