Audio stops / interrupts and comes back after some seconds

I observed this issue before and it came back now.
I create a layer and made a simple sequencing.
So, it is just running in a loop and out of the blue the audio stops and starts after a few seconds again.
Sometimes it does it - sometimes it doesn’t.
Now I have also linked it via network to my Ableton live, so not the internal sequencer is playing, but Ableton playing midi tracks to the Zynthian midi channel and the same thing happens.
I know if I will reboot, the issue might not be there again, but at some point, it will show up again.
I observed this some weeks ago for the first time, die updates in between and today it is doing it again.

I have a very basic setup with a Pi4 8GB and an external audio card connected the NI Traktor Audio 2 MKII which works just fine.

I can’t figure out what causes these dropouts.

Link to a short video footage to demonstrate the issue:
Zynthian Audio Dropout video footage

It would be interesting to watch patchage during the incident to see if any audio routing changes.

I was wondering if the soundcard might drop out and come back.
So, if I reboot the Zynthian or also just reboot the UI, it is gone for some time and then comes back again.
I try the internal Pi audio card and see if the same happens with that one.
In case it is the sound card, would there be anything I can do? Maybe some adjustments in the audio card settings? I gonna add a screenshot of the settings.

Ok, the same dropout happens with the internal Pi4 audio card.

did you observe audio and MIDI routing during the incident? It will be good to iterate through the possible issues and eliminate them to hone in on the cause.

Could you explain please, how this is done?
How to observe audio and MIDI routing?
I guess there is a terminal command to watch the stream.

@riban …I am still having the problem and the fun is gone playing with the Zynthian.
I can’t figure out how to solve this.
It seems to be an issue of the software, if it happens with both (internal and external) sound cards.
You mentioned to observe the midi routing and audio routing.
there is no midi routing. It does it also with the internal sequencer and just one synth layer.
first it works for some time and then out of the blue it starts and keeps repeating.
Pi4 with 8GB RAM should not be an issue, software updated, nothing else connected.
only zynthian with mini jack in the internal Pi sound card.
Is that sound card not able to play one synth track? I cant believe it.

Some observations (but not resolutions yet):

  • In the video, when the sound stops, so does the indication of MIDI input
  • The audio level meters continue to behave as expected for a loss of audio hence Zynthian core continue to run
  • There is an xrun coincidental to return of audio

I suspect some odd routing issue, probably of the MIDI signal. How is the MIDI being driven?

@riban it happens also if I program a simple sequence in the sequencer, without any external midi input.
I will do another test today with only zynthinan on power, internal PI audio, by the use of headphone jack and will create one midi layer with a synth and a simple 4 bar sequence and let it run for some time.
when it happens, I will film it again.
in case it is happening this way again, what could be done?
Do you want me to attach screenshots of my configuration settings?

The external devices I usually connect are a USB mouse on the 2.0 port and a Korg Nano Keys 2 also on USB 2.0 and if I use the NI Traktor Audio 2 I plug it into the 3.0 port.
Mostly I also have the LAN cable connected to check the configuration settings and I also used Ableton to remote control all available 15 MIDI channels on the Zynthian for a test, which worked fine, but also caused such dropouts.

As I explained. The dropouts happen in all settings I did so far. Minimal setup with basically nothing connected and maximum setup with external sound card and Ableton remote controlling the MIDI channels.

This all works really nicely until the audio suddenly stops, just to come back after some moments.
Once this happens after some time of running it, it keeps happening in short periods over and over again and doesn’t go away. So, it does not happen from the start - only after some time of performing.

I am back in the Zynthian world after a one-year break.
Now I am still experiencing those audio dropouts.
I have connected a Native Instruments Audio 2 (MK2) device.
Yesterday I updated the entire system. I downloaded the newest Zynthian software and put it on the SD card and still, this happens.
When this happened previously I thought the Pi soundcard might not be suitable for the Zynthian, so I connected the NI DJ soundcard, which should be easily able to handle the audio.
I also changed the audio settings from 44100 to 48000 to see if this changes anything.
The weird thing… at some days all works fine.

I made a short video to show how it behaves:
Zynthian Audio Dropout

Additional note:
After rebooting all works fine again and then I let it run and after some minutes the dropout issue appears again. When it appears, then it keeps dropping out in short periods, like working for a half minute, dropping out for about a half minute, coming back and dropping out again…

Tried external MIDI via Ableton using the emagic MT4 and internal sequencer as well…
Both ways the audio dropout happens.

I am observing that the CPU Temperature seems to go up above 62°C.
Could this be the reason for the dropouts?
I am not using overclocking.
Raspberry Pi 4 Model B Rev 1.4

Screenshot 2022-11-30 at 16.45.41

You should think of improving thermal dissipation in your device. 62ºC is too close to the limit, and it probably will go up when busy. This could be the cause of your problems. Try to monitor the temperature closely, every second or so. If the temperature goes beyond 80ºC, the CPU will reduce the frequency sharply and sound could be interrupted.

Anyway, the RBPi shouldn’t reach 62ºC without working hard, unless ambient temperature is quite high or you put some kind of thermal isolation that avoids heat to be removed.

Could you give some details about your setup? What RBPi4 version do you have? Could you try with another RBPi 4?


1 Like

The built-in fan starts when the Pi boots up and the temperature shows 44.3°C.
Screenshot 2022-11-30 at 17.26.30

I did reload the Zynthian main page every second or so, when I made the previous screenshot and the highest I could capture was 62°C.

I will cut some air slits in the case and see if this improves the temperature situation.

That Pi is the only one I have, so I can not test this with another one.
As you can see the case is pretty large and nothing is in there.
Another thing I was just thinking about is maybe I have hooked up the fan in the wrong way…?
I mean… it should transport heat out instead of blowing inwards.
I need to check the blowing direction. Gonna do this first.


A fan inside a perfectly closed thick-wooden box is not going to do nothing except contributing to heat the ambient still more. Wood is a very very good thermal isolation. My advice is:

  • First, remove the plastic/metacrilat enclosure and secure the RBPi directly to the wooden case.
    Use spacers of the height that fits your current “window” for connectors.

  • You need fresh air going into the case and reaching the CPU before getting warm, so open a first set of ventilation slots just over the fan. This is the “input”. In fact, you could consider attaching the fan directly to the wooden case. If you do so, you could use a bigger & slower fan, so you can reduce the noise. In such a case, you also could use a bigger heat-sink for the RBPI’s CPU.

  • To finish, open a second set of ventilation slots (output) in one side. The closest to the RBPi, the better.

If you do well, you can gain extra CPU power by overclocking the RBPi. FYI, my current zynthian, what i call the “Z2 prototype”, runs at 2 GHz (+25% up!) with no fan and temperature is about 40ºC. I use a aluminum case that acts as a huge heat-sink. I hate fan noise :wink:

Best regards,


I am opening the lead of the box now. It just holds one by magnets.
I get your point and will work on improvement and give feedback when I am done with this.

In fact, just to be sure that over-heating is the problem, take the RBPi from the plastic and wooden enclosures and try to reproduce the issue. Run the RBPi in the open air!

1 Like

Already took it out of the case and will run extensive tests.
Will post the results when I am done.

@jofemodo …some bad news.
I took it out of the housing and also the Pi out of its housing and now it runs really hot and the temp symbol on the display lights up.
Switched it off, because I thought this thing starts cooking now.
So, that little fan held the temperature way down. Now it goes up straight away.

Screenshot 2022-11-30 at 19.06.19

Hi @Eule !

That’s not normal at all! I never saw before a RBPi4 going to 80ºC in open air unless the ambient temperature is >40ºC or some really intensive task is being executed. I suspect your RBPi4 is not working OK.

But at less you have a “diagnostic” for your problem. Everything points overheating!


Yeah… so the Pi must have had this issue since I bought it and I never realized.
Only when I started to work with Zynthian I recognised the dropout issue.
For now, this means for me the Zynthian is dead until I buy a new Pi.

Right now the Pi is back in its case with the little fan (not inside the Zynthian case) and I booted Zynthian and do nothing. No music plays… Now the temperature is at about 42°C constantly.

Is it possible that I am using CPU intense synths?
I know this behaviour from rich sounds from certain plugins at my DAW.
Some sounds each the CPU and the 5 synths I have selected today are the following:

  • olivers-other/Bender Lead
  • Fantasy/ImpossibleDream4
  • Laba170bank/DoublePadBass
  • Fantasy/Emptyness1
  • Collection/Slow Strings

Maybe someone could test if the sounds I am choosing are CPU demanding?
I am not using any effects.

Now the Pi is doing nothing but running Zynthian without playing and the temp is between 41/42°C.