BETA-Tests: more LV2 plugins for MOD-UI


Hi all,

I have written some installation scripts for much more LV2 plugins. To use them you can do the following:

  ssh admin@<YOUR-ZYNTHIAN-IP>
  cd /zynthian
  git clone
  cd zynthian-recipe/recipe
  sh # This will take a while an dhopefully produces no error!

After installation there will be about 500 plugins available. Take a look at for a list of bundles which will be updated or installed. You can call the script as often as you like. It should update your system if there were changes in the repositories.

Some installation scripts are not used because there are already system installations in use.

Regards, Holger

Edited 20170429: fixed typo, fixed script error

Picture "No interface available"

This sounds great - thankyou! I tried to update (I changed ‘cd zynthian-recipe/recpipe’ to ‘…recipe’ as I guess that’s a typo?) and it all downloaded etc but the update failed with these messages: [[:not found
56: export: 3: bad variable name.
Any ideas?


I had the same error @alexbarbed.


@alexbarbed @rod_amaral

Sorry: my fault! Forgot to “chmod 700”. Will fix this today in the repo…

Regards, Holger


@alexbarbed @rod_amaral

Fixed! Please:

cd /zynthian/zynthian-recipe/recipe
git pull

Regards, Holger


It works great! Thank you very much! It’s like Christmas!

Not wishing to derail the topic, but do you know if it’s possible to build a modular synth with this? I can see all sorts of components in there which look like bits of a modular, but there are some crucial things missing (or I can’t find them) to get MIDI into them. I’m guessing some kind of MIDI-CV thing and a triggerable envelope / gate. I’m sure I’m missing a trick somewhere as there are so many esoteric plugins that look suspiciously modular?


In fact this is possible. Take a look at MOD-UI forum were they talked about this last year.

Perhaps we can try to use this, but CV programming is not fully implemented in MOD-UI yet.

Regards, Holger


Hi @C0d3man

After the zynthian update I’m having a problem with zynthian-ui.

When I select a preset the effects added on the pedalboard do not appear in the zynthian-ui listing.

Here is the sample image:




Oh! Me too! Hmmm… will investigate this.

Regards, Holger


Hi @rod_amaral,

I think I have found the problem. I located a wrong package I installed inside It is fixed in the current recipe but for roll back you need to do the following:

apt-get purge  python3-tornado python3-pystache 

If this does not help the following may also help:

cd /zynthian/zynthian-sw/mod-ui
pip3 uninstall tornado
pip3 install tornado

I also fixed an error inside - there were some errors in the script and it stopped without installation. Can you try the fixes?

Regards, Holger


Hi @C0d3man,

Worked Perfect!



Added a new plugin, see:

(The mono and stereo Gain plugins but with smaller footprint on the pedalboard).

To update you should git pull and start again (inside /zynthian/zynthian-recipe/recipe).

Thanks to Robin Gareus (x42)!

Regards, Holger


Hi @C0d3man

I have this error: 45: /zynthian/zynthian-recipe/ [[: not found 56: export: 3: bad variable name



I did the manual installation of the plugin, however I had to make some changes to be able to compile and install the modgui:

sed -i – ‘s,-msse -msse2 -mfpmath=sse,g’ Makefile
make MOD=1


Sorry, I cannot reproduce this problem. But I made an error by calling the right script inside and I just fixed it.

Regards, Holger


HI @C0d3man,

Some cool plugins for zynthian:

I installed it on mine and it works perfectly. As soon as possible I will do the modguis for them.



Hi @rod_amaral,

thanks for your suggestion! I have added a recipe for the infamous plugins. As usual:

cd  $ZYNTHIAN_DIR/zynthian-recipe/recipe
git pull
./ # or: "sh"
reboot # just to be sure

Currently I have only tested this on i386. I hope this works on Raspi, too.

Regards, Holger


Hi @C0d3man :slight_smile:
I also encounter the same error as @rod_amaral : 45: /zynthian/zynthian-recipe/ [[: not found 56: export: 3: bad variable name

Then I tried the infamous plugins on the Zynthian and it failed the following way:

    root@zynthian:/zynthian/zynthian-recipe/recipe# sh
    Cloning into 'infamousPlugins'...
    remote: Counting objects: 5309, done.
    remote: Compressing objects: 100% (10/10), done.
    remote: Total 5309 (delta 2), reused 7 (delta 2), pack-reused 5297
    Receiving objects: 100% (5309/5309), 3.96 MiB | 2.61 MiB/s, done.
    Resolving deltas: 100% (3892/3892), done.
    Checking connectivity... done.
    -- The C compiler identification is GNU 4.9.2
    -- The CXX compiler identification is GNU 4.9.2
    -- Check for working C compiler: /usr/bin/cc
    -- Check for working C compiler: /usr/bin/cc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    -- Performing Test SUPPORTS_SSE
    -- Performing Test SUPPORTS_SSE - Failed
    -- Performing Test SUPPORTS_FAST_MATH
    -- Performing Test SUPPORTS_FAST_MATH - Success
    -- Found PkgConfig: /usr/bin/pkg-config (found version "0.28")
    -- Checking for module 'cairo'
    --   Found cairo, version 1.14.0
    -- Checking for module 'ntk'
    --   Found ntk, version 1.3.0
    -- Checking for module 'lv2>=.0.1.0'
    --   Found lv2, version 1.15.1
    -- Checking for module 'fftw3f'
    --   Found fftw3f, version 3.3.4
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /zynthian/zynthian-sw/plugins/infamousPlugins/build
    Scanning dependencies of target infamous-rule
    [  1%] Building C object CMakeFiles/infamous-rule.dir/src/rule.c.o
    [  2%] Linking C executable infamous-rule
    [  2%] Built target infamous-rule
    [  4%] Generating casynth_ui.h
    Scanning dependencies of target casynth_ui
    [  5%] Building CXX object src/casynth/CMakeFiles/casynth_ui.dir/casynth_ui_main.cxx.o
    [  6%] Building CXX object src/casynth/CMakeFiles/casynth_ui.dir/casynth_ui.cxx.o
    [  8%] Linking CXX shared library
    [  9%] Built target casynth_ui
    Scanning dependencies of target casynth
    [ 10%] Building C object src/casynth/CMakeFiles/casynth.dir/casynth.c.o
    [ 12%] Building C object src/casynth/CMakeFiles/casynth.dir/waves.c.o
    [ 13%] Building C object src/casynth/CMakeFiles/casynth.dir/note.c.o
    [ 14%] Linking C shared library
    [ 14%] Built target casynth
    [ 16%] Generating envfollowerCV_ui.h
    Scanning dependencies of target envfollowerCV_ui
    [ 17%] Building CXX object src/envfollower/CMakeFiles/envfollowerCV_ui.dir/envfollower_ui_main.cxx.o
    [ 18%] Building CXX object src/envfollower/CMakeFiles/envfollowerCV_ui.dir/envfollowerCV_ui.cxx.o
    [ 20%] Linking CXX shared library
    [ 21%] Built target envfollowerCV_ui
    [ 22%] Generating envfollower_ui.h
    Scanning dependencies of target envfollower_ui
    [ 24%] Building CXX object src/envfollower/CMakeFiles/envfollower_ui.dir/envfollower_ui_main.cxx.o
    [ 25%] Building CXX object src/envfollower/CMakeFiles/envfollower_ui.dir/envfollower_ui.cxx.o
    [ 27%] Linking CXX shared library
    [ 28%] Built target envfollower_ui
    Scanning dependencies of target envfollower
    [ 29%] Building C object src/envfollower/CMakeFiles/envfollower.dir/envfollower.c.o
    [ 31%] Building C object src/envfollower/CMakeFiles/envfollower.dir/rms_calc.c.o
    [ 32%] Linking C shared library
    [ 32%] Built target envfollower
    [ 33%] Generating hip2b_ui.h
    Scanning dependencies of target hip2b_ui
    [ 35%] Building CXX object src/hip2b/CMakeFiles/hip2b_ui.dir/hip2b_ui_main.cxx.o
    [ 36%] Building CXX object src/hip2b/CMakeFiles/hip2b_ui.dir/hip2b_ui.cxx.o
    [ 37%] Linking CXX shared library
    [ 39%] Built target hip2b_ui
    Scanning dependencies of target hip2b
    [ 40%] Building C object src/hip2b/CMakeFiles/hip2b.dir/square.c.o
    [ 41%] Linking C shared library
    [ 41%] Built target hip2b
    [ 43%] Generating powerup_ui.h
    Scanning dependencies of target powerup_ui
    [ 44%] Building CXX object src/powerup/CMakeFiles/powerup_ui.dir/powerup_ui_main.cxx.o
    [ 45%] Building CXX object src/powerup/CMakeFiles/powerup_ui.dir/powerup_ui.cxx.o
    [ 47%] Linking CXX shared library
    [ 48%] Built target powerup_ui
    Scanning dependencies of target powerup
    [ 50%] Building C object src/powerup/CMakeFiles/powerup.dir/powerup.c.o
    [ 51%] Linking C shared library
    [ 51%] Built target powerup
    [ 52%] Generating powercut_ui.h
    Scanning dependencies of target powercut_ui
    [ 54%] Building CXX object src/powercut/CMakeFiles/powercut_ui.dir/powercut_ui_main.cxx.o
    [ 55%] Building CXX object src/powercut/CMakeFiles/powercut_ui.dir/powercut_ui.cxx.o
    [ 56%] Linking CXX shared library
    [ 58%] Built target powercut_ui
    Scanning dependencies of target powercut
    [ 59%] Building C object src/powercut/CMakeFiles/powercut.dir/powercut.c.o
    [ 60%] Linking C shared library
    [ 60%] Built target powercut
    [ 62%] Generating cheapdist_ui.h
    Scanning dependencies of target cheapdist_ui
    [ 63%] Building CXX object src/cheapdist/CMakeFiles/cheapdist_ui.dir/cheapdist_ui_main.cxx.o
    [ 64%] Building CXX object src/cheapdist/CMakeFiles/cheapdist_ui.dir/cheapdist_ui.cxx.o
    [ 66%] Linking CXX shared library
    [ 67%] Built target cheapdist_ui
    Scanning dependencies of target cheapdist
    [ 68%] Building C object src/cheapdist/CMakeFiles/cheapdist.dir/cheapdist.c.o
    [ 70%] Linking C shared library
    [ 70%] Built target cheapdist
    [ 71%] Generating stuck_ui.h
    Scanning dependencies of target stuck_ui
    [ 72%] Building CXX object src/stuck/CMakeFiles/stuck_ui.dir/stuck_ui_main.cxx.o
    [ 74%] Building CXX object src/stuck/CMakeFiles/stuck_ui.dir/stuck_ui.cxx.o
    [ 75%] Linking CXX shared library
    [ 77%] Built target stuck_ui
    Scanning dependencies of target stuck
    [ 78%] Building C object src/stuck/CMakeFiles/stuck.dir/stuck.c.o
    [ 79%] Building C object src/stuck/CMakeFiles/stuck.dir/rms_calc.c.o
    [ 81%] Linking C shared library
    [ 81%] Built target stuck
    Scanning dependencies of target ewham
    [ 82%] Building C object src/ewham/CMakeFiles/ewham.dir/ewham.c.o
    [ 83%] Building C object src/ewham/CMakeFiles/ewham.dir/retuner.c.o
 /zynthian/zynthian-sw/plugins/infamousPlugins/src/ewham/retuner.c: In function ‘RetunerAlloc’:
 /zynthian/zynthian-sw/plugins/infamousPlugins/src/ewham/retuner.c:235:1: warning: label ‘fail’ defined but not used [-Wunused-label]
 /zynthian/zynthian-sw/plugins/infamousPlugins/src/ewham/retuner.c: In function ‘findcycle’:
 /zynthian/zynthian-sw/plugins/infamousPlugins/src/ewham/retuner.c:295:12: warning: variable ‘d’ set but not used [-Wunused-but-set-variable]
      int    d, h, i, j, k;
 [ 85%] Linking C shared library
 /usr/bin/ld: cannot find -lzita-resampler
 collect2: error: ld returned 1 exit status
 src/ewham/CMakeFiles/ewham.dir/build.make:120: recipe for target 'src/ewham/' failed
 make[2]: *** [src/ewham/] Error 1
 CMakeFiles/Makefile2:851: recipe for target 'src/ewham/CMakeFiles/ewham.dir/all' failed
 make[1]: *** [src/ewham/CMakeFiles/ewham.dir/all] Error 2
 Makefile:127: recipe for target 'all' failed
 make: *** [all] Error 2
> [  2%] Built target infamous-rule
[  9%] Built target casynth_ui
[ 14%] Built target casynth
[ 21%] Built target envfollowerCV_ui
[ 28%] Built target envfollower_ui
[ 32%] Built target envfollower
[ 39%] Built target hip2b_ui
[ 41%] Built target hip2b
[ 48%] Built target powerup_ui
[ 51%] Built target powerup
[ 58%] Built target powercut_ui
 60%] Built target powercut
[ 67%] Built target cheapdist_ui
[ 70%] Built target cheapdist
[ 77%] Built target stuck_ui
[ 81%] Built target stuck
[ 82%] Linking C shared library
/usr/bin/ld: cannot find -lzita-resampler
collect2: error: ld returned 1 exit status
src/ewham/CMakeFiles/ewham.dir/build.make:120: recipe for target 'src/ewham/' failed
make[2]: *** [src/ewham/] Error 1
CMakeFiles/Makefile2:851: recipe for target 'src/ewham/CMakeFiles/ewham.dir/all' failed
make[1]: *** [src/ewham/CMakeFiles/ewham.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
mv: cannot stat ‘/zynthian/zynthian-plugins/bin/infamous-rule’: No such file or directory

Had a bad run I guess :frowning:



Hi @lod @rod_amaral

You have to call ./ and not sh! I think that is the problem.

I have fixed the installation script for the infamous-plugins. It now makes sure that zita-resampler is installed before compiling/linking.

Regards, Holger


I hope I have fixed this problem. Please pull && try :wink:

Regards, Holger