BETA-Tests: more LV2 plugins for MOD-UI


#41

Hi @ssj71

… have read much of your posts at MOD-forum :wink:

Ah - thanks for this information! I will try to update the Zynthian buildscript next week.

Regards, Holger


#42

Hi! Do you have Loopor (https://github.com/stevie67/loopor) in this set?


#43

Hi @brkl

will try to install this the next days.

Regards, Holger


#44

Now it is. Please pull and run recipe/loopor.sh .

Regards, Holger


#45

Hi @C0d3man !

I was looking for a dedicated drumsynth and I came across this one here:

Its available as a LV2. Here is the GitHub link:

Is a zynthian integration doable? It would be :sunglasses: to have a analog style drumsynth …

Regards!
Martin


#46

Ok - added to recipes. Compiles and load. Havn’t tested if it make noize. Can you check this?

Regards, Holger


#47

Hello @C0d3man !

Thank you for setting this up, here is my report:

I did run the install script:

root@zynthian:/zynthian/zynthian-recipe/recipe# sh stegosaurus.sh
Cloning into 'stegosaurus'...
remote: Counting objects: 99, done.
remote: Total 99 (delta 0), reused 0 (delta 0), pack-reused 99
Unpacking objects: 100% (99/99), done.
Checking connectivity... done.
Setting top to                           : /zynthian/zynthian-sw/plugins/stegosaurus
Setting out to                           : /zynthian/zynthian-sw/plugins/stegosaurus/build
Checking for 'gcc' (C compiler)          : /usr/bin/gcc

Global Configuration
 * Install prefix                        : /usr/local
 * Debuggable build                      : False
 * Build documentation                   : False

stegosaurus Configuration
Checking for program 'pkg-config'        : /usr/bin/pkg-config
Checking for 'lv2' >= 1.4.1              : yes
 * LV2 bundle directory                  : /zynthian/zynthian-plugins/lv2

'configure' finished successfully (0.801s)
Waf: Entering directory `/zynthian/zynthian-sw/plugins/stegosaurus/build'
[ 1/18] Compiling manifest.ttl.in
[ 2/18] Compiling stegosaurus.ttl.in
[ 3/18] Compiling stegosaurus.c
[ 4/18] Compiling stegosaurus_synth.c
[ 5/18] Compiling wavetable.c
[ 6/18] Compiling fastmaths.c
[ 7/18] Compiling noise.c
[ 8/18] Compiling stegosaurus_ui.c
[ 9/18] Compiling deliriumUI/deliriumUI.c
[10/18] Compiling deliriumUI/button.c
[11/18] Compiling deliriumUI/knob.c
[12/18] Compiling deliriumUI/microknob.c
[13/18] Compiling deliriumUI/fader.c
[14/18] Compiling deliriumUI/switch.c
[15/18] Compiling deliriumUI/adsr.c
[16/18] Compiling pugl/pugl_x11.c
[17/18] Linking build/stegosaurus.lv2/stegosaurus.so
[18/18] Linking build/stegosaurus.lv2/stegosaurus_ui.so
Waf: Leaving directory `/zynthian/zynthian-sw/plugins/stegosaurus/build'
'build' finished successfully (1.868s)
Waf: Entering directory `/zynthian/zynthian-sw/plugins/stegosaurus/build'
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electro.ttl (from presets.lv2/electro.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus.lv2/manifest.ttl (from build/stegosaurus.lv2/manifest.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus.lv2/waves/sine.wav (from waves/sine.wav)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electro2.ttl (from presets.lv2/electro2.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus.lv2/stegosaurus.so (from build/stegosaurus.lv2/stegosaurus.so)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus.lv2/stegosaurus.ttl (from build/stegosaurus.lv2/stegosaurus.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electro3.ttl (from presets.lv2/electro3.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus.lv2/stegosaurus_ui.so (from build/stegosaurus.lv2/stegosaurus_ui.so)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electro4.ttl (from presets.lv2/electro4.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electro6.ttl (from presets.lv2/electro6.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronic.ttl (from presets.lv2/electronic.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronic2.ttl (from presets.lv2/electronic2.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronic3.ttl (from presets.lv2/electronic3.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronic_new.ttl (from presets.lv2/electronic_new.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronic_new2.ttl (from presets.lv2/electronic_new2.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronic_new3.ttl (from presets.lv2/electronic_new3.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/electronicq.ttl (from presets.lv2/electronicq.ttl)
+ install /zynthian/zynthian-plugins/lv2/stegosaurus-presets.lv2/manifest.ttl (from presets.lv2/manifest.ttl)
Waf: Leaving directory `/zynthian/zynthian-sw/plugins/stegosaurus/build'
'install' finished successfully (0.099s)
'clean' finished successfully (0.034s)

After the installation the plugin is visible in ModUI. It is also possible to place it on the pedalboard (its listed in “all” but - not in the “generator” section) and wire it to the in and out. Furthermore it is possible to open the plugin and selekt a preset. The knobs are also looking assigned to the plugins functions.

But if I try to send MIDI no sound is played and ModUI crashes/disconnects. After reconnecting to the webinterface the board is empty.

Can I provide more helpfull info or do you have abn idea whats going on?

Regards!
Martin


#48

Hi Martin @lod

thanks for testing! Very strange. I just tested on my adm64 installation of MOD-UI and it works. Must be a problem with compiling the code on the Raspi. I hope I have some time to take a look at this at weekend.

Regards, Holger


#49

Hi!

I can’t find update_zynthian.sh in the recipe folder

Thanks!


#50

Sorry, I think it is beta_update_zynthian.sh ?


#51

Yes, renamed to make clear that it’sbeta…


#52

hi there i have updated as above and now not able to open the standard plugins inside the mod-ui plugin host on zynthian. it freezes when ii select one. ?


#53

The beta-scripts are installing the newest mod-host/mod-ui from moddevices. Both are not running out of the box. I think this may be the problem.

Try to run

rm -rf /zynthian/zynthian-sw/mod-host /zynthian/zynthian-sw/mod-ui
/zynthian/zynthian-recipe/recipe/zynthian-mod-ui.sh
/zynthian/zynthian-recipe/recipe/zynthian-mod-host.sh

I will fix this also in the beta scripts…

Regards, Holger


Obxd midi drop
#54

Hmmm… that’s really bad. If I have some time, I must start the beta-script on my zynthian-edge-image and will look why there are problems. Sorry - currently I cannot help just in time.

Regards, Holger


#55

Great! it worked for me with the latest SD image and utility menu “software update”.

I just had to replace the sh update_zynthian.sh in your original post
with: sh beta_update_zynthian.sh

One note mentioned that it “will take a while” I did not put clock on it, but the installation script execution time was 7-8 hours !!!

Resulting pedal count total: 505

(There are about 9 pedal graphics missing.)

Funny I was just about to install the 25 guitarix plugin archive when I ran across your massive and so easy to use installer. (it would have taken me a lifetime to get all those plugins installed on my own)

Reported ST free space on my 16 gig card after installing on top of a standard image:
SD Card: 81% (12G/15G)


#56

I think replacing update_zynthian.sh is not the best way, because the rest of the Zynthian system does not get updates anymore. So extending the update_zynthian.sh script should be the way. Or you login via ssh and call the beta_update_zynthian.sh by hand…

Regards, Holger


#57

Hi @ssj71

I’ve successfully compiled your nostalgia-inducing lv2 remake of reMID/reSID (https://github.com/ssj71/reMID.lv2) on Zynthian. I’ve even played a few notes through the MOD-interface, but unfortunately the plugin eats up all available CPU.

Do you (or anyone else) know, if there’s any special parameters I need when building the plugin for a Arm-cpu?

Best regards
Ðaniel


#58

Hey great! Thanks!
1 thought is you can reduce the polyphony to something like 4 just to try to keep it down a bit by changing this line: https://github.com/ssj71/reMID.lv2/blob/master/src/remid.ttl#L93

You can try this without needing to recompile or anything, but if its maxing CPU when idle that may not make a difference. Currently there is no optimization turned on at all. You could add -O2 or maybe try -O3 in the complier flags but I haven’t tested these build options and have learned the hard way such things can expose new bugs. If you are game, please do try it and report anything you find. I’d like to shake those bugs out, but won’t have tons of time to try it myself anytime soon.


#59

Cool, thanks!
I’ll look into the polyfony when I get a bit of spare time.
The plugin didn’t max out CPU while idle, but I might try the build optimizations just out of curiousity. Do you prefer bug reports on GitHub, if anything happens?


#60

absolutely! Thanks. :+1: