Buildroot for Zynthian?


#41

waveshare32 doesn’t work.
My screen stays white

more /var/log/Xorg.0.log
[ 3159.292]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[ 3159.292] X Protocol Version 11, Revision 0
[ 3159.292] Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian
[ 3159.292] Current Operating System: Linux zynthian 4.9.59-v7+ #1047 SMP Sun O
ct 29 12:19:23 GMT 2017 armv7l
[ 3159.292] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708
_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=
0x40000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext
4 elevator=deadline fsck.repair=yes rootwait
[ 3159.292] Build Date: 18 October 2017 04:55:30PM
[ 3159.292] xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)

[ 3159.292] Current version of pixman: 0.34.0
[ 3159.292] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 3159.292] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 3159.292] (==) Log file: “/var/log/Xorg.0.log”, Time: Sun Feb 25 08:57:12 201
8
[ 3159.293] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 3159.293] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 3159.294] (==) No Layout section. Using the first Screen section.
[ 3159.294] (==) No screen section available. Using defaults.
[ 3159.294] (
) |–>Screen “Default Screen Section” (0)
[ 3159.294] () | |–>Monitor “”
[ 3159.294] (==) No device specified for screen “Default Screen Section”.
Using the first device section listed.
[ 3159.294] (
) | |–>Device “Display”
[ 3159.294] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 3159.294] (==) Automatically adding devices
[ 3159.294] (==) Automatically enabling devices
[ 3159.294] (==) Automatically adding GPU devices
[ 3159.294] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 3159.294] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 3159.295] Entry deleted from font path.
[ 3159.295] (WW) The directory “/usr/share/fonts/X11/100dpi/” does not exist.
[ 3159.295] Entry deleted from font path.
[ 3159.295] (WW) The directory “/usr/share/fonts/X11/75dpi/” does not exist.
[ 3159.295] Entry deleted from font path.
[ 3159.295] (WW) The directory “/usr/share/fonts/X11/Type1” does not exist.
[ 3159.295] Entry deleted from font path.
[ 3159.295] (WW) The directory “/usr/share/fonts/X11/100dpi” does not exist.
[ 3159.295] Entry deleted from font path.
[ 3159.295] (WW) The directory “/usr/share/fonts/X11/75dpi” does not exist.
[ 3159.295] Entry deleted from font path.
[ 3159.295] (==) FontPath set to:
/usr/share/fonts/X11/misc,
built-ins
[ 3159.295] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 3159.295] (II) The server relies on udev to provide the list of input devices
.
If no devices become available, reconfigure udev or disable AutoAddDevic
es.
[ 3159.295] (II) Loader magic: 0x1fbf40
[ 3159.295] (II) Module ABI versions:
[ 3159.295] X.Org ANSI C Emulation: 0.4
[ 3159.295] X.Org Video Driver: 23.0
[ 3159.295] X.Org XInput driver : 24.1
[ 3159.295] X.Org Server Extension : 10.0
[ 3159.297] (++) using VT number 3

[ 3159.297] (II) systemd-logind: logind integration requires -keeptty and -keep
tty was not provided, disabling logind integration
[ 3159.297] (II) no primary bus or device found
[ 3159.297] (II) LoadModule: “glx”
[ 3159.298] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 3159.302] (II) Module glx: vendor=“X.Org Foundation”
[ 3159.302] compiled for 1.19.2, module version = 1.0.0
[ 3159.302] ABI class: X.Org Server Extension, version 10.0
[ 3159.302] (II) LoadModule: “fbdev”
[ 3159.303] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 3159.303] (II) Module fbdev: vendor=“X.Org Foundation”
[ 3159.303] compiled for 1.19.0, module version = 0.4.4
[ 3159.303] Module class: X.Org Video Driver
[ 3159.303] ABI class: X.Org Video Driver, version 23.0
[ 3159.303] (II) FBDEV: driver for framebuffer: fbdev
[ 3159.306] (WW) Falling back to old probe method for fbdev
[ 3159.306] (II) Loading sub module “fbdevhw”
[ 3159.306] (II) LoadModule: “fbdevhw”
[ 3159.306] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 3159.307] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 3159.307] compiled for 1.19.2, module version = 0.0.2
[ 3159.307] ABI class: X.Org Video Driver, version 23.0
[ 3159.307] (EE) open /dev/fb1: No such file or directory
[ 3159.307] (EE) No devices detected.
[ 3159.307] (EE)
Fatal server error:
[ 3159.307] (EE) no screens found(EE)
[ 3159.307] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 3159.307] (EE) Please also check the log file at “/var/log/Xorg.0.log” for ad
ditional information.
[ 3159.307] (EE)
[ 3159.313] (EE) Server terminated with error (1). Closing log file.
pi@zynthian:/zynthian/zynthian-sys/sbin $

*** /etc/X11/xorg.conf.d: directory ***

pi@zynthian:/zynthian/zynthian-sys/sbin $ more /usr/share/X11/xorg.conf.d

*** /usr/share/X11/xorg.conf.d: directory ***

pi@zynthian:/zynthian/zynthian-sys/sbin $


#42

Please open this stuff in a github issue here.
Its really hard to keep conversations here. And it fills the thread.
@jofemodo Any ideas?


#43

Also, had some progress in qemu, didn’t push yet, but there is an armv7 kernel out there. You can follow talks here:


#44

Hmmm… strange. Yesterday I tried and started an engine. After some played keys the system freezes. I restarted and than it worked. Until now I cannot reproduce this problem. :roll_eyes:

Regards, Holger


#45

So I created a hotspot module. We could now make zynthian start a hotspot that lets you connect and set it up when it fails to connect to wifi.
Just the sort of things that can be extended now.


Question about security in Webconf
#46

please make a topic in webconf and tell me what has to be done to change the name and turn it on and off.
The show stopper for me is the failing Pianoteq engine btw.


#47

New Raspberrypi released today! 3 B+
And you know what is cool with CustomPiOS?
That I can build a nightly which can supports it by the end of the day :slight_smile:


#48

I think it’s the same architecture as the “normal” RPi3. So IMHO no special optimizations are needed, or?


#49

Not that I know of.
However any images prior to the one released today would not work according to the image released today.
And they changed behavior of the wifi firmware changes.
See the release notes.
We are quite used in OctoPi that when a new Pi is released, since the Rpi Foundation does not release any release candidates, bugs are discovered in our nighties.


#50

@guysoft

There’s a problem building ZynthianOS (related to the compiler errors):

zynthian_envars.sh: model=cat /sys/firmware/devicetree/base/model 2>/dev/null`

In the env system of Zynthian it tries to detect the used model (RPi2 or 3). But in the qemu environment this can’t be done:

/bin/cat: /sys/firmware/devicetree/base/model: No such file or directory

So the compiler flags for the RPi2 are used as default. I changed the default to use the RPi3 flags - but the problem is the automatic detection inside zynthian_envars.sh. I have not much clues about CustoPiOS/ZynthianOS, so I have no idea how to fix it…

Regards, Holger


#51

New image:
http://unofficialpi.org/Distros/ZynthianOS/nightly/2018-03-16_2018-03-13-zynthianos-stretch-lite-0.1.zip
Md5: bc0b2dc38368ab1e9b0a016367c86d7e

Effected by: https://github.com/zynthian/zynthian-sys/issues/39

Will not have Realtime until this is fixed: https://github.com/guysoft/RealtimePi/issues/9


#52
  1. Can you link to where you changed it?
  2. @jofemodo is there a point to build Zynthian for anything other than arm64?

#53

I changed /zynthian/zynthian-sys/zynthian_envars.sh (line 79) to:

    CPU="-mcpu=cortex-a53"
    FPU="-mfpu=neon-fp-armv8 -mneon-for-64bits"
    model=`cat /sys/firmware/devicetree/base/model 2>/dev/null`
    if [[ ${model} =~ [2] ]]; then
            CPU="-mcpu=cortex-a7 -mthumb"
            FPU="-mfpu=neon-vfpv4"
    fi

So the default are the flags for RPi3, no matter if the cat ... works or not.

Regards, Holger


#54

Ok, thanks but please link the commits when you post this stuff, because I wanted to know both when and where :slight_smile:

Moreover, when you say “I changed”, where did you actually change it? The file in git was not edited the last 3 months:


#55

I changed this in my personal repo - and havn’t committed yet… so the only way was to explain this via forum-thread :wink:


#56

You can also link to your branch :wink:
For example, I have this one: https://github.com/guysoft/zynthian-sys/tree/realtimepi-test

I admit I am not sure how you guys worked until now, and I don’t want to impose order, but suggestions kinda pop up to me. So please say if you want to adopt something or not, or want me to say less.


#57

When there is gihub task, i start the comment with # < no > . Easy and i like to keep it that way.
I don’t want to link with this forum


#58

i tried to make your build run.

  1. Still an internal 500 error when webconf is called.
  2. When I tried to look at it:
    ssh pi@zynthian.local
    ssh: connect to host zynthian.local port 22: Connection refused

But hey, at least I got a ping :slight_smile:


#59

I think there is a bug that ssh works only on second boot (only when hotspot module is enabled, so I need to debug the hotspot module and find which line causes that). Would be nice if you can confirm that.


#60

yes, I could get in the second time.