Cannot boot on Raspberry Pi 400 - PiSound

I’ve been using a vpc1 + pianoteq setup on a Pi400 and Pisound for a while with no issues.

I’ve been trying to boot Zynthian to test and consider using it as a mani build fo rmore flexibility, but cannot seem to even boot it.

After burning the img, and booting, I just see a flash of text, then goes black and nothing.

Tried taking out the Pisound, as it was flashing 2 red leds ( not quite sure what those are :(… ) And still the same issue.

CHanging the config option on the htmi to for mode 16 also make no difference ( texted on my samsung g9, older hd screen and oled tv. Still the same behaviour.

Tried commentting off additional hardware and sound card, and still always the same behaviour.

I don’t think it is booting, even though it shows up on my network as zynthian. But nothing on screen, and nothing on .local or the machine’s ip.

Any ideas on what else to try?

I have an older Rpi3 around somewhere which I’ll test as well once i can find it :face_exhaling:

EDIT: ALso commented the display config options, to make sure it wasn’t trying to set the zynthian’s touchscreen. ALso no change :smiling_face_with_tear:.

Display Config


You should leave it for some time after first boot until it completes its setup and reboots then connect to webconf and change settings. If I get a chance I will try with my Pi 400.


I was reported similarly issue with raspberry 400 and Pisound. I’ve never run this combo. I replaced Pisound with USB Behringer.

hi @alfatreze welcome in Zynthian’s Exotic World :wink:

It’s a bit unclear. When you talk about changing config, how do you do that ?
If it’s via webconf, that means that thz underlying Linux system is up and running wich is a good news.

could you elaborate (webconf, ssh, router info …)?

Also, @riban recommendation is highly accurate, be patient on first boot …

When I mean changing config it’s directly on the SD cards config.txt file.

It doesn’t really seem it’s a waiting problem, though I could be worng, because right after booting, I just see a quick flash of text, less than a second, then it just stops displaying anything. Hence I was fiddling with display output options.

For the webconf access, I tried waiting between 5 to 50 min or more) but could never access this. I’ve connected the pi directly to my router and checked the ip. I couldn’t access with either zynthian.local or with the direct ip address.

I might look at the config.txt in another distro and just check things, maybe I´ll find something.

SOme of what i tried to do with zynthian, was to keep the pisound disconnected for now, try to force set a specific HDMI output, and comment the bits in the config related to the zynthian screen, rotation, etc, as well as the extra hardware (i2c, etc).

NOne was any help.

I’ll do another round of trial, and maybe also try an older build, and will post results and the file with my specific config.

For what I’ve read the pi400 should be supported, so I’m trying to get it to work at first with just that.

Looking at this guide, No Hardware Build - ZynthianWiki it should be really simple. Only thing I’m not doing is connecting the headphones, as there’s no audio jack on the pi.

does it respond to a ping ?

It looks like your software setup is broken.

I think the best is to burn a new image and try again. Even with more or less exotic hardware, everything regarding setup could be done through webconf. You shouldn’t have to edit config.txt by hand.

Good luck.


Finally was able to make this work.

Burning the card with Etcher on windows, I was finally able to boot form it properly and access the web config.

Previously doing it on my mac M1, while it did start the boot, the splashscreen never showed or any of the boot messages or thw web ui. Which was confounding me to hell.

I was able to setup most things as dummy and select my pisound, but I still getting a continuous ui reboot. Where the ui wiuld crash, show the console with login for a sec, then splash “loading ui” then boot the ui proper. After a couple of seconds would restart and keep on this.

I tried plugging and unplugging multiple times with no luck. I ended up. updating through the web conf, setting the profile as default, wiring as dummies and generic screen. After unplugging for a couple of hours and going for lunch after turning it back on it´s now working.

Quite temperamental I must say. Might do this a few more times with different cards and see if i can identify what the issue might have been.

In conclusion:

  • If booting it doesn’t show the zynthian spalsh, try burning again. New card, software, computer whatever. Just as long as it shows that splash :D.
  • If having reboots, try to make sure stuff is well configured and just in case leave it for a while before trying again :P.

Now to test the hell out of it and see if I’ll go for the harware build :smiley:

Thanks guys for the help :sunglasses:

1 Like

Excellent :+1: