Can't midi thru - beatstep master usb -> zynthian -> midi keyboard slave usb (no sync)

Hi, I’ve experimented and searched the forum but I can’t seem to configure my zynthian install (raspberry pi only no hardware kit) to send midi thru from the beatstep as master. All the devices are via usb midi connections. Maybe I’m missing something simple but it just doesn’t want to sync. The mpk keyboard won’t pick up clock from the beatstep so there’s no arp available on the keyboard. I also tried a keystep and same problem.

Can anyone offer some pointers on what to try?

1 Like

Hi @LFO!

Great to welcome you to the community. I hope you will have fun here

Have you enabled MIDI Output in webconf? This enables the MIDI through type functionality. I think it may also be an option in the admin menu but I am traveling today so unable to check.

1 Like

Thanks Riban

Is this the setting you mean?


I can see the midi clock being sent from the beatstep in the midi log but the mpk doesn’t accept it so far.

Yes, that is the setting. Are you using the latest release (2306) and fully updated?

I ran the update again, I think it’s saying it’s already up to date. Not sure where to find the actual version though.


In Software->Repositories check Advanced View.
Then select staging-2305 for every repo.

And you’ll be in the latest stable release.

You are already on the latest, fully updated stable. That is fine. I will look. I know we worked on MIDI clock and routing recently so maybe we block the clock being passed through. Let me check…

1 Like

I have enabled “Route MIDI to Output Ports” and system messages (CLOCK, CONTINUE, etc.) are being forwarded from the Zynthian MIDI input (5-pin DIN) to Zynthian MIDI output (5-pin DIN). Let me try with USB MIDI…

[Edit] Clock is sent to USB MIDI output.
[Edit] Clock is received from USB MIDI input.

We need to better understand what you are trying to do and what is not working.

1 Like

I’m hoping to use the beatstep as the master clock and zynthian can be a midi host to pass the midi clock through to the mpk or keystep keyboard. Then the arpeggiator or sequencer can be used.

The beatstep is sending out as shown in the screenshot. But it doesn’t send out on any of these ports when I check the midi log (2nd screenshot).


Hmm… this should work. I have MIDI clock entering a Zynthian (5-pin DIN or USB MIDI) and leaving Zynthian (5-pin DIN and USB MIDI) which is what I think you want here.

I have found an issue that enabling a MIDI output in webconf does not seem to apply until after a restart, e.g.

I tried doing as you suggest, set the midi outs then save and reboot. It still doesn’t want to work.

This time I tried making the keystep the master clock. I notice that the clock is coming out of the keystep (and beatstep) but when I check the master midi out, there are only CC and note on/off messages.

So technically I’m getting midi out but it’s not passing the clock for some reason.

You need to enable “Enable System Messages (Transport)”.

It was already on but I rebooted anyway and checked again. It’s still on and not sending clock.


hi @LFO, welcome.

don’t give up. You’ll ended to find the good way to go with your Zynthian personnal setup. It’s a Swiss army knife for doing “YOUR” music.

Okay - is there a blue line under the heart at the top right of the screen? When MIDI is received a blue ‘m’ should show briefly and when MIDI clock is received a blue line below this should show.

Will you then please try to enable Zynthian to send MIDI clock:

  • Go to sequencer
  • Access menu
  • Select Tempo
  • Set clock source to Internal send

Then start a sequence playing by pressing on a zynpad pad. (It can be empty.)

Check whether MIDI clock is sent from the Zynthian.

1 Like

I wasn’t aware of the blue line under the ‘m’ to show clock. I can see that line when I start playing arps with the keystep as master.

I tried this setting: in the zythian sequencer the clock is changed to internal send. When launching a sequence, I can also see the blue line under the M. I rebooted after this change to be sure then checked the midi log again and unfortunately I still can’t see any midi clock going out.

If I have an internal sequence running, what channel should I see the output?

1 Like

Thanks LE, don’t worry, this won’t scare me away. I have enjoyed using zynthian so far and hope to contribute in some way (like midi troubleshooting on the wiki :laughing:).

The content (note on/off commands) of a sequence are sent on the MIDI channel that the sequence is configured for. By default zynpad has a 4 columns of sequences with each column on MIDI channel 1, 2, 3 & 10. The MIDI clock is a system message so does not have a channel.

This is my MIDI config with MIDI clock thru working:

1 Like

Ensure the target device is enabled in the list of MIDI devices. I have seen in the past a device become unselected so double check the destination is selected. I have also seen that changes here don’t always take immediate effect so may require a restart and check the values after a restart and a refresh of the webconf page.

Also check in Zynthian UI Admin menu that “Bridge MIDI-OUT” and “MIDI System Messages” are enabled. These are the same parameters as shown in webconf so they should follow them. Toggling either of these in Admin menu seems to work immediately (no save, no restart required). I only see MIDI clock passed thru when both of these are enabled.

1 Like