Connect Zynthian 4.1 with Arturia Beatstep Pro - MIDI/CV


How to connect the Zynthian with the Arturia beatstep pro via MIDI or CV?
So, probably the MIDI-way is easiest to connect: ARTURIA MIDI OUT = > ZYNTHIAN MIDI IN.
And how to connect the Zynthian trough the Arturia’s CV outputs? New interface needed for the Zynthian?


Theoretically you could do it with the analogue expander.

BUT, I have to question why - I’m using a Keystep Pro and anything I could achieve with CV can be done over MIDI; the CV is more useful for matching MIDI and analogue transitions on an external synth like the Neutron.

IIRC the Beatstep is similar - any controller or sequence can come out of a MIDI port and channel as desired.

Unless you’re using the Beatstep with a DAW and need the USB port, the easiest thing is to just plug in the USB.

Hi Richard, i just wanted to use the default drum gates output on the Arturia…
So, as a MIDI-Zynthian newbie i just need to connect it via MIDI and reconfigure the Arturia?

That would be the easiest - but also for drum gates, there may be an easier circuit to use to interface with the expanded module. The Keystep Pro worked right away on USB for me, and I could assign tracks to MIDI channels and have some pretty complex sequences (and layers) going with minimal hassle or research (some aspects of Zynthian are very intuitive).

Basically to use any CV stuff with Zynthian, you need to make some new interfaces or grab existing MIDI/CV conversion tools. Ultimately all that the Zynthian is going to do with CV values is convert it to MIDI to use anyway.

1 Like

Ok, thanx for helping me out Richard!

When i connect Arturia via USB and set seq 1 and seq 2 on different MIDI channels (1+2) the Zynthian plays both channels on one layer/channel. MIDI logs on the Zynthian shows the Arturia is sending on channel 1 + 2…

Please help! :slight_smile:

You have to disable “Single Channel Mode” in the Admin menu.

1 Like

When “Single channel mode” is disabled the device become multitimbral. Maybe we should change the name of this setting and perhaps change default (out of the box) to enable multitimbral mode.

1 Like

A lifesaver… thanx!