Corrupted latest stable image issue?

Hi all! I am new to the community and was trying to use Zynthian OS for a project. However even though I tried several different times downloading the latest stable version and some previous version and got corrupted files. I checked with md5 file to see the hashnumbers matching and each time the different image files showed same number but not matching up with the corresponding md5 file hashnumber. What could be the issue?

Also I could burn the image into an sd card but the raspberry pi wouldnt install/load the OS. It throws an error of :

---[ end Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

Hi @hero04

Good to see you here. I hope we can sort this and get you enjoying Zynthian and hopefully this community.

It looks like you are not able to flash a valid image to SD card. This often caused by the program used to flash the image. I now use Raspberry Pi Imager which works every time for me.

It looks like your download is failing. You should end up with an image that is 11.8GB. (It is big!) That should validate with the md-sum so if that is failing then you may be having interrupted download. Unfortunately we don’t have a minimal image so you need to be able to download that massive image successfully.

Hey, thanks for the response. I do have downloaded a 7gb or so zip file which eventually takes 12 gb or so like you said. But the latest version is not matching with its own md5 file. Also the other versions are not matching with their own md5 files. However we did download from another computer and the results were same. I even tried to install debian to rpi and then follow the commands on github page to install the zynthian os. But stuck at the last 2 lines. It gave an error of “cant execute binary files” or something like that.

ok, just redownloaded the last stable version and the cheksum of the zip file matched with the md5 file. however after burning the image into the sd card it still gives same “end Kernel panic …” error.

Please post the actual link you are downloading the image from, the application used to flash the image to SD, the operating system and what physical interface are you using to connect the SD card?

https://os.zynthian.org/ from this page via this link : https://os.zynthian.org/zynthianos-last-stable.zip

to flash the sd card used, raspberry pi imager, wind32 disk imager and USBit. All gave same error.

the sd card flashed in windows pc, connected to the pc via sd card adapter.

edit: also checked the image itself and md5 hashnumber is not matching up with the md5 checksum file. Also downloaded images on another pc and results are same.

FYI, the MD5 hash is from the zipped file.

Thanks!

ok, then no issues with the hash number matchings. However the end kernel panic… error remains same :frowning:

finally got some improvements on installing the os. used different rpi and different sd card, now its trying to install but after some time it gets zynthian login state and flashes the screen. I mean screen goes on and off repeatedly and it doesnt accept “pi” and “raspberry” credentials for zynthian login.

If you don’t have an official kit then you are going to have to connect to Zynthian via webconf and configure its hardware.

Yeah, i also figured that but it doesnt open browser interface when i go to its ip address. But just realized its ip address was different than what os shows on the screen. Thanks again for the help! I appreciate it.