Failed starting software [solved]


#21

What is in waveshare32b?


#22

waveshare32b is the driver you have to put in /boot/overlays
It looks like you did not put it there?
Time to read http://www.waveshare.com/wiki/3.2inch_RPi_LCD_(B)
or place This file in /boot/overlays


#23

Hi Kees,

I give up for now. I have ordered a pitft so there wont be any problems anymore. My raspbian skills are not sufficient to solve this problem. I can use the LCD for some other project like a Retropie. In that project it will work. Thanks for all your help.

Best regards, Pim.


#24

Ok, good luck with the PITFT. Else, if you are ever in the Breda area, you can pay me a visit…


#25

Thanks for the info, i´m interesting on this lcd, i buy on ebay, i hope that work fine! :slight_smile:


#26

Thanks Kees, i’ll keep it in mind.
The PiTft clone arrived today. I plugged it in and there was something happening, but not what i expected. I wrote a clean image on my sd and tried again. Now everything is ok. Zynthians splashscreen and menu are now on my screen. Now i am going to build the rest. Thanks for all your help.

Regards, Pim.


#27

Hola, ya tengo el Lcd waveshell 3.2, he usado el driver waveshare32b.dtbo en
/boot/overlays y editado el config.txt tal como recomienda Keeze101, y al arrancar aparece el logo Zynthian, luego pantalla en negro, pantalla en banco y ahi se queda, en pantalla en balco, alguna sugerencia? gracias!.

Hi, I already have the Lcd waveshell 3.2, I have used the waveshare32b.dtbo driver in /boot/overlays and edited the config.txt as recommended by Keeze101, and at boot time appears the logo Zynthian, then black screen, screen at Bank and there remains, on display in balco, any suggestions? Thank you!.


#28

Did you also rewire the controllers and used the right hw-version? Did you login to the box and started the software manualy and looked at the ouput?


#29

Disculpa, he usado una raspberry pi 2 con el lcd waveshell conectado directamente para probar y ocurre lo descrito, al arrancar aparece el logo de zynthian, luego pantalla en negro y posteriormente blanco y ahi se queda. Lo de recablear el driver no comprendo a que se refiere, aclaro que tengo muy poca experiencia en linux, gracias.

Sorry, I used a raspberry pi 2 with the waveshell directly connected to test lcd and occurs as described, at boot time appears the logo of zynthian, then screen in black and white then and there goes. The rewire the driver I do not understand that refers, let me clarify that I have very little experience in linux, thank you.


#30

Hi @mesathlon!

Try to run the zynthian GUI from the command line:

# systemctl stop zynthian
# /zynthian/zynthian-sys/sbin/zynthian.sh

Perhaps you see something interesting there :wink:
Also, confirm that your waveshell display is configured as framebuffer 1: /dev/fb1

Suerte!


#31

Gracias,me no se ahora mismo como hacer eso, pero investigaré un poco a ver si lo consigo jeje


#32

No es difícil. Tan solo logate con SSH y trastea un poco desde la consola. En la wiki está explicado como debe hacerse :wink:


#33

perfect!! thanks;)
¡¡Perfecto!! Gracias;)


#34

Bueno ahora me aparece zynthian error en pantalla tras cargar. comentar que tengo conectada solamente el lcd a la rp2 sin los encoders.
He de cambiar algo en la configuracion como comenta keeze101?

Ok, because I use a different lcd screen (waveshare 3.2"), the wiring is also different. I had to rewire pins 2, 3 and 4 of controller 2 to another location. I used 18, 22 and 28 of the PI and created my own HW-version :slight_smile:
All seems to work now! Time for some sleep and see if I can get some sound tomorrow!
Podria alguien orientarme que es lo que tengo que hacer con esto y como ? gracias de antemano, un saludo.


#35

Hi @mesathlon!

What audio interface are you using? Remember that the RBPi native “audio interface” doesn’t work. You need a decent DAC for running jack audio.

Regards!


#36

Hi, Yes i used a Pifi dac+ , But I can not get it to work, when I finish booting shows zynthian logo and the word error :frowning:


#37

Hi @mesathlon!

Could you give more details?
Have you checked that the Pifi DAC+ driver is correctly loaded and that jack server is running? etc.

Regards!


#38

Also check the pin use of all your components and make a scheme and the right HW-version… That what was causing the same error message over here in the beginning…

If you are not familiaire with that all, perhaps it is better to use the recommended parts, so the stock setup works…


#39

Hello,
I have the same layout. Dac+ Pro and on top a 3.2 waveshare32.
No additional zynthian controllers/knobs yet.
But the waveshare has 3 buttons already.

This is the error message, i get in an endless loop when I call
/zynthian/zynthian-sys/sbin/zynthian.sh

INFO:root:HW version PROTOTYPE-4
Zynswitches poll thread created successfully
INFO:root:SWITCHES INIT…
INFO:root:SETUP GPIO SWITCH 0 => 107
INFO:root:SETUP GPIO SWITCH 1 => 23
INFO:root:SETUP GPIO SWITCH 2 => 106
gpio: Unable to open GPIO direction interface for pin 27: No such file or directory
wiringPiISR: unable to open /sys/class/gpio/gpio27/value: No such file or directory

He finds those three buttons on the screen and cant handle them?

Kind regards,
Markus


#40

Hi @mheidt!

First, you have to reconfigure your wiring layout. There is no autodetection. You have to specify the assigned pins for switches and encoders. If some of the pins already configured is in use (like it seems to be the case), then you have problems like this. Do you know what pins are used by the WaveShare32 touch interface? And by the WS32 switches?

If you want to use a “non official” setup, you will have to tweak a little bit the things :wink:

Regards!