FluidSynth broken

Could please somebody try the following to prove to @jofemodo that this bug is the most important one?

Take the latest image (2020-01-15) and try to create a FluidSynth layer with the GM soundfont.
The bank/sound screens won’t show.

I tried on two different machines. V2 kit and a V1.

Yep confirmed at least as far as the GUI goes.

I try to load Fluid GM (zynthian-ceed.local) , doesn’t do it but comes through to

Which I can use to remote control a fluidsynth patch elsewhere that does reliably load on machine startup.

Engine generation snapshot somewhere…?

Yep I can’t load a new engine Fluid GM engine on the remote machine ( zynthan-amp2.local)

That’s as far as I get as I’m a Teletubbyzurückwinker . . . .

1 Like

@riban, as you outed yourself as fluidsynth champion…could you please have a look?

The first click on the file is dead. The second displays the screen @wyleu posted

Damn! I should have kept my head down :slight_smile:

Sorry - I can’t reproduce this. Can you give step-by-step instructions on how to reproduce?

I used a Raspi3.
Install 2020-01-15 buster
Create FS layer on channel 1

When you try to select the sf2 file, the click is dead.
When you click on a different file it’s dead also.
When you click second time on file, the screen shown above is displayed.
No program selection screen was shown.

I am going to test it on my Raspi4 tonight.

I could reproduce in a fresh Buster, but then, after updating & rebooting, the error has gone.
I would check again …


Nothing. I reflashed and tested again, but nothing. It’s a slippery bug … ;-(

yes, it’s slippery.
But although I updated a lot, it fails in 90% of the cases on both of my machines.

I am testing on RPi4 and can’t reproduce… until now!!! Just happened.

I just returned to my studio to see Zynthian running on its own touchscreen as well as on my laptop’s Xserver which might explain this behaviour, i.e. two instances of zynthain running on same Raspberry Pi 4. Could this be the same issue for you?

no, i was testing on two Raspi3.

I mean, could it be that a second instance of Zynthian somehow got started. Maybe next time it happens, check how many are running.

Au contraire.
The fluidsynth process starts and after a second it’s already gone.

Not Fluidsynth - are there two instances of Zynthian?

I’ve got only one zynthian instance on a 3B+ on a machine that exhibits the behaviour.

journalctl -f is having a whinge . . .

I think the error is caused by a memory leak on fluidsynth code, probably introduced on v2.1.0.
I opened an issue:

Until it’s solved, i’ve modified the install script for using v2.0.9. Please, re-build your fluidsynth and check if problem has gone …



1 Like

This could be related with other fluidsynth recent & strange problems, like:

FluidSynth Output is Hopping Around Channels L and R


Zynthian changes all Soundfonts in multiple FluidSynth Instances


I can confirm, that at the first few bootups this works with fluidsynth 2.09

Thank you!



After some more testing, I’m sad to say that the problem

still persists.

I can not get fluidsynth to load to soundfonts in two instances seperatly. Sigh.