Help a newb? My MIDI in port lights up, doesn't seem to transmit MIDI to synth layers

Got it - (the V3 kit from Zynthian that is, the one with no soldering) - built it, tested it - audio out, audio in, and MIDI over USB all work - BUT! MIDI over standard midi DIN does not work! The LED lights up indicating there is MIDI being recieved… all three of the MIDI IN, THRU, OUT are firmly attached in the correct places, the LEDs are connected in the correct polarity… am I missing something?

I am absolutely not a programmer - so if you suggest looking at script I will likely die. I;m assuming it must be something pretty simple - tutorials show it working pretty much out of the box. ALSO, I have no Idea if the MIDI out or thru ports are working, I haven’t gotten that far!


THere has been some debate concerning the MIDI schematics for the zynth…
Presumably you’ve had a look at ?

I assume you are working with this circuit. You say you find code intimidating, but don’t worry I doubt there is any code involved in this issue, as code can only do what the hardware lets it, and the likelihood is your problem is hardware. . .

Firstly do you have any way of checking electrical connections like a multimeter? That would certainly help because although it’s a good visual inspection will often reveal problems there real proof is finding out where electrons actually go in a circuit. It’s not difficult to get a tiny piece of dirt or grease on the point where two metal surfaces meet which prevents electrons crossing the gap and that’s all that’s needed, but these sorts of things are really only an issue when you start cos once it works it tends to stay working. . .

So with that in mind lets look at the circuit.
MIDI IN is the one that needs the most protection from dangerous conditions as it’s really nothing more than a sensitive electrical input, and with the likes of those ghastly ham fisted radio gorilla’s around it’s perfectly possible that some unpleasant voltage will get plugged into a circuit destroying the sensitive and sometimes expensive components. We also don’t want a direct electrical connection between those horrible voltages and our circuit because that can produce hum, for various reasons I won’t go into, or can in really horrible circumstances give people significant electric shocks if other kit is miswired, so the people that designed MIDI included the opto isolator to address this. Its the H11L1 chip and it is as it’s picture describes a little LED next to Light sensitive component. notice that there is no electrical connection between the circuit input side ( the Left) and the bit that does the switching ( the right). ie. isolation !

You say the LED does work. Well that great cos it means a fair bit of the circuit is ok.
The LED is connected between pins 1 & 2 and as is said on the thread I pointed to it’s actually part of the circuit.


The MIDI in ‘signal’ comes in at pins 3 & 4 and thats probably not the best way to think of it. Rather it’s more like a switch that is connected between those pins and it closes to send one binary signal and remains open to send the other which is connected to the source of electrons in the device that is transmitting the MIDI . In effect it’s shorted out, and the current, when the LED is on comes from the MIDI device’s MIDI out socket.

So we prboably assume that R1 and the Diode D1 ( which is there to prevent problems if the MIDI signal coming in is connected the wrong way round, a common mistake). Now it is possible that you have both the MIDI in connection the 'wrong way ’ up AND your LED might be the wrong way round so that’s worth checking. You don’t say what you are using as a MIDI source but if it’s something commercial it’s probably ok, but worth thinking about.

From here on in it’s really about connections. if you have got a multimeter check the connection through to the pins on the Opto Isolator and make sure there are actual electrical connections because that would mean the LED could light but electrons are not flowing thro’u the opo’s LED so nothing will happen.

ON the other side of the opto we could also have problems of lack of connection. The electronics don’t care they only do what electrons want to do. You might have a dead opto isolator, and that you can’t rally tell without testing it or substituting another part, or there might be a dry solder joint ( a connection that looks dull rather than shiny and doesn’t look like the solder flowed properly) that doesn’t conduct, or ,and most people have done this at least once, an IC pin is folded up under the body of the chip and doesn’t actually go into the hole or the socket that is’ meant to.
A careful inspection with a magnifying glass will often reveal this sort of thing, and if it’s a dry joint, a dab with a soldering iron will sort it out.
Again if you have a multimeter check that there is 5V on pin 6. if the capacitor C1 or REsistor R3 were short circuited ( not very likely but … ) then the chip wouldn’t work,

if you have spare LED and resistor you could use that to check to see if there is a signal ( LED on & off ) at pin 4.

And finally there are the ribbon connectors. THE MIDI IN signal isn’t actually handled by other chips on the xynaptik board it is transfered directly to pins on the Raspberry Pi itself (pin 10 on the Pi connector). again if you have a multimeter check the continuity to the pin on the Pi ( this can be a bit hard to do as you really need to work out whichpin is pin 10 and the nmake an electrical connection to it. But ribbon connector connections are at the root of many electrical problems and it’s possible that the ribbon connector doesnt make a connection for some reason or other. They are amaxingly good and have been improved ver years but it’s still 40 parralle electrical connections and it doesn’t need much to stop one connector working.
Do all your encoders work? It’s posible to offset a ribbon connector by one pin or miss an entire row when plugging it together. Again a good inspection assuming things are wrong will often show something up.

This is very long lump of information and doesn’t specifically indicate a direct fix, but it hopefully will give you some things to investigate to address this problem. Photo’s are also a great help, if nothing more than confirming the overall health of the components ( Oh i didn’t realise that big crack on the board might be a problem sort of thing )
Take a photo and if you can get it onto the computer you browse this thread with and just drag and drop it int the thread will allow us to see what’s going on.

So in summary

  1. Photos
  2. Visually Check ribbon cables
  3. Visually check circuit board
  4. IF you’ve got a multimeter check continuity and Power on pins.
1 Like

Hamlet (holding a skull in his hand) : where do electrons go ? Where do they not go ? That is the question…
(Shakespeare, 1609)

1 Like

opus, Ophelia. . . . . Yeah close enough . . .

heads of to stage ‘unfortunate’ accident involving @opus.quatre, a handy river and a large oar . . .

1 Like

Oar ? Olympic Athlet from Russia ?

No, big thing found on boats for gently sculling down the river and smacking swans on the head . . .

1 Like

Skulling down the river… I see…

But am I not getting a little bit off topic ? Slightly… almost un-noticeably…


Go in to the Admin menu and stick the zynth in “Single Channel Mode” and see if that works.

1 Like

Hi @steveheyerdahl!

First, try with the webconf’s MIDI log tool:

  • Connect your zynthian to your router/network
  • Access the webconf at http://zynthian.local, or using the IP you can get from the UI’s Admin menu (network info).
  • Go to Interface->MIDI log
  • With your MIDI device connected to the MIDI-IN, push some notes. You should see the events flowing into the log. If not, try selecting “MIDI-IN” in the top-left select box.
  • If you see the events, send a screenshot.

If no luck, then, please double check the wiring from the MIDI connectors to the Zynaptik module. MIDI-IN connector should be connected to the MIDI-IN, etc. Try unplugging the connectors and checking if all the wires are OK and all of them are soldered to the MIDI connector, etc. Also, send a photo, as good and detailed as you can.

You can also try swapping 2 MIDI connectors (i.e MIDI-IN and MIDI-OUT), to see if it’s a wiring issue.

BTW, what SD image are you using? Could you send a screenshot from the webconf’s dashboard?

Thanks … and good luck!

Hey everyone - thank you so much for your (sometimes very detailed!) responses - I am even less a hardware wiring guy than a coder! THat being said, since this was a straightforward build, no soldering, etc, I figured it would be within my abilities. …

I started with the easiest troubleshooting that was suggested - I switched the cidi in fir the midi thru connector, swapped it on the connector on the board - and voila! sound! So I switched back and there it was, the midi in now worked like it should. So I shut the case, and no sound! I opened it, and there was sound, I half way shut the case - no sound - I visually checked the connections, everything in order, I used my fingers to snug up anything that may have been loose, but everything seemed tight - this time though, when closing the case, it still worked - and it is still working! So far so good!

The SD image I’m using is the one on the Zynthian wiki page - Download Zynthian “Aruk RC-3” SD-image - I tried updating the firmware from the zynthian.local screen - and it went along for a time then stopped - the screen was blank - so basically it got bricked, or something like that - I had to re-flash the SD card, and that is where I am now.

I picked this up because I was really interested in the Zoia, the MOD duo, and the Organelle - and the Zynthian seemed like a similar device/platform. The main difference, as far as I can tell, is that there are FAR more tutorials for those other devices - I would be very obliged if you could point me to a good resource for getting to know my way around the Zynthian - so far all I can do is load up and use 1 layer at a time - the effects, or the synth. I know there are far greater capabilities!

Thank you again

Please use an image from

@jofemodo, why don’t we change the wiki?

1 Like

oh ok - I see there is a whole list - is there a big difference? I see the more stable ones are listed RC1, etc… and they’re quite a bit older - and again I’m showing how little I know Linux - there are .zip and .zip.mp5 files - which one would I want?

The latest zip. If there are issues, tell us, so that we can move it.

To learn your way around the Zynthian, check out the Zynthian wiki. It contains a User’s Guide and many other resources and links to help you.

Hi @steveheyerdahl I’m new here too, and I build the V3 Kit just like you, after hesitating about going Organelle (yes you’ve got it’ just like you!)…well don’t worry there’s always someone here to help you out.
Maybe in your case you can ask @jofemodo to link you the latest image (I had one last week, I only just started my Zynthian project just like you :stuck_out_tongue_winking_eye:).
I had some trouble with the Aruk RC -3 and the latest image solved that bit.
Zynthian is amazing, very versatile and in perpetual evolution, I really love it.

1 Like

this was](

never goes past this screen.

On a fresh image I usually let it sit for at least 10 minutes while it expands the file system etc on the SD Card. It eventually reboots and the the error goes away.

The nightly builds are sometimes “unstable” or broken. You can try
This worked for vincent too.

You have to plug an Ethernet cable between zynthian and your router. Zynthian should show you its ip address. Point your web browser to that address, you will be asked for a password which is raspberry. Then in the hardware menu, check that the right kit is selected.

I refreshed the SD card, and let it sit over an hour. Still on the error screen

I admit, I think I may have chosen this product mistakenly - I am not a technical person and troubleshooting software/hardware destroys my ability to be creative