How to configure latest stable for V2 Kit

after a long absense I’m trying to install latest stable image on my official kit V2 with PiScreen 3.5 bougt back in 2018.

here’s from the order receipt:

  • Aluminum Case Kit v2
  • 4 x Controller Module Kit v2
  • All-In-One Module Kit
  • Ribbon Bus cable v2
  • Wiring Kit v2
  • RaspBerry Pi3 (computer board)
  • HifiBerry DAC+ Kit (soundcard)
  • OzzMaker PiScreen 3.5’ (touchscreen)

I can access my zynthian via ethernet and can make settings in webconf.
But I can’t figure out what settings I need to make, there are so many options.

I tried:
Display: PiScreen 3.5 (v2)
Wiring: MCP23017_EXTRA
I2C: MCP23017@0x20

But there’s something wrong with that:
zynthian only shows zynthian logo, sometimes red: ERROR
webconf continously asks for reboot (It says: needs reboot to apply changes → then i click reboot, but then it asks for another reboot.)

The hardware config is original as shipped.
Except for the soundcard which I replaced by Hifiberry DAC+ADC.

Would be really great to get some advice on how to configure it correctly.
Thanks a lot

Here is the complete config:


Raspberry Pi 4 Model B Rev 1.1
Audio: HifiBerry DAC+ ADC
Display: PiScreen 3.5 (v2)
Wiring: MCP23017_EXTRA
I2C: MCP23017@0x20
Profile: v4_studio


Raspbian GNU/Linux 10 (buster)
Build Date: 2022-11-01
Memory: 4% (91M/1872M)
SD Card: 40% (12G/29G)
Temperature: 56.9ºC
Overclock: None


Tuning: 440 Hz
Receive Mode: Stage (Omni On)
ZS3 Sub-SnapShots: On
MIDI to Output: Off
Master Channel: off


zyncoder: stable (98c3df2)
zynthian-ui: stable (f15cbd3)
zynthian-sys: stable (72d32e4)
zynthian-data: stable (3ba7f00)
zynthian-webconf: stable (bec0a78)


Snapshots: 5
User Presets: 5
User Soundfonts: 0
Audio Captures: 0
MIDI Captures: 4


Hostname: zynthian
Wifi: off
IP: fd89:73d2:6129::350 fd89:73d2:6129:0:6601:88b1:b1ab:6fd0
QMidiNet: Off


It seems like a problem with your audio device.

  • What is the exact model of your HifiBerry soundcard?
  • Could test with a different model from the list?
  • Could you send the output of running “aplay -l” from the command line?
  • Could you send the output of running “i2cdetect 1”?


The exact model of my Hifiberry Card is this:

The above output is now for the latest stable 2306 image from a couple of days ago.

When starting, zynthian shows the mixer screen but i can’t navigate, encoders do not work.

Here is the config screen:

Would i need to change wiring to make the encoders work?

I also tried Hifiberry DAC+ instead of DAC+ADC but still same problems.

my zynthian boots into the mixer screen.

Same here for my (old) Zynthian-v2. Fresh intallation. But I cannot change the kit via Webconf (Hardware->Kit). I chosed V2 and rebootet. On the main screen there is Profile: v4_studio shown and when going to Hardware->Kit V2 is selected. Encoders do not work…

Is there a problem with webconf’s kit selection?

… some tests:

Switching from v2 to v5 seems to work (after Reboot), but the red reboot message at the bottom remains after reboot. On the main screen Profile: v5 ist shown and encoders do not work.

Switching to v1 (and reboot) shows on the main screen Profile: - nothing as profile.

Going back to v2 (and reboot) shows Profile: v4_studio (no encoders)

Problem still unsolved.
Been reading through the wiki but can’t figure out what to do.

Touch screen is working but encoders don’t. Neither click nor rotate.

What is the correct setting for encoders or how can I find out?
I can’t remember having these kind of problems with earlier zynthian software versions.

I opened a bug report #886 for this. I think we have to be patient :slight_smile:

1 Like

Is it worth trying [ ] or better switch back to [ ] ?

Always worth trying, it improves lots of things :slight_smile:

Hi all, my poor zynthian is still not usable since I tried to upgrade to a more recent image. Which is the latest usable image for V2 kit? I tried 2022-11-01 stable but same boot loop there. Even if I try to login via webconf, it won`t accept the standard password which should be raspberry.
Where could I find older images? I’m stuck and would need some little support to get it runnung again. My configuration was mentioned earlier in this post.

1 Like

You are not the first one to report this. @C0d3man already open an issue in the tracker and i’ve tried to figure where the problem is, but i’ve not a single V2 in my lab. I’ve V1, V3, V4 & V5, but i failed to keep an V2 unit with me, so i can’t test. I would build one, but i’ve not remaining AllInOne modules neither!!
If someone send me a V2 unit, i promise to solve the issue, so these venerable units continue working with the latest zynthian versions. BTW, V1 units do it very nicely!! :wink:

Best Regards!


Perhaps it could be useful to send me the output from re-building the zyncoder library:

cd /zynthian/zyncoder
rm -rf build

with the screenshot from the webconf’s dashboard.


1 Like

I disassembled my v2 (and made it into a v4). Except for the Raspi, I would still have everything. Should I send the rest (with or without Hifiberry)?

1 Like

Send me the all in one only. I think it should be enough.


1 Like

Ok, will do this on monday!

1 Like

Ok - on the way (by snail mail - hope it will not take too long).


I’m trying to wrangle the current stable onto my SDCard as I still use a v2.1 kit (with a pi4)

1 Like

First observation, clicking reboot in the webconfig after setting the kit doesn’t actually seem to reboot it. I had to manually ssh in and reboot to get it to pick up that I had set the V2 kit. Otherwise aplay -l didn’t show the card, suggesting the dtoverlay hadn’t been set. Presumably the constantly churning zynthian / jack restarting cycle inhibited the reboot somehow.

This was the only config I set

This is how the webconfig was after I set it.

The second thing is my encoders are working fine with the 2023-08-25-zynthianos-stable-2308 image. I haven’t hit update yet though.

Edit, now I have, the checksums are still as above and the encoders are still working.

@jofemodo Has it arrived in meantime?