How to tell if the software update completed successfully?


#1

Hello all,

I built a full kit from Zynthian, with the wifi berry+, the nice case and touch display with the 4 encoders.

It works, but…I suspect my extreme latency issue when using midi in jack is because its not updating.

I have the zynthian connected to my laptop via wired ethernet, and i can sftp into the zynthian, use the webconf interface webpages using zynthian.local. I do in fact hear instruments that I create layers for.

The laptop is win8.1 64bit, and it connects to the internet via my wireless adaptor, which is shared with the wired ethernet adaptor.

But I am not convinced my zynthian is getting updated.

How can i tell if it is updating?

or… perhaps someone can tell that i am missing something

Any pointers would be appreciated.

Thanks in advance… - Mark


#2

Can you send as copy of he webconf screen so we can check the software versions of the code you are using…?

This is the current settings ( which I’ve just updated cos I can see jofo’s new ip address on the error screen !)

The hex details next to the software areas link throu’ directly to the github repository so you can see how current your code is…


#3

Wow! Thank you for that speedy reply.

Yup, thats my problem. Presuming its hexadecimal and higher means more recent and more features and fewer bugs.

Thanks again. I will see what I can regarding this shared internet thing in windows.


#4

You should be able to automatically update from the webconf…

The hex code isn’t increasing it’s simply the first six characters of a much longer unique string identifying the commit of code. However it is the best way of telling precisely which lump of code you have loaded…


#5

When you connected your Zynthian with the pc, it won’t update.
Unless you have configured your pc that way, that I doubt.
You should connect the Zynthian with your router


#6

@wyleu… I see, well, I definitely have different versions.

?? update from webconf??

@mhidt Thanks for your reply, but as far as I know, I thought I configured to share an internet connection (aka ‘ICS’)

So I did try connecting to my router, and just like with ICS, I see some text scroll, but when I check - nothing has changed.

Heres my screen shot.


#7

The software update function on the webconf is under the software menu, if you don’t see the menus try the hamburger (three horizontal bars on the left hand side of the screen) to get the menu.

As mheidt says you need to have a connection to a router and then out to the Internet to get this to work.
the webconf update will make a fairly detailed report of the update process so that should tell you if everything is working properly.
From what you show your IP address seems a little different from what you tend to get with a ‘normal’ router.

Can you log onto the zynth as root ?

ssh root@169.254.190.95?

If so you should be able to ping google …

ping google.com

to establish if you have a connection from the zynth to the great big hideous Internet and then onto the github repositories…


#8

You should connect your zynthian to the router (local network) using an ethernet cable or Wifi. Connecting to the PC will allow to access your zynthian (webconf, ssh) but currently zynthian can’t connect to the Internet using the PC as a gateaway.

Looking at your screenshot, It seems that your zynthian is connected to your PC because the IP address starts with “169.254” that is a “link local” IP address. Please, check that it gets a “normal” local network IP address when connected to the router.

Connecting to the router normally works very well out-the-box and you should update the software without problems. Ahhh! When updating is working OK, you should update twice for installing all the new packages :wink:

Regarding your latency problems. It’s not normal at all!! Gorgona image normally works perfectly OK out-the-box (without updating!), with a small latency of around of 10ms. So, if you are having latency issues, i doubt it’s solved by updating. You should give more details about how are you using your zynthian, how you connect everything, what MIDI controllers, your audio chain (mixer, etc.). Also, check that your power source is good enough … this is a very common source of bizarre problems.

Kind Regards,


#9

Hi @wyleu! This option is not available in a fresh Gorgona image. You have to update first using other method :wink:

For having a detailed report of the update proccess with a fresh Gorgona image the only option is using the command line (SSH):

# /zynthian/zynthian-sys/scripts/update_zynthian.sh

I doubt that you can get access to the Internet with this IP address, as it’s a link-local address.

From the wikipedia:

In a computer network, a link-local address is a network address that is valid only for communications within the network segment or the broadcast domain that the host is connected to. Link-local addresses are most often assigned automatically through a process known as stateless address autoconfiguration or link-local address autoconfiguration .[1]

Link-local addresses are not guaranteed to be unique beyond their network segment, therefore routers do not forward packets with link-local addresses.

For more details about link-local addresses: https://en.wikipedia.org/wiki/Link-local_address

Cheers!


#10

Hello again,

So, yes, that screen cap is when the zynthian is connected through my lap tops ethernet port… its the only way i can communicate with the zynthian.

I can’t make ipmidi/qmidinet to work either.

Thanks for all the replies. :+1:

Edit/
When connected to my laptop, i can use winscp, access webconf… but not when connected to my router.


#11

Well that’s told me! Listen to jofo! I will now be going to my
garden shed with a bottle of whiskey and a revolver… I may be some time…

Distant sound of general midi programme change 128


#12

@wyleu he he… its all good… well, ya know…

Anyway, I did get ipmidi/qmidinet working… and in deed, working quite good. Even the usb midi devices work well… just not the midi in (well, I have no way of testing midi out either).

Anyway, thanks again.