Improved Audio Routing: Output & Input

Hi @zynthianers!

Mr @jypma & me have been working on improving the zynthian’s audio routing. This include:

  • Layer’s audio output can be routed to 1 (mono) or 2 (stereo) system audio outputs.

  • FX-layer’s audio input can be connected to 1 (mono) or 2 (stereo) system audio captures.

  • Sound-cards with more than 2 outputs/captures should be supported on this way too!

Of course, all the new functionality is accessible from layer’s option menu … :wink:

Please update and test …

The details & discussion here:

Enjoy!

10 Likes

This might be amazing and exactly what I was looking for, but let me check first…

My soundcard has an XLR input and a 1/4" jack… So basically 2 mono inputs… Can I have a mono input / mono output layer that plays on both speakers now?

If so… big love. If not so… Also big love but with an added look of expectancy! :joy::+1:

4 Likes

Of course you can, my dear cabbageheaded friend …

I will be awaiting your confirmation.

Thanks!

1 Like

How does one set that up?

I have a pre-amped piezo on one channel which I want to add a little reverb to, and a humbucker that I want to increase the gain on and provide a little compression and then I want to provide individual level controls & pan to he stereo output pairs . . .

Can that be done and if so how does one set it up?

1 Like

@wyleu I would have thought adding chorus FX chain and selecting input 1 then adding gain FX chain, adding the compressor to this chain and selecting input 2 would work? Are you asking about the subsequent stereo imaging? There is output routing so you could probably deroute the outputs from system:playback and into a subsequeng gain layer???

@jofemodo When I select “Audio Capture” I am presented with an empty screen:
image

Pretty obvious really … we have Audio Capture & Audio Output

Audio Capture . . .

Audio Output . .

It seems that your soundcard doesn’t have audio capture … ir it’s not configured correctly

I think you would like to have something like this:

I will add It ASAP

Enjoy!

Doh! I forgot I had unplugged my USB soundcard during a recent Zynth Club.

4 Likes

It worked! Amazing… Zynthian just keeps getting better and better!

1 Like

Hi @wyleu!

I just added the stereo-mixer LV2-plugin. Just update and enjoy …
Tell me if it solves your use-case …

Regards!

2 Likes

Just tested it today: awesome :clap: :clap: :clap:

It seems to do the job !!! Thanxs!

so that 's :face_with_monocle: satisfied, before the baying hoards feel the need to propogate unrest . . . .

One aspect of zynthian-pedal.local implemented … :smiley:

3 Likes

He he. I was listening to your audio clip whilst looking at the Audacity screenshot and got confused when the audio stopped before the play cursor reached the end. :roll_eyes:. It’s been a hard day. I need beer… It may all start to make sense… or simply matter less :wink:.

I am really liking these developments. This tiny box is becoming a flexible workhorse. I see permanent audio inputs on the horizon (as opposed to the temporary USB interface I occasionally plug in).

3 Likes

If you create an audio FX layer with a mono effect, e.g. C* AutoFilter, you are only given the option of Mono from capture_1 or Mono from capture_2. You are not offered mono from both which is a valid workflow, e.g. you have a stereo source which you want to mono. I suggest for mono effects you are also offered “Mono from capture_1 and capture2” similar to “Stereo from capture_1 and capture_2” that you are offered for a stereo effect.

Ein? What branch are you testing on? It’s on master and it says nothing like “mono from” … :grin:
With the current implementation you have all the possibilities, except swapping stereo channels.

Ah! I didn’t realise you had merged with master. I now see it working cheers!

I think it would be beneficial to see which effects have mono / stereo inputs / outputs within the plugins list.

Also, it will be good when we can route outputs to left / right / both.

You already can do that …

er… maybe you can - I can’t!!! I can route Left output to left and right output to right but don’t see how to route both outputs to left or both outputs to right.

Simply select left, leave right unchecked, and both outputs will be connected to left. Same for right.