Issues with first run (no sound, no webconfig...)


#41

that’s the point : tried different software (volumio) with same hardware, and it worked like a charm.

I’m a noob at this but here i don’t get it, it seems to work for nearly everyone seeing the forum…

I’m gonna double check my soldering points but i guess if it would be the problem, i wouldn’t have the UI or controls working.

If there’s a savior around herre… meanwhile i’ll sacrifice one or two goats, never know…


#42

for now i’m trying to get a sound with the audio test (and fails… again and again). Midi is way out of my league for now !
hope one day i’ll have the chance to configure midi ^^


#43

Roaming the forums i note these lines :

Playback open error: -16,Device or resource busy

Could it be that hifiberry is occupied with a parasitic process of some sort (the “busy” stuff) ?

Is so, how can i control, seek and kill it ?

It seems some users had the problem (with not exactly same card but meh…) and solved it by some commandlines i’m not sure i can use for my case : No Alsa/jack from zynthian image but Hifiberry Amp+ plays from hifiberry image

It refers to “jack”, this little guy is present many times in my mystery case… could it be the culprit ?


#44

Jack is the audio server that takes audio from (possibly multiple) software and sends it to the alsa driver that sends it to the sound card.

I tried to find a diagram but searches for “Jack and Alsa” only bring up pictures like this:
Jack and Alsa?


#45

Ahah, I know now how i’ll NOT name my first child !


#46

Hello @arkhhh, @Baggypants and @mheidt,

sorry to hijack this thread, but I just want to give some hints because I started with a new image as well but built it myself…
At first when I built my zynthian Kit V2 I looked at the photos for the orientation of the H11L1.
I was glad because I soldered them on IC sockets.
If your MIDI In and MIDI THRU lit if you start your zynthian you need to solder them turned around. This must be updated in the wiki and I am sorry for everyone who has soldered with the photos in mind.

Now for the software part: It might not solve your problems with sound on your zynthian first but it will help you update.

After first boot when you log in via ssh you find the commands from the first install script:
cd /zynthian/zynthian-sw
ls
cd…
cd zynthian-sys
ls
cd scripts
ls
./set_first_boot.sh

I think at this time date and time are not set.
So I did a
htpdate -t -s www.isc.org
as found here

Then I started zynthian software update on the zynthian itself and it updated.
Don’t let yourself get fooled because your zynthian might not do something for a long time while downloading.
Update twice.
Rebooting or powering off helps in my opinion, too.

If you see the updating process coloured when started from your zynthian via Admin menu you are on a good way through the process.
I hope that helps

Greetings and God bless, Marius


#47

Okay so the optocouplers are upside down…
It explain part of problem ^^
Thx for the info, for the software part une gonna tale my asprin and try this asap !
To be continued !


#48

Don’t give up, I’m rooting for you to get this working.


#49

love this quote “i’m rooting for you” ! thx !

And god bless sockets (i remember when mounted the kit i was unsure it was necessary… i’m glad i had no confidence and put them on !) Desoldering is evil…


#50

Something bother me about the optocouplers :

You’re saying they’re upside down on the photos on the wiki, but if we look at the PCB, the marks are matching with the side of the mounted opto (head up, optos are also head up).

I rememberded, looking at the photos, that in fact i looked at the PCB before implanting the optos, and with photos with and without, it was matching (that’s why i was hesitating before soldering sockets).

So the problem would be, if i’m not wrong, not only the photo of the wiki, but the etching of the PCB ?

Thx for the precisions before swapping them !


#51

Hello @arkhhh,

to clarify this, the ICs have to be mounted on the mounting side of the PCB, what else should they.
The sign on the PCB is right, so Pin1 of each optocoupler must point to the jst plugs
The pictures show that Pin1 points away.

Greetings and God bless, Marius


#52

So if we’re talking about this photo :

They’re on the right side (dot upleft, pcb mark is right too).

And so mine are right too (possible that i didn’t understand well your sentence, my english is sometimes… limited ^^). maybe you were talking of the side “of the PCB” (it would explain everything !)

But the led from midi in is blinking at start, that’s why i’m disturbed now !

Anyway, i’ll give a try so be it !


#53

Hi @arkhhh,
this is what I was talking about.
Normally ICs are marked with a ‘dot’ for Pin 1. The unsoldered PCB in the wiki also shows a rectangled solder point for Pin1. So the dot of the IC has to point to the connectors and not the resistors/diodes.

I hope it is a bit clearer for you now.
God bless, Marius


#54

so : Opto’s good, and procedure failed (i mean no progress, still no sound, every updates seems good now)

I’m gonna dig in jack and alsa problem, saw some clues with the “Playback open error: -16,Device or resource busy” problem.

I don’t understand why i’ve got this problem(s), i honestly think had follow the steps now…

journey continues


#55

Hi @arkhhh!

Sorry for my radio silencie, i’m moving yo my new house and my life is a Kindle if caos these days.

Please, could you try to burn a fresh SD with the Gorgona Omega image and test the synths without updating? Although the raw image is outdated, It should work out the box…

Also, for updating the software, you should connect your zynthian to the router with a cable. Connecting directly to the PC works for accessing the webconf, but normally zynthian can’t reach the internet using the PC as a gateway.

Regards


#56

Hi !

Done this (brand new sd, etched the img and try again, with or without updating) after first fails.
Failed too.
No problem with network connexion, it is like it (zynthian to router, pc to wifi, no prob to access webconfig or updating now).
Mystery…


#57

It’s very strange! And you tested with Volumio and it worked … that’s stranger yet!!
Please, could you tell me the full filename of the SD image you are using?

Thanks!


#58

Sorry, forget my last comment. I saw you are using Gorgona Omega for V2 :wink:


#59

Could you unplug the 3-pin connector from the HifiBerry and test the RCA output again?


#60

Yes it is the right image (i tried the 2 sources, torrent and DL, for the case of downloading error of some kind, and tested each mounted, it made no differences, proof of “good” downloading IMHO).

I’m about to try extreme measures and flasing the experimental version (yes i’m going mad at this point !)

Seeing this advice in another thread i also tried with and without the 3 pin connector each try : no difference with the no RCA output issue…

And yes it is very strange (and frustrating) !!