Issues with first run (no sound, no webconfig...)


#61

It should be something very stupid or very strange. Lot of people are using this image with the standard zynthian kits and other more bizarre zynthians, and it works out-the-box …
I mount zynthian kits every week and burn new images regularly and i have no problems at all. So … yes, it’s very frutrating and you can be sure that i’m thinking a lot about your problem … but i have no idea, precisely because it should work out-the-box.

Have you tried to disconnect the AIO circuit and use only the touch interface?

Regards,


#62

@arkhhh
Maybe there is another zynthian user close to your location, so that you can meet and swap parts?
For analysis purpose only :slight_smile:


#63

I’im really convinced it’s a stupid thing, that’s why i’m digging, someone said, in this forum i think, that with a technological object, sacrificing young virgins is useless to solve a problem (wasn’t exactly the sentence but this is the spirit !).

Think i’ll drink all night when i’ll solve it !

I’ll try disconnecting the AIO, right i didn’t do this, because i wasn’t sure it was not needed to control RBP, i’ll give a shot before extreme measures.

Then gonna start everything from scratch, DL and formating everything til last bit and we’ll see. And go experimental if it fails again.

For the other zynhtian in my neighbourood i’d like to but i saw on map that there’s only one near and about ten in the whole land, and don’t know how to contact them. But it would be nice !

I’ll be back here if i found something tonight, again, thx for the help !


#64

Could you paraphrase the problem as you see it?


#65

Hard when you don’t know the source of problem…

Everything seems good (controls, ui, wiring, solderings, connexions, even updates) but no sound nor midi devices are heard or detected.

got good image, brand new and properly formated SDcard, got official RP alim, mixing table fully functional, hifiberry also functional (tested with volumio).

Lot of commands and alsa tweaking tried that shows that it’s all good and… no results.

And A LOT of tries with different SD, images and steps…

Still :

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Playback open error: -16,Device or resource busy

I think i have “paraphrased” the situation…

Now tried commands with AIO disconnected => failed

Starting from scratch now.


#66

i didn’t tell this i think : the green led up on the hifiberry is continuously on, i don’t know if it’s normal or if the led should light only when sound is diffused ?
Stupid question i guess but never saw a HFberry before and it could be a proof of… device busy" ?


#67

Have done everything i could, but even with a total restart it won’t work.

Plus i have mounted this : https://www.hifiberry.com/build/download/ and it works fine, speaker test gives a fine noise (in fact an horrible noise but to me now it seems some fu**** chopin to my hears !)

So : it works fine with volumio, fine with raspbian lite, totally not with zynthian. yay…

Tried to apply this (asit seems a comparable case) : No Alsa/jack from zynthian image but Hifiberry Amp+ plays from hifiberry image

But as i understand just a piece of what i’m doing, it stops with the command : " lsof | grep snd" which is refused (unknown command !)

I tried the : “killall -9 jackd” (nasssssssty !) but zynthian rebooted (some sort of reboot, a blink) but speaker-test gives nothing…again.

Test sound from zynthian ui gives nothing…

Voilà !

Can’t stand more i guess i’m gonna transform this in a fuzz pedal or mini barbecue. It seems my zynhtian have an orphan deceased so this is the end.


#68

Hi @arkhhh,

thinking about your message what you would do in the later evening when finished with zynthian… alcohol doesn’t make the evening any better.

So get drunk if you like, I prefer to stay sober.
I wish the next day will be a good one for you.
Thanks for trying so hard and keeping us updated about your progress.

Greetings and God bless, Marius


#69

You’re right about alcohol, it does not make feel better, but it could help forget this total mess :wink:

i will have tea instead, and come back in some days, i love lost causes ^^

Thx all for the help !

grab his FOLK and 100% analogic guitar


#70

Ok.
Yes it can all appear intimidating. You are also combining several different fairly involved technical skills, all of which have a considerable bearing on the final outcome.

But you have a raspberry pi ? ( It is a model 3 at least is it.?)
You have a hifiberry DAC out card that has worked with the raspberry pi and speaker test has run successfully?
So that is a good starting point.

You say you have the screen and the encoders interacting properly. Congratulations! that is a considerable part of the functionality Working and altho it doesn’t make any sound does provide a health check. Incidentally was this with the Encoder board connected? If you did say I apologize but I don’t remember if you mentioned it.

The networking side is also awash with traps. Suffice to say if the great and the good were starting the Internet from scratch there would probably be several changes that would be made and networking would probably be fairly high in that list ( If you want purest insane why did we do it that way have a look at email).

But you are past that hurdle because you are using Putty and webconf, so there’s another couple of bit that are playing correctly. Again congratulations.

It would probably be a good idea to try building it from scratch on the bench bit by bit to. It would at least allow detailed pictures of the encoder board, which works ( you can operate encoders and it shows up on the screen) but personally I’d love to see a detailed picture of that board to see how everything looks.( After all that is the component that is most ‘personalized’).

I have built many many zynthians in all kinds of forms using different audio boards, displays and encoder configs. The early efforts were frustrating in the fashion you describe but we get there, and try to roll as much back into the process to help people further on down the line.

You seem to be a little daunted by the commands you are typing. It’s certainly a horrible feeling typing weird incomprehensible bits of magic text into a terminal and very disheartening when the spell doesn’t work. Again this is all done at a distance so we are making a best guess but you actually sit at the reactor whilst we only watch the atomic explosions from a distance.
A few useful things to know.

Audio on Raspberry Pi’s is a complicated system there is.

  1. Alsa The bit that handles the audio hardware. When you use speakertest or aplay or aconnect you are dealing with Alsa commands and these are good confirmations that wires aren’t crossed and things are as they should be. THere isn’t really an Alsa server that runs but obviously the Alsa code has to be correct to make it all work… Much of computer programme is indivdual chunks and they all make a lot of assumptions about what is available and if they don’t find it then tend to sulk with obscure lines about Dbus or can’t find . or some such. But you say speaker test works …but next we come to jack . . .

  2. Jack An Audio server and a very good one. This is where the magic goes on it allows various Audio & MIDI devices to work together. but it is a completely different component from Alsa althou it uses Alsa to transfer good audio data out to Alsa which interfaces to the hardware. There is a Jack server and this is started at startup and it has to be running for good stuff to happen. The normal way of checking this is a tool called qjackctl which people who use remote linux machines to log on kind of just works but if you are using a windows remote machine you need a component, which I know is mentioned in another of these threads elsewhere (xming seems to be the way to get X-Windowes on windows.) That will tell you if jack is running properly and what it can see in the alsa world. BUt what started the jackd server , well it’s something called …systemd

  3. Systemd the start up beast operated by its command line systemctl. This is a long list of instructions on what to do to start up the bits and pieces that are required and also check to see if some bits are already available before thinfgs start and its a great way of starting a row in the many many bars that Unix people retire to after a long day of frustration. What is does allow you to do is start and stop individual components and get the status. The zynthian has several components that run to make it all work and some them will continue to run whilst others are restarted. This is what people mean by a system so you can stop the zynthian component with systemctl stop zynthian. But you don’t need to restart it using systemd and indeed this is the way we run the system to see what kind of error messages the indvidual bits are producing because a ‘normal’ zynth doesnt produce logging because with the ssd disk on a pi this is a fine way to clutter up the disk and corrupt ssds.

I have to go out now but I hope this in some way explains a bit of the magic you are typing. Apologies for the tome, you sound very frustrated and I certainly know that feeling but, remember this is not a personallised bug set aside for you, it’s just a piece of technolgy that has something that prevents it behaving correctly and once it’s fixed it will not remember and will work blissfully. The down side of this is you wont remember the fault so when it reoccurs on your next zynthian you will have to come back here to remember how you fixed it.

Just like toothache…

Keep at it!


#71

Wow… thank you for all this, it helps a lot (if not yet to find solution, at least for the morale !)

I love technology, music, sarcasm and irony, so don’t worry about my despair, i continue to think that i’ll not be beaten by a machine (I AM YOUR MASTER, DEVIL BINARY THING !)

In fact i learn more with trial and error and solving problems than reading long treaties (not that second is unuseful but a bit boring for an old learner and experimental addict), so here i learn… a lot… really, a lot (more than i expected !).

This being said :

  • hardware : is the complete kit ready to mount (RBP3B+, HIFIberry DAC+, AIO, knobs kits etc.) so i guess it’s not a variable in the equation (it’s fully functional with other OS, it’s a fact now)
  • “health check(s)” : done with and without the encoder board connected. no noticeable differences in results.
  • AIO image : i’ll post this tonight, but to be precise i controled every point of solder and tested continuity almost evrywhere with multimeter (i didn’t find the schematics to go further).
    If it was a real analog device i’ll have check with audioprobe but here it seems not needed because, well, digital !
    I’m just not sure (and don’t know how to control) for the microchip. Maybe electrostatic discharge have been acted on it ? bad bended leg ? but all the controls work and all legs are fully in contact with the pcb (controlled one by one) so how to see more…
  • Alsa : regarding all the control commands done, seems okay (everything is in place, no volume or mute)
  • jack : thx for explanation, that’s the part where i needed some light, i understood the role of the guy, but not how to control him eficiently. I’m gonna dig a little (better than random commandlines ^^) and look at qjackctl
  • Systemd : nice infos, it gives light again and help with seeking bug, but i’ll need to dig here too to understand more

Anyway thx again for your time, really appreciate it, and be sure when i’ll find the culprit, i’ll be back to explain how to start fire under the stake !.. IF i understand how to, for sure !


#72

the AIO “naked”


#74

My friend, your AIO board looks really fine. Anyway, i’m pretty sure that the problem isn’t there. That’s my proposal:

You send me your zynthian. I’m really curious about it! Your case is not very common and i want to know where the problem is:

  • If it’s my fault: some part is broken or documentation is confusing => I pay the shipping costs
  • If it’s your fault: you make an error or miss something that is well documented, etc. => You pay the shipping costs
  • If it’s a bizarre problem and it’s difficult to say who is the “zokete”, the we pay 50-50.

What do you think? :wink:


#75

Seems fair… i’ll give myself à couple of days to dig more, and tell you.

Anyway, i just noticed the schematic in wiki page (didn’t scrolled enough…), i don’t think its related with my little problem but i’m intrigued :
There’s this 4 pins connector on AIO wich obviously is this same schem’s switch 4 pins but it is not described nor present on photos or the wiki guide.
What’s his purpose ?
Thx


#76

#77

So… i’ve been wandering linux’s forums, HIFIberry’s forum, Zynthian’s forum, jack’s forum, blogs, obscure webpages with no name and, still, no clue about my little problem.

If the offer is still on, give me the adress for expertise, i’m in (sad to admit defeat but in).

Thx


#78

Well, until jofemodo is coming back around here, i’m trying to dig again (it is said hope gives a reason to live).

And i’m stuck trying to use qjackctl.

What i’m doing :

  • i’m on Windows (yeah i know… sorry !)
  • started zynthian
  • installed xming to launch x server
  • launched it, started it
  • configured putty in x11 forwarding mode
  • connected to my zynthian as usual within putty (root)
  • tried qjackctl & command

At this time i guess the jackd ui should appear, don’t have abnormal message in console.

But in fact there are 2 windows that appears in the taskbar, but impossible to display them !

One is named “jack audio connexion kit (default) active” the other “connexions - jack audio connexion kit”, but can’t see anything on previews nor to display one !

Don’t know what i’m missing…

Can anyone help me on this ?
Clear procedure to access qjackctl on zynthian ?

Have read the doc from jack and xming and some other sources, but can’t find why i can’t see the jack ui.

Know i’m surely wrong somewhere but… well i definitely suck at this (but i try hard !)

thx !


#79

What did you mean when you said “& command”


#80

Hi @arkhhh!

Of course the offer is on! This is my address:

Fernando Moyano - Made Makerspace
Noguera Pallaresa 59-61
28014 - Barcelona
SPAIN

The best!


#81

Typing the command line “qjackctl &” in putty.
Assuming the fact i’m doing something useful to get gjackctl starting… really unsure about that !