Just built a Zynthian and can't get past an ERROR screen


With only the soundcard, I tried the aplay command, here’s the result:

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0


Ok, as it’s a prebuilt, @jofemodo has to tell the next steps.
It’s either ribbon cable or my guess is the AllInOne board as only one LED is lit up.


Thanks for all the help, I really appreciate it. I just hope to get this working so I can focus on playing and experimenting.


Yah thats a bummer. I don’t know if it makes you feel any better but mine was only working slightly better, like I said the left channel was pretty awful and the midi still doesn’t work so I spent a lot of time monkeying around with it.

I think we bought maybe similar timeframe as I’ve only had it a few days, may have a bad batch. I need to write an email to @jofemodo asking for some help troubleshooting.

It sounds good now and I got a usb midi interface working well. Pianoteq stage is now letting me play killer sounds (rhodes and the steingraeber) without a pc in the loop and I’m super happy with this device.

Just needs some polish and love that we can give it as a community.


Yeah, I can’t wait to get it going. I may not be the most linux savvy user, but I really want to experiment and put the good word of the project out there.


It seems that there is some problem with the Ribbon Bus cable or the AllInOne circuit. Could you test the Ribbon Cable with a multimeter? Also, the extra 40 pin connector soldered on the hifiberry could be the cause of failure. Could you test this too?

I will replace the broken parts, so don’t worry, but you have to wait until July 18th because i’m on holidays, camping with my family on the mountains.

Sorry for the inconvenience …

Kind Regards,


Hi @jofemodo thanks for your reply.

I tested the ribbon cable and the hifiberry, both seem to be OK.

But when I was running a continuity test on the AllInOne pins, I’ve found that those two have some resistance between them (I do not know if this is normal and yes, I’m being careful to not touch the two 5V pins):

Obviously, both 5V pins create this resistance.

Let me know if this is expected from the board and if this could be a cause for the problem. If it’s normal, I’ll keep looking.


I’m out of ideas. I still can’t make it work =/.


Hi @victorlucky!

I will send you a replacement for the All-In-One circuit and will see … :wink:



Hi, thanks, I hope that’s the issue.

How can I send you the details (address and everything)?


Don’t worry, i think i’ve your address, if you didn’t move recently … :wink:
Please, when you receive the new circuit, send me the broken one as an “ordinary post”. It should cost you almost nothing and i would like to investigate what the problem is …

Kind Regards,


Thank you so so much. I have high hopes for experimentation on the Zynthian!


Hey @jofemodo, any news about that? I’m not in a hurry, I just want some update.


The package was shipped 2 weeks ago as a “standard post”. Canada is far away and postal service is slow in spain, specially in summer, but , so you should receive it very soon, i hope :wink:



I thought that would be the case. You’re a fantastic person! Thank you very much.


Hey @jofemodo, I finally got the board. I still get the same error, though. I’ll send the new board back to you. I don’t know what to do anymore.


Please, send me everything and i will search for the problem and solve it. Try to maintain the original packaging if possible …
For lower shipping costs, try to send the package as a standard certified “postal card” (under 2 Kg) using your “national” post service. Of course, i will pay the costs if it’s my fault … :wink:



Hi Victor!!

Have you solved the problems or are you sending back the kit for inspection?



Hi @jofemodo, I’m sending it this week.