Just released Pianoteq 8

Just released Pianoteq 8. yeaaaa!
I am downloading and installing it

1 Like

Just tried the desktop version ! Sounds smoother and softer at the same time. Hope our RPi’s will be capable to work with this version.

I just tried uploading it via the web interface… didn’t work.

It works for me so I think it’s a loading problem. Are you licensed? I had problems loading it using Mozzilla, but then Chrome loaded it, the license number was already present in the window and it was enough to use the button to re-register the program.

I’ve been playing it since this morning and it hasn’t had any problems.

I tried to add it to a fresh install. Maybe I’ll try installing the older one first… yes licensed.

From the webconf window you have to select Software/ pianoteq/Upload bynary-PTQ, a window opens where you can drag the still compressed file. At that point with Mozilla nothing happened, while with Chrome a bar appears showing the progress of the installation… Does it appear to you?

Yes it all looked ok then rebooted but when it reloaded there was no option to put in the license key so it was back to square one. All using chrome. Then I tried to run an update which ended in a fatal error and it wouldn’t start so I’m flashing the sdcard again for a second try!

The old one is already installed by default…so with the new installation you should have it in demo version. At that point register it and then update… But try with other browsers… nobody has this problem but I had it.

I have reinstalled it several times with Firefox and the only problem I can see is that you cannot input the license key until you have rebooted.

And you cannot change the licence key unless you upload it again…

But these are small nuances.

1 Like

I have it working now. It seems that from the fresh install it needed a couple of reboots to iron out a start up crash which appeared when I set the screen rpi touch. Then I installed pianoteq 7.5.4 and activated and following that I did 8. With this new stable release it seems reboots take a bit longer and the web ui appears to have frozen when in fact it is doing stuff. Anyway now it works, this is my first time with the new mixer etc so a bit to learn.

1 Like

The only issue I’ve found is that when adding Pianoteq 8 as an lv2 the presets don’t make a difference. You have to go into the web vnc ui to change the instrument sound. In this way I was able to have a piano and an rhodes sound at the same time.

This is very interesting…can you explain better what you did?

Hm. The guitar not available in presets yet. Must be added somewhere?

I believe it is a separate paid plugin…

1 Like

I have it active. But it does not appear in the active nor in the DEMO presets. Obviously, it is still missing in zynthian-ui/zynthian_engine_pianoteq.py at testing · zynthian/zynthian-ui · GitHub
So, created a “bug report” (#830) – or is it “feature request”? :).

1 Like

I’m testing the new pianoteq, to be hopefully merged RSN, and I can use it with Pianoteq 8.

Give it a try! :smiley:

I installed the V805.7 version on the Zynthian but I’m afraid it will click a few … I’m waiting for someone else to confirm …

It works like a charm. And in the testing branch you will fins a very substantial change to make Pianoteq much more pleasant to use, Give i t a shot!


Now with improved display of instrument / bank / preset. (@pau please check it out - it is a Christmas present for you!)