Kit v4. No sound on headphones? [SOLVED!]


Got my Zynthian today! Yay!! Everything works apart from the headphone out. For one I don’t know which headphone socket to use so I have been trying both.



Aka newbie without a clue

Hi Andy

Wow, both headphone sockets!!! I didn’t think it had any.

newbie here too.
Same problem (on rc2), I’ve been trying both the headphone out of the hifiberry and the headphone out of the rpi itself, both are completely silent…

+1 same

Same for me T_T … (using buster rc2)
I tried both (Raspberry headphones AND hifiberry headphones)

@andycallaby Also strange behaviour of the 6.5mm jack Audio out. I plugged my headphones in there and, predictably, only one side was working, but both times (ie. whether I’m plugged in audio out L or audio out R) it was the left side! (I was running the Audio test from Admin menu)

Is it the same for you? It’s unlikely it’s a plugging issue, because both sides of audio out belong to the same connector on the hifiberry.

@YPares. Works fine on the audio outs hooked up to my speakers. Just the headphone out is not playing any sound.

That “Headphone Out” is the onboard audio output, I think you’d need to change the audio card in the web interface to use it?

The 6.5mm Jack outputs are both mono, so they would both only output on the left channel of a stereo pair of headphones. You would need a headphone amp to mix from both outputs for a proper stereo in headphones.

1 Like

Ok. So that’s normal. Yeah, I’m only gonna use the Zynthian with headphones or regular jack speakers for now, so I’d really like to be able to get them to work properly. Headphone outs aren’t activated by default?

It’s possible @jofemodo has some cunning way of activating it that I don’t know about, but for now I’d set the audio to Raspberry Pi onboard or whatever looks similar, that will get it working in headphones only. I’m lucky in that I have a mixing desk the zynth stays plugged into and I take headphone out from that.

You’ve just given me a brilliant idea with audio_out…

So you mean that all audio outputs just can’t be activated at the same time :confused: ? That’s throws a wrench into the ease of use of the device…

Not usually.

I’ve thought of something though. It might take a day or so.


But then why doesn’t the second headphone out (the one from the Hifiberry) doesn’t work when setting it to use the Hifiberry soundcard in the webconf? (ie. buster RC2’s default)

Oh, That’s an input.

1 Like

Aaaaaah ^^ okay then.
Okay, so in webconf setting Kit to custom and Soundcard to “Rbpi On-Board Audio” did the job. But it’s not very convenient and unexpected that all outputs don’t just work out of the box…

1 Like

We can fix it, we have the technology:


Okay. In the meantime, I ran the Update via webconf, and now I can’t set the Rbpi On-Board Audio… It’s been replaced by Rbpi Pwm Audio (and Rbpi HDMI Audio), and using either of them result in the Zynscreen showing a big ERROR at startup…

Stopping Zynthian and starting it via and SSH console with /zynthian/zynthian-sys/sbin/ to get the log, the error seems to be:

error: failed to open file /zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl (No such file or directory)
lilv_world_load_file(): error: Error loading file `file:///zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl
INFO:zynthian_gui.<module>: STARTING ZYNTHIAN-UI ...
INFO:zynthian_gui_keybinding.load: Loading key binding from keybinding.yaml
DEBUG:zynthian_gui_keybinding.load: Loading default keyboard bindings.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
libjackpeak failed to start jack client: 17

Something related to Jack, then.

But in the meantime, I guess I’m in for re-flashing my SD card, to undo the update…

1 Like

What image did you use? If it was a Stretch then use a Buster.

I’m having the same problem. Rpi Pwm Audio is somehow broken.