Low / barely audible sound from 3.5mm Headphone

Problem:

Zynthian sound quality triggered via midi is low / barely audible.

I originally mentioned this in a post related to a separate issue regarding 3.5inch screen not working.

Sound

DX7 Wurlitzer/RA wurly notes C2 to B2 on (Keystation Mini 32 default octave settings)

Recorded:
Output from Pi 3.5mm into Focusrite solo into Ableton, Aif converted into wav with slight gain increase.

Test outside of Zynthian ( produces clear audio)

speaker-test -c2 -D plughw:2,0

aplay --device=hw:2,0 piano2.wav


Environment:
Raspberry Pi 4B (Model B) Rev 1.2
Linux zynthian 5.10.60-v7l+ #1449 SMP
Display: Custom Device
Wiring: DUMMIES
GPIO Expander: Not detected

cat /proc/asound/modules
0 usb_f_midi
1 snd_bcm2835
2 snd_bcm2835

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 2: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3


Webconf

Webconf → Hardware → Audio →

Soundcard:
RbPi Headphones

Driver Config:
dtparam=audio=on
audio_pwm_mode=2

Jackd Options:
-P 70 -t 2000 -s -d alsa -d hw:Headphones -r 44100 -p 512 -n 3 -X raw

Audio Notes Options:
-O complex -t 0.5 -s -88 -p yinfft -l 0.5

Mixer:
Headphone Left,Headphone Right

All boxes unchecked.

I will continue to investigate.

Thanks.

A brief update on this, still no progress outside of performing an additional successful test outside of Zynthian to confirm onboard Headphone device is working fine.

Test performed: Installed omxplayer and played mp3 file.
Results: Sound outside of Zynthian was fine.

Test details below:
apt-get install omxplayer
omxplayer voodoo-ray.mp3 -o alsa:hw:Headphones

Any pointers on how to debug this would be appreciated. I’ll have another look through previous forum posts.

Thanks.

You may have said this on the other thread but will you post the software section of the webconf dashboard? Actually a picture of the whole dashboard would be useful.

Have you checked the settings in the audio levels screen?

You could try increasing buffers to 1024 and reduce the samplerate, e.g.

-P 70 -t 2000 -s -d alsa -d hw:Headphones -r 32000 -p 1024 -n 3 -X raw

This will reduce load on CPU which may help.

Thanks @riban - I’ll try those settings, I’m not familiar with the audio levels screen, this is all new to me.

See screenshots below, I hope this is what you are referring to.

Thank you.

Hey,

Re: Audio levels, apologies my only time/experience spent using Zynthian so far was on getting the screen working and now onto the audio issue, so was unsure what you meant.

I’ve now had a look in audio levels and tried all available x checkbox options individually and together.

There was a slight increase in volume with all checked, but the sound is definitely not working as it should.

I noticed in the UI log the hdmi is enabled, I’m wondering if this should be disabled and could be conflicting? Will also look up ‘snd_bcm2835.enable_compat_alsa=0’.

Mar 28 15:03:56 zynthian startx[3327]: Kernel command line: coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:73:A8:E4 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

Sorry for creating all the traffic on the forum, I have quite a limited window to fully focus on getting this up and running.

Hopefully my summary once working will prevent some of questions coming back into the forum.

Cheers,

Also, forgot to mention I tried the suggested settings(buffer / sample rate), but they didn’t make any difference…

Ta…

Here’s something to try in case you haven’t already. The Audio Levels @riban mentioned does not contain contain checkboxes. It can be found on the Zynthian Main Menu.
Main Menu

Once selected, it should allow you to set the Headphone level.

Thanks @ronsum

When trying to select Audio Levels the UI hangs and then seems to jump me into another menu, maybe due to my tapping. I’ve shut the Pi off to let it cool down a bit.

Just to clarify:

  • I’ve managed to test the soundcard/headphone outside of Zynthian and it’s loud and clear.
  • My testing in Zynthian has been with the volume set to full.
  • I do see the green bars and midi signal when testing. Audio is as per sound file attached to this thread.
  • I’m testing the menu with both touchscreen and a keyboard.

FYI here are checkboxes I was referring to, not sure how I ended up there =)

Cheers.

What?!?

That’s shouldn’t be that many audio destinations? How did you navigate to that screen?

You can test audio within Zynthian by accessing the Admin menu and the selection the audio test which plays a media file. This excludes the synth engines from the investigation and just checks how Zynthian is handling audio.

[Edit] I see you are using a large SD card. There have been reports of Zynthian having problems with large cards. If you have a smaller one it would be worth trying with it.

Also have you performed an update from the Zynthian UI or webconf? Don’t update manually at command line.

I have been trying to replicate @Buddhafiner setup using a RPI4 and no soundcard. When I select Rpbi headphones in the webconf, I get a distorted sound at low volume when playing any synth engine. If I try to select the Audio Levels page, nothing happens, it simply stays on the Main menu. If I go to layers and long press a layer to select “Audio Output” I see the same screen showing 8 system playback lines.
Next I go back to the webconf and select Hifiberry Dac + Light and check the Rbpi Headphones box. After reboot I can select the Audio Levels from the main menu and turn up the Headphone volume. The result is no more distortion and I have a usable volume. I would have expected to get the Error screen when selecting Hifiberry Dac + Light, however the Zynthian works just fine. Now when I go back to the Layers and long press a layer to route the audio, I get the “Send Audio to…” screen and only have system playback_1 and system playback_2.

@ronsum , thank you for taking the time to replicate and confirming you are experiencing the same problems.

@riban , I can confirm I did initially try the audio test in Zynthian and it played the same very low distorted audio. The only Zynthian update I have performed was via the Web config. I’ll look into testing on another smaller SD card.

Cheers.

@Buddhafiner , another thing to try: go to the webconf and under Hardware Audio select Dummy Device and check the headphones box.

After a reboot, on your Zynthian navigate to the Main menu and select Audio Levels. You should then see the screen to allow you to turn up your headphones. I just tried this on my Rpi4 and it worked for me.

2 Likes

Houston… we have sound!

I almost thought it hadn’t worked because the filter cut off on the selected instrument was low. This is fantastic news, it’s been an epic ride, really do appreciate all the support on here.

Not gonna ask anymore questions, at least for tonight, it’s finally time to check out the Synth. <3

Massive thanks!

3 Likes