Mapping Midi Control Korg Nanokontrol 2

I’m just getting started please excuse if this is a newbie question…
I have set up some layers I’m very happy with:
1>SalamanderGP + Clone midi to channels 2,3,4,5
2>FluidR3 / Rhodes
3>ZynAddSubFX / Synth Pad 1 + Midi Filter Lower 2/3rds of keys
4>ZynAddSubFX / Synth Pad 5 + Midi Filter Lower 2/3rds of keys
5>ZynAddSubFX / FM Bass 2 + Midi Filter Lower half of keyboard

This makes quiet a nice layered set of sounds.
Question 1)
I’ve mapped the Korg to control the volume of each synth by going into each and moving from left to right across the volume control, then assigning it to a fader. The problem I have is when I then select the first patch the faders for the others don’t work. They only seem to work as I select each one. Is there some way for the faders to control all the volumes all the time?

Question 2)
I’d like to map the knobs to dial in reverb for each, I would like to do this by routing the output of each to a single Audio FX layer. No problem that is easy. Is there some way to control independantly the volume which goes to that Audio FX layer?

Question 3)
Is it only one effect per Audio FX layer, or can I create a chain within one layer?

Help much appreciated! Thanks, John

1 Like


  1. It may depend on the mode you are working in: single channel / multitimbral. I will let someone else tackle this one.
  2. You could add a “Gain 2x2” layer for each effects send you want, manually change input and output routing so that each synth feeds a Gain 2x2 plugin and all Gain 2x2 plugins feed the reverb then use the Gain 2x2 controls as effects sends. Use the mono Gain plugin for mono sources because there is a bug in Zynthian that causes some mono to stereo paths to get routed A-leg only. Remember to deroute the main audio input to each gain plugin and the reverb.
  3. You can create a chain of effects on each layer. Bold press on the layer and select “Add Audio-FX” from the context menu.

Attached is my example… Little bit of x-run. Maybe I’m pushing it too hard? Maybe worth getting a pi4?

Turning off single channel mode under midi options in the web interface seems to have acheived the control signals going to all channels - awesome!

Unfortunately I discovered that I mapped some controls to more than one layer… how to unmap?

You unmap by going through the mapping process but clicking BACK before sending a MIDI CC.

RPi 4 is definitely worth it. RPi 3 is not really up to the kind of features in Zynthian. You will certainly enjoy a more complete experience.

Now this is worrying but having saved my progress, which seemed so promising, when I got back to my zynthian this morning some of the mappings were different and I could hear another instrument playing from around middle c upwards. In the end I had to remove all the layers to make it go away! It’s like there’s a ghost in the machine!

Today I’ll try to retrace my steps and see if the same thing happens.

Hi @m0rvj!

I’m really interested in tracing and solving this issue, so please, try to reproduce and send the snapshot.

Thanks a lot for helping to debug zynthian!!