Midi Filter Rules: Keyboard Split + Single Channel Mode

I´ve tried to make a keysplit with my raspi 3.
But in single channel mode with split 45 or 59 I hear by sending ch1 or ch2 the sound 1 or sound 2 but not both dividet by splitpoint.

sry, don´t have an ui log

Hi @Micki!

When Single Channel Mode is enabled, the MIDI filter modify all input MIDI messages, changing the channel to the selecter layer’s channel. This is done in the first stage, so any rule you set will be applied to the modified MIDI messages.

The keysplit mapping rules you have created should work fine when you’ve selected the layer in channel 0 (aka 1) in your zynthian.

But when you change the “active channel”, it won’t work. You should configure the keysplit for every channel you have a layer in. I your case, channels 0 & 1 (aka 1 & 2).

Anyway, could you send the full rule list to confirm you are configuring correctly the keysplit?


I think cloning a second layer to the first one helps as well?
Or is this not working like the single channel mode?

I don’t think so … although it could be tested :wink:

No it´s not useable, because there´s no split. you hear both sounds.

Hi Fernando,
I´ve tried a lot of possibilities, but of coarse, it´s clear:
I send only one channel with the ch#0,
that signal is ruled, so that all note ons/offs less than 45 has to have ch#1.
No cloning, no single channel.

There are only the shown 2 lines with rules.
I´ve tried to record the midi commands using the midi log, but there is nothing to see…

Dear @Micki!

I just tested your exact configuration and it works like a charm for me:

MAP CH#0 NON#0:45 => CH#1 NON#0:45
MAP CH#0 NOFF#0:45 => CH#1 NOFF#0:45

What zynthian SD image are you using? Is it updated to the last?


In fact, if you use this configuration:

MAP CH#0 NON#0:45 => CH#1 NON#0:45
MAP CH#0 NOFF#0:45 => CH#1 NOFF#0:45
MAP CH#1 NON#46:127 => CH#0 NON#46:127
MAP CH#1 NOFF#46:127 => CH#0 NOFF#46:127

It will work also when “single channel mode” is enabled, given that you only are using these 2 channels.
With this set of rules you can change your active layer in the zynthian, for adjusting the layer controls, and the keysplit will continue to work as expected.


1 Like

I think it´s Aruk stretch.
I cannot update, there is a stop sign14

I will try the new rule :slight_smile:
looks good, doublesafe

But I have both sounds not splitted

You have to update your zynthian. This “update” symbol has not sense. It’s not from zynthian. It’s your browser or some kind of “malware” or “malware-protection”. Please try with another browser or computer.


I tried as well. It works in Non Single Channel Mode.
I just took the first two lines of Fernando’s rules.

I have seen the no-entry sign also. When the page first loads the “Update” button is disabled and hovering over shows the no-entry symbol. After a few seconds the button enables. Sometimes this does not happen. I have not figured out when or why. Maybe @Micki can raise an issue in the bug tracker with detail of the fault condition.

@mheidt, you programmed the update handler … do you know something about this symbol?

This means, that the client (javascript) didn’t connect to the websocket.
Refreshing the page should solve it.
if not, i would need the console log of the browser

Today I made an update direct with the admin window at the Z.
I took the first two lines and
I took all four lines: alwqys the same: no split


I can confirm an issue.
On my v2 kit, the rules work. But when I use a Rasp4 with MCP23008, the split doesn’t work.

I hope, I can provide more details later.

I tested with my rasbi3/MCP23008, latest buster build. generally it works.
But I get hickups.
I used a D50 as Master and that one sends CC123 with every Noteoff and Pitchwheel0 with NoteOn.

When I play trills in the split zone (one note left, the other right), it seems that the CC value of 123 is used as NoteOff value
CH#11 NOTE_ON 59, Vel: 60
CH#11 NOTE_OFF 59, Vel: 64
CH#10 NOTE_OFF 60, Vel: 64
CH#10 NOTE_ON 72, Vel: 60
CH#10 NOTE_OFF 123, Vel: 64
CH#11 NOTE_ON 59, Vel: 62

or worse:
CH#10 NOTE_ON 68, Vel: 60

I only pressed 59 and 60…


I found the bug.
@Jofemodo, if the midi profile name contains a blank, it is not loaded.

but regarding my trill hickups, it’s a kind of magic.
Same machine with a jessi (updated to last) image doesn’t have any issues.
The faulty buster image doesn’t have issues with a USB master keyboard, that doesn’t send the CC123.