New build, can not boot

Hi, I just received my Zynthian 4.1 and built it according to the wiki guide.
I double checked all connections, and put on my sd cards the latest stable build.

When I power it the screen lights on, but nothing shows up.
I suspected it was a software issue, since the hardware connection seemed ok.

Took me a while to get off the sd card, actually I had to unbuild a couple of pieces, its very very hard to reach through the bottom. :smiley:

Anyways I am trying the sd card on a different Pi4, with nothing connected, I wanted to see if it would boot, and connected it to a monitor.

I can see the boot process starting but then for a second the login prompt appears and the system then reboots. This goes on and on. I tried reformatting the card but same result.

Should I try an older version of the distro?
Any hint.


The latest stable build works perfectly with the official v4 kit.
Could you try accessing to the webconf from your computer? You have to connect your zynthian to your local network and then browse to:



  • What power supply are you using?
  • What SD card (brand, model and capacity). Is it new?

Yes, it can takes a little bit, but i NEVER open a case for extracting/placing the SD card. It’s perfectly doable with a little bit of practice. A pair of curved plies could help you with this, but i normally use my fingers without too much problem :wink:


Thank you @jofemodo so very much. I recreated the sd card,removed the ribbon connector and placed it back again, and then it worked! I am now very happy, thank you so much.

Looking forward to exploring the zynthian!


Great @smarques !
We are waiting for your :face_with_monocle:

Tell me if you have more problems with the ribbon cable and i will send you a new one. We buy the IDC connectors by hundreds from china and although we test every single ribbon cable we build, some IDC connectors are randomly faulty.


Also experiencing a similar issue. Preface: I have attempted booting the 09/15 image from two 32gb MicroSD cards (Samsung and Sandisk) one being written using Etecher and the other created with USB Image Tool. I have also attempted writing the latest release.

It seems that on every occurrance regardless of either SD being booted from a Raspberry Pi 3 or 4 (using official usb-c power), it shows the usual wall of text and then the login prompt which is auto-logging into the ‘zynthian’ user then proceeds to a blank / black screen with a cursor in the top left corner (non-blinking, assuming it attempt to load the GUI) then cycles back to the previous screen, then again to the blank cursor screen and loops continuously.

Note: I am able to access the web config via a browser using the dhcp ip address of the pi and it appears to load as normal.

Update: I have switched the Display: Generic HDMI Display and now getting the ‘Zynthian’ image with a red ‘ERROR’ and below an IP overlay. Attempted performing an update via the web gui and issue has reproduced.

Any ideas what could be breaking here?

You need to configure the audio device. The default is to expect the HiFiBerry DAC+ADC STAGE.

Neglected to mention. I have been following Floyd Steinberg’s video as well. Went ahead and plugged in the Behringer U-control UCA222 and have set it to Generic USB Device in web config;. Also attempted adding the line to .jackdrc “-P70 -t2000 -dalsa -dhw:USB Audio CODEC -r44100 -p256 -Xraw”. The error looks to be present even after doing so.

Go back to the Web Config and instead of selecting Generic USB Device, try selecting Behringer Uca222.

1 Like

I forgot to mention, if you don’t have encoders, you will need to set wiring to Dummies.

1 Like

This worked. I owe you beer.

We’ll take it in :face_with_monocle:

Last thing, maybe. Now that this one is outputting audio via test menu, it still does not get midi response from Novation REmote MK2 on ch1. (from menu > midi test also working)

I will be taking this sd and bringing to a rpi3, and burning a new image for rpi 4 (to be installed to Zynthian case). Is there anything I must take note of? It should boot just the same to my understanding.

Are you using 5-pin MIDI from the Novation or USB MIDI?

The image will work with Raspberry Pi 3 or 4. Remember the form factor for the 4 changed with its network / USB ports swapped.

Build is complete. Audio output is function as is midi with REmote hooked direct to it via USB and using latest OS build. Wifi also working too now, apparently. Can’t wait to get the ZAQuencer hooked to it.