New engine Jalv: LV2 plugins as standalone layers


#22

It’s not an easy issue, as every plugin use different names for “volume” controllers. Some plugins doesn’t have a “volume” LV2 controller port, but listen MIDI CC7 or CC11 for volume, CC1 for mod-wheel, etc. Anyway i’m working on a good solution, but it’s not so easy:

Currently i’ve added the possibility of specifying (hardcoded by now) a list of standard MIDI controllers for every plugin. For instance, i’ve defined such a list for MDA ePiano, MDA Piano and MDA DX10.

If you know of other plugins listening MIDI-CC , please, tell me and i will add it to the list.

I hope to improve this system by allowing to specify a “LV2-native” volume controller, or adding some heuristics for finding the right controller in the plugin’s list. Simply try to find some “standard names”:

  • volume
  • gain
  • level
  • more?? :wink:

Kind Regards,


#23

Hi @Zynthianers!

Great News Again!

  • @mheidt has created a configuration tool for the new Jalv engine. The tool allows to enable/disable the plugins you want to use with the Jalv Engine. Thanks a lot, @mheidt!!

  • The new Jalv engine is now merged with master branch. Those of you that changed to “jalv” branch for testing, you should change-back to master like that:

    cd /zynthian/zynthian-ui
    git checkout master
    /zynthian/zynthian-sys/scripts/update_zynthian.sh
    reboot
    

If you didn’t change to jalv branch for testing, just update your zynthian software using any of these options:

  • from the zynthian’s Admin menu
  • from the webconf tool
  • from the command line

If it doesn’t work, update again. If still failing, you should reboot and try again.
If still doesn’t work, try burning a new image and updating. :wink:

Enjoy!


#24

Yep - I see, not easy to solve. How about adding a stereo volume knob “behind” the generator as a default for jalv? So you have a dedicated and well know volume knob…

Regards, Holger


#25

It’s the great zynthian mixer debate all over again !! :smiley:


#26

Yes, of course. This is in my list too. :wink: The final solution will include it when need it, but i don’t like the idea of having an extra when no need for it.

Also, there is the need of a global volume. I’m thinking about the possibility of adding a phisical slider to the design. Perhaps an horizontal slider in the case-top. What do you think about?

Regards


#27

Have updated and while I can see the plugins in the interface, I can’t load them*. Have run the update scripts, and I wasn’t on the test jalv branch. Before I try a new install here’s the debug log in case anyone can see the problem:

xorg-debug.txt (61.7 KB)

*Edit: MDA epiano, MDA piano, MDA DX10 are the three that are working for me


#28

The same for me…


#29

Is this an external stereo volume pot or a software driven AtoD to Jack overall volume and if so will Midi be able to drive it?
I’m not keen on sliders they are too easily knocked…


#30

the same thing happens to me


#31

hi @jofemodo, if finding issues, where do we write? in meantime i write here.

  1. LV2 mda piano (at least i tried with it) if put on a second layer with different midi channel and correct clone on channel 1, does not load sound. it must be assigned to same channel midi, then re-changed to second channel, and now clone works. i know could have been unclear.

#32

confirm to me too. same engines.


#33

Hi @zynthianers!

Sorry for the “last-minute-bug”. I added a “last-minute-feature” and didn’t test correctly.
It should be working now. Just update again :wink:

Enjoy!


#34

Thank you very much…but for me the system hang on Midi channel selection (for those engines)


#35

Same for me: hangs on the midi channel select. Here’s the last bit of the log:

...
ROM4A__25__VOICES => https://github.com/dcoredump/dexed.lv2#ROM4A__25__VOICES
ROM4A__20__STGS_5THS => https://github.com/dcoredump/dexed.lv2#ROM4A__20__STGS_5THS
ROM4A__23__RECORDERS => https://github.com/dcoredump/dexed.lv2#ROM4A__23__RECORDERS
ROM4A__21__BELLS => https://github.com/dcoredump/dexed.lv2#ROM4A__21__BELLS
ROM4B__30__..GOTCHA.. => https://github.com/dcoredump/dexed.lv2#ROM4B__30__..GOTCHA..
DEBUG:root:ZCTRL 'Channel': 0 (0 -> 16), None, None
INFO:root:Short Switch 3
WARNING:root:zynthian_gui.zyncoder_read() => 'NoneType' object is not iterable

#36

@jofemodo, the same for me. MDA piano and some other plugins work without any problem, but Helm, Dexed, OBXD and others - hang the device on MIDI channel selection step.


#37

Sorry guys! Yesterday i tried to solve the problem from home, without a real zynthian for testing. It didn’t work :blush:

Now it’s fixed and tested, so it should work!! Please update and confirm.

Regards,


#38

Works here! Thanks for the fixes :100:


#39

Now is ok thank you very much @jofemodo !!!:smiley:


#40

Worked for me too ! :)))


#41

already if it works, thanks