New engine Jalv: LV2 plugins as standalone layers


#42

working for me too… but, anyone experiencing broken snapshots?
they don’t load.

i tried to see thru ssh debug:
DEBUG:root:ZCTRL 'Layer': 0 (0 -> 4), None, None ERROR:root:Invalid snapshot format: 'zynthian_gui_engine' object has no attribute 'engine_info'

actually this snapshot was saved brand new. not an old one maybe before updates.
Any snapshot reports this error of "no attribute ‘engine_info’


#43

It should be fixed now. Update and try again :wink:


#44

hi there having enormous fun with this. one thing though i am trying ‘GX cabinet’ amp and cab simulator with audioinjector and need to start qjackctl in order to connect the patch cables or no sound. many thanks :slightly_smiling_face:


#45

Then we need to add some connection tool inside Zynthian-UI … :wink:


#46

works :slight_smile: i’m testing for other issues


#47

I have some problem with new engines
Every new listing - freezes the UI back function or any encoder does not work I have to unplug it to reboot it.


#49

Did update few mins ago and problem persist
Any body experiencing the same issue.?


#50

Hi @BalamSoto!

I can’t reproduce your problem. Could you be more specific? I would need an “action sequence” that reproduce the error.

Perhaps your Jalv version is not updated to the last … could you try this?

cd /zynthian/zynthian-sw/jalv
git pull
./waf
./waf install
reboot

regards,


#51

Thanks
Here is the sequence from the zynthian device
Did update from main tools interface
Updates were install according to script
Reboot
Add new layer - selection from new list
User interface freeezes , encoders get irresponsive
To get back to a functional interface I have to do a cold reboot
I was under the impression that updating from zynthian interface will collect and install all necessary updates.
I am away from my computer to do ssh now

Hope this description is clear

Best


#52

Hi @BalamSoto!

It’s pretty clear, but i can not reproduce the error. Try:

  • Updating Jalv as i told you above
  • Deleting default snapshot if it exist. Old snapshots could fails in strange ways.
  • Update Software from CLI and see if everything is really installed.

If nothing works, please, send a log-dump or … re-burn your SD card and update again.

regards,


#53

Hi there, I’m having a similar problem to BalamSolo, but I’m using emuface on Fedora 28 so there are many more moving parts. I’ve tried with the distro jalv and you’re zynthian one. What I’m seeing is the lv2 plugin loads, but then something doesn’t set the zyngine variable, it seems fine in the zynthian_engine_jalv.py, but it’s missing by the time it gets to autoconnect which then can’t find the jack ports to connect to it. Log below:

INFO:root:Short Switch 3
INFO:root:NO REMOTE DISPLAY
INFO:root:Starting Engine Jalv/MDA ePiano
DEBUG:root:Plugin Name => MDA ePiano
DEBUG:root:Plugin Name => MDA ePiano
INFO:root:Getting Controller List from LV2 Plugin ...
DEBUG:root:proc output:
\info_controls
INFO:root:Getting Preset List from LV2 Plugin ...
DEBUG:root:proc output:
\get_presets
DEBUG:root:ZCTRL 'Channel': 0 (0 -> 16), None, None
INFO:root:Short Switch 3
INFO:zynautoconnect.zynthian_autoconnect:Autoconnecting Midi ...
DEBUG:zynautoconnect.zynthian_autoconnect:zyngine: None
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib64/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/home/baggypants/zynthian/zynthian-ui/zynthian_gui.py", line 464, in zyncoder_thread_task
    self.zyncoder_read()
  File "/home/baggypants/zynthian/zynthian-ui/zynthian_gui.py", line 482, in zyncoder_read
    raise err
  File "/home/baggypants/zynthian/zynthian-ui/zynthian_gui.py", line 478, in zyncoder_read
    self.zynswitch_defered_exec()
  File "/home/baggypants/zynthian/zynthian-ui/zynthian_gui.py", line 442, in zynswitch_defered_exec
    self.zynswitch_short(event[1])
  File "/home/baggypants/zynthian/zynthian-ui/zynthian_gui.py", line 396, in zynswitch_short
    self.screens[self.modal_screen].switch_select()
  File "/home/baggypants/zynthian/zynthian-ui/zyngui/zynthian_gui_selector.py", line 238, in switch_select
    self.click_listbox()
  File "/home/baggypants/zynthian/zynthian-ui/zyngui/zynthian_gui_selector.py", line 235, in click_listbox
    self.select_action(self.index)
  File "/home/baggypants/zynthian/zynthian-ui/zyngui/zynthian_gui_midi_chan.py", line 99, in select_action
    zynthian_gui_config.zyngui.screens['layer'].add_layer_midich(self.list_data[i][1])
  File "/home/baggypants/zynthian/zynthian-ui/zyngui/zynthian_gui_layer.py", line 147, in add_layer_midich
    zynautoconnect.autoconnect()
  File "/home/baggypants/zynthian/zynthian-ui/zynautoconnect/zynthian_autoconnect.py", line 290, in autoconnect
    midi_autoconnect()
  File "/home/baggypants/zynthian/zynthian-ui/zynautoconnect/zynthian_autoconnect.py", line 130, in midi_autoconnect
    ports=jclient.get_ports(zyngine.jackname, is_input=True, is_midi=True, is_physical=False)
  File "/home/baggypants/.local/lib/python3.6/site-packages/jack.py", line 1327, in get_ports
    self._ptr, name_pattern.encode(), type_pattern, flags),
AttributeError: 'NoneType' object has no attribute 'encode'

INFO:zynautoconnect.zynthian_autoconnect:Autoconnecting Midi ...
DEBUG:zynautoconnect.zynthian_autoconnect:zyngine: None
ERROR:zynautoconnect.zynthian_autoconnect:'NoneType' object has no attribute 'encode'

#54

I am a chump!

I checked out the zynthian jalv but forgot to checkout and compile the zynthian branch and compiled the master branch instead!


#55

Right now, the file generated by webconf does not fit the expected format used by zynthian-ui.
@jofemodo will tell you when it works again.


#56

The Zynthian-UI is modified according to the last webconf changes. It works again :wink:


#57

would this be usefull to connect audio ins and out automatically- :face_with_raised_eyebrow:


#58

Zynthian has its own auto-connector from the very beginning. It’s a key part of Zynthian as we need to control carefully the way everything get connected, MIDI & Audio.

Anyway, thanks for the link. I will take a look and take interesting ideas … :wink:

Regards,


#59

of course zynconnect should have known apologies. :face_with_hand_over_mouth:


#60

Would it be possible to have a script to run for lv2 discovery instead of the webconf?


#61

Why do you need it? You could take a look in the source and build your own


#62

Just because I’m finding running the webconfig in Fedora difficult due to the lack of python3-lilv for some inexplicable reason (python2-lilv exists, but that leads to other odd problems). I’m sure I can pull the appropriate bits out of the code though so don’t worry.