New feature: Peak Meter on status bar

Hi @zynthianers!

Good news! Our recently incorporated, but very talented member, @riban, has been working in a nice peak meter for our beloved zynthian status bar. It replaces the current CPU-meter, although it’s optional and you can re-enable the CPU-meter from the webconf tool.

Congratulations for your work, @riban … and thanks a lot!!

Update & Enjoy!!

7 Likes

Hi @mheidt!

I just added a task on webconf repo for implementing this option.

Thanks!

@riban, could you give here the current specifications of the Peak Meter? DB ranges, times, decay ramp, etc.

Do you think could be interesting to have the possibility of customizing some of these parameters?

Thanks,

The meter covers the range -50dBFS to 0dBFS, i.e. maximum permissible level at full scale (far right) down to 50dB below that at far left. The green bar covers the range -50dBFS to -10dBFS. The yellow bar covers the range -10dBFS to -3dBFS. The red bar covers the range -3dBFS to 0dBFS. There are independent meters for left and right channels which monitor the system output, i.e. the mix of audio that feeds the Zynthian output. (There is the ability to change what is monitored using the audio routing features of Zynthian.) Level decays with a logarithmic rule, taking one second to decay to -200dBFS so will decay to -50dBFS (the displayed range) in about quarter of a second. Peaks are displayed instantly, i.e. the attack of the meter is immediate*. The peak hold bar remains for two seconds or until a higher peak is reached.

  • Meter is updated 5 times per second so there could be 200mS delay in peak being displayed.

I think we should garner user feedback then configure with parameters that provide the best indication of level to meet user requirements. I think that providing user configuration of meter dynamics may prove a support burden with little benefit. Once you have a meter that works well then most users will be happy. I don’t know of many users that requested they could change the dynamics of their VU meters in their cassette machines!!!

6 Likes

Totally agree with you! :ok_hand:

:rofl::joy::star_struck: You are of my generation! My kids have never seen a cassette!

1 Like

How many people don’t have any clue about the origin of the “PLAY” symbol on their brand new digital thingamabobs :smiley:

(or the SAVE icon… )

No words:

1 Like

My kids saw a 3.5" floppy disk on the table and said, “That looks like the save symbol”! :rofl:

3 Likes

You are all youngsters… . . . :face_with_monocle:

This Is a video recorder . . . .

3 Likes

Back to business:

I just updated (a newly installed SD card from sunday, base )zynthian_gorgona_omega_rbpi3_kitv2-2018-04-03.img + updates from sunday). After the update from today I tried to reboot but the reboot failed: screen was dark but Pianoteq was still running background. So I made a hard-reset (unplug-plug :zap:):

Zynthian logo was on the screen for some seconds, than screen was dark. No network -> no login. Hmmm… after conecting a monitor to HDMI I could see that Raspi boots and after that a shutdown was directly started - to fast to see what was going wrong…

Anybody else?

Will try again with the same procedure…

The quadruplex tape… you’re a dinosaur, aren’t you? :smiley:

And talking about dinosaurs, my first videorecorder was a 40 KG Sony UMatic BVU800 that a friend gave to me… and that I never used, because of the “too professional to be useful in real world” video inputs it had… but I loved the front panel in perfect Death Star Weapon Style :wink:

1 Like

Sony Service…my old job :cry:

1 Like

And again a reboot problem… before rebooting I started Pianoteq. It worked but no Peak meter was displayed on the screen. Than I tried to reboot and the screen freezes after saying “YES”. My ssh login was disconnected.

So: Power cycle. After this power cycle Zynhtian comes back again.

What is going wrong here?

I have had similar recently. Power cycle required to fix. Sometimes due to seg faults. I think clearing the python cache files may have helped but not sure it was consistent. Do you think it related to this thread (peak meters)? I think my issues started before starting work on this feature.

Note: You may need to update twice before audio level meters work. The first update seems to install the code and the second seems to build the code. Also may need to reboot the device. @jofemodo does this need attention?

Sorry guys! I forget to say that :flushed:
Yes, It’s exactly as riban says.The update script needs some improvements.
If you only updated once probably you get an error screen or a “dead” status bar.

I will improve the update script ASAP for avoiding the “update-twices”:

Regards,

Sorry, I was always an Ampex child…
VPR-3’s ruled the world!!! :smiley:

Till betacam SP & D1…

As has been hinted I AM quite old!!

1 Like

Yes, you may be right… I have this behaviour since the last update, but this probably just accidental.

I am not a python pro. Can you tell me how to cleanup the python cache?

Regards, Holger

Animated cassette image while recording active please. :rofl:

1 Like