New Features: Improved Audio-Routing + Pianoteq Fast Preset Loading


#21

yes… i noticed :sweat_smile::roll_eyes::expressionless:
even it’s strange, i made that snapshot with effect layer right after update… but by now it works even mine, brand new

Ok, thanks.


#22

oh, there’s another little issue, but it’s plugin related: sooperlooper jv2 doesn’t catch midi mapping… other plugins do normally. is it a known issue?
Regards
(i’m still writing here… should i open new topics in another section? )


#23

Hi @ivanmonterosso!

You are right. There was a problem with MIDI learning and “labeled” controllers.
Update your software and tell me if it’s working now :wink:

Thanks,


#24

Hi @ivanmonterosso!

You were right with the first error too. I found a bug that prevented to load snapshots using certain combinations of plugins. It’s solved now :wink:

Thanks a lot for your help with debugging!!


#25

Hi Fernando,

I just updated and there was no option for a Pianoteq layer anymore :disappointed_relieved:

Has anyone else this problem, too?

Regards, Holger


#26

Hi Holger!

My fault! It should be solved now. Try updating your software again and restarting UI :wink:

Regards,


#27

:star_struck: many thanks, it works again!


#28

Yep… actually Yesterday i had same error with a brand new Snapshot… but didn’t have time to post it here… Ok Will update ASAP…so could happen with random plugins ? …i Would try as many as possible and report it :joy:


#29

Great!! Please, do it!! :wink:


#30

Ok, just started for real :smiley:

  1. there is some weird behaviour with sooperlooper lv2. Now midi learning works, but once loaded, plugin does not appear in Audio routing list under synth layer. So, no sound can be processed.

attached my snapshot, in case of issues in reproducing error…
002-test looper lv2.zss (2.3 KB)

  1. All zyn effects saved on snapshots are bad. but…you fixed zynverb, and loading first a snapshot with it, fixes the others effects :smiley:
    Any idea?

  2. sometimes in routing list effect of previous snapshot is already there. if chosen, it loads and works :open_mouth: but it’s not present as effect layer.

In meantime, a little suggestion:
Once added an effect layer, could it be routed by default on first synth layer (and same midi channel, of course) instead of doing it manually?
I mean: when adding an effect layer, there’s no way to previewing it instantly over a sound. Maybe could be good to use it on the fly…
By now I must go back to synth layer, bold click and route to loaded effect. Would ever do This complex operation in case of multiple effect assignment, but until that the first synth layer is the perfect candidate for previewing effects… what do you think?
regards


#31

Hi @ivanmonterosso!

I’ve been working in this and i think you will love the result … although the code is quite fresh and can have some bugs… but i’m pretty sure you will help me to debug :wink:

Now, when an effect is created, it’s chained to the end of the FX-chain. Basically, it’s connected to the last plugin currently connected to “system” output.

When an effect is deleted, then the FX-chain code try to rebuild the connections in a “logic” way: It connects the output from the upstream plugin with the inputs of the dowstream plugins.

Of course, it’s far from perfect … but it’s a good starting point … and quite comfortable compared with having to connect everything by hand.

So, please, update your zynthian software and enjoy!! :sunglasses:

Kind Regards,


#32

sure i will do with pleasure :slight_smile:


#33

Hi @jofemodo , i just updated for a try, but don’t see changes … effect stays unassigned on synth routing list… i’m on master branch. :thinking:


#34

Ups!! I missed to “push” the changes. Try now! :wink:


#35

yes… it works, and it’s wow :smiley: … will try some combinations to see if there are issues.


#36

what is this new single channel ON/OFF function?


#37

I don’t know, and I’ve read the manual and everything (perhaps if I looked at the code …? ) . . .:roll_eyes: .

root@zynthian-amp2:/zynthian# grep -r “ZYNTHIAN_MIDI_SINGLE_ACTIVE_CHANNEL” --include=*.py .
./zynthian-ui/zyngui/zynthian_gui_config.py: midi_single_active_channel=int(os.environ.get(‘ZYNTHIAN_MIDI_SINGLE_ACTIVE_CHANNEL’,0))
./zynthian-webconf/lib/midi_config_handler.py: [‘ZYNTHIAN_MIDI_SINGLE_ACTIVE_CHANNEL’, {
./zynthian-webconf/lib/midi_config_handler.py: ‘value’: self.get_midi_env(‘ZYNTHIAN_MIDI_SINGLE_ACTIVE_CHANNEL’)

And in the webconf file mentioned above…

[‘ZYNTHIAN_MIDI_SINGLE_ACTIVE_CHANNEL’, {
‘type’: ‘boolean’,
‘title’: ‘Map external events to Active layer/channel’,
‘value’: self.get_midi_env(‘ZYNTHIAN_MIDI_SINGLE_ACTIVE_CHANNEL’)
}],

So it should:

Map’s external events to Active layer/channel.


#38

Exactly! With this feature, you can change the instrument you play by simply changing the active (selected) layer in your zynthian. You don’t need to change the MIDI channel in your keyboard. You click “layer” (chan) button and the next layer in the list will be selected and receive all MIDI events. This is very convenient on stage, specially when your keyboard doesn’t allow to change the MIDI channel easily.

Regards


#39

Thanks jofemod, Pianoteq is working again for me as well.

(I wanted to demo it at the next electronic mudic producer group meet in California, run by a guy named Holder)

Regarding the Pianoteq Mod-UI plugin, a partial enhancement I could live with to provide more than the single Piano sound, would be user settings defined by taking a snapshot of the currently active Synth Layer of Pianoteq, (instead of crafting a full setting UI in the LV2)


#40

hi … some suggestion regarding single channel feature:

Let’s assume There are several engines on several channels with a sooperlooper layer added as Mod. I must switch cyclically through layers, but passing on Mod (in or out) causes break of entire recorded buffer.
This is because of sound/note off when switching between layers.
And it must go this way.
But maybe it’s wrong with Special Layer.
What do you think?
Regards