New features: Mixer Panel + MIDI player BPM control

yes, the problem is, that MIXER is layer 0.
Old Snapshots won’t work. I have preload-snapshot selected…

OK! I will see if i can fix it …

BTW, i’ve updated the wiki’s documentation with the new features:

https://wiki.zynthian.org/index.php/Zynthian_UI_Users_Guide

Feel free to edit and improve :wink:

It should be solved now :wink:

…and don’t think I didn’t hunt for it … :face_with_monocle:

Hello,

This is about Mixer layer.
With V2 kit with DAC+ sound card, under Mixer menu, I can see much more settings splitted into 4 pages (MX#1 to MX#4) than in post New features: Mixer Panel + MIDI player BPM control.

As a not so familiar with alsa user, It is not easy to figure out how to set these parameters (de-emphazing, filters, ramp up/down, …).
Would it be possible to have a description of each setting and a possibility to come back to default configuration in case we messed-up something ?

1 Like

Simply go to webconf audio config, click “save” and reboot. This will reduce the number of mixer controllers shown in the UI :wink:

A configuration tool for the mixer is on the way …

2 Likes

Yes I did it, but still I have a lot of mixers or settings.

Am I doing something wrong ?

Delete the default/last snapshot and reboot …
You can simply “disable” the “Restore last state on startup” feature on webconf UI options, reboot and enable again …

1 Like

It didn’t remove the additionnal settings.

Not a big concern, It seems that these settings are not impacting the sound so much.
Just that I want to understand what is their purpose. Probably I need to learn more about alsa and Hiffiberry.

Having digital volume control is nice anyway.

If you saved the audio settings in webconf and delete the default/last-state snapshot, it should only show the controllers configured in webconf.

Got it !

I saved kit V2+ again in web conf, rebooted and now I only have two mixers : Digital and Analogue on/off.

:slight_smile:

Today i firstly saw the “MIXER” in the display.
I only see MX#1 with PCM. I can control it perfecty, also with CC-Controller via Midi-learning.
So I´m looking forward to use the Mixer-Edit-Tool (that´s on the way :sunglasses: )

Or is it possible right now to configure the Mixer-Display for
Behringer UCA-222, Audio-Input-Volume?

It would be very helpful, if I can configure the drums-vol-poti and the drums-bpm-poti also in Mixer-Display… :face_with_monocle: :smiling_face_with_three_hearts: :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:

Last news: a lot of hanging notes …try to delete MIXER

Hello,

On the touchscreen, I noticed that the Mixer seems to be still the first layer when I create a Mod UI layer (whereas it is the second one if I create a synth or an effect layer)
It seems to induce some problems:
After creating the layer, I don’t access directly to its preset selection, instead of that, I see Mixer’s UI.
I need to push back several time and go to Mod UI layer to choose a preset.
It also seems to induce some freese or crash, particularly when removing the layer or changing the preset.

Could it be a corner case of same problem ?