New Raspberry Pi 3 B+ variant


#1

Hmm. GigEthernet (limited to about 350MBit due to hardware limitations) and 1.4Ghz cores. Not more RAM. Ok, better WiFi and some smaller goodies… but altogether not a big step.

Regards, Holger


#2

10% better performance. Guess we need any single percent for Pianoteq 6.1


#3

I’m a bit disappointed with this. I don’t have any RPi applications where I’ve hit any performance problems with Ethernet so those improvements don’t help. I know that the RPi Foundation likes to make incremental steps, but regularly rolling out slight upgrades just slows them down from making more radical upgrades. Let’s hope that RPi 4 brings more…

But it would have been nice if they’d included an audio codec. It would have simplified Zynthian!


#4

The audio codec wouldn’t have met our requirements. And isn’t there one on board anyways?
I am dissapointed, that it doesn’t have 2GB RAM.


#5

The problem of the current Raspi is that the software runs very good and stable. But it is limited to the current hardware design. So the only thing they can do is to change external periphals or use the same CPU with a higher clock rate.

A significant change (more cores, more memory,…) can only be done with a change of the good tested Raspian and (perhaps) other hardware incompatibilities… but I think they are working on this.

Regards, Holger


#6

I am buying one and will test if Pianoteq will run better than on the normal 3B.

Regards, Holger


#7

is there any progress with 6.1?


#8

Modartt released a fixed version which supports the switch “–mutlicore max”. This seemed to work for me. I have to add this into the engine. Currently I have not much time - I hope to fix this at the weekend.

Regards, Holger


#9

Added “–mutlicore max” now.


#10

Have one and will test it the next days/weeks.


#11

Ok, tried wit ha Zynthian image: No - does not work - even sdoes not start :neutral_face:

So I updated to stretch and booted again: better… but webconf and zynthian won’t start. Only after reinstalling some packages I got it running:

apt update && apt dist-upgrade -y 
apt autoremove
apt install -y --no-install-recommends python3-jack-client python3-liblo python3-requests python3-websocket python3-jsonpickle
pip3 install tornado
pip3 install tornadostreamform
pip3 install alsaseq

Ok, looks like it works… not tested all engines. MOD-UI has problems… lot’s of work for the next months :wink:


#12

Did you use CustomPiOS? @guysoft compiled against the new rasbian already, iirc


#13

No - I used the “hard” way :tired_face:

Will now try with CustomPiOS.

Regards, Holger


#14

Notw there is a known bug and a workaround:


#15

not really. Hi will update-zynthian and then its gone.


#16

@guysoft: thanks for this info! I only had time to take a fast look at everything. It seems to work. I had strange trouble to start some engines. MOD-UI blocked the system. After a hard reboot it worked. Strange.

I also installed Pianoteq and tested: worked, too.

So I can confirm: normally ZynthianOS works on an RPi3. But more tests are needed to understand why sometimes the start of engines is blocking my system.

Regards, Holger


#17

Did the Pianoteq Demo work? I had problems. But I didn’t test lately


#18

Yes, I can confirm Pianoteq is working after uploading. Some MOD-UI pedalboards are not working (like OXBD or NoizeMaker) - perhaps because the LV2 plugins are not installed?

Regards, Holger


#19

I’m trying to test the new RBPi3 model B+ …

OK, i burned an Gorgona Omega “Release Candidate 3”, boot with an old RBPi3 model B and run rpi-update. Reboot (always using the old RBPi model B) and … surprise!!

After installing the new firmware, Pianoteq performance is seriously degraded. You can’t play with the current parameters (22KHz + 32 voices) … ;-(

I’m testing with other engines, trying to figure if all engines are affected or it’s a Pianoteq-only problem.

@C0d3man, @mheidt, could you confirm this behavior?

Thanks


#20

It doesn’t seems to be affecting other engines …