New SD image setup script


#1

Hi @all!

The new SD image release is really near now, but it will take some days yet. I hope it will be ready for Christmas! Jojojo!
Those of you that don’t want to wait more, can build your own image and help me to test the building script. The script is quite big and take some hours to complete, but at the end, you will have a brand-new Zynthian SD image, with a lot of new features like:

  • NEW! MOD software integration (MOD-UI + MOD-HOST). Thanks to @C0d3man for his huge contribution to this new feature!!! => You can access your zynthian from the browser: http://zynthian.local:8888
  • NEW! Lots of LV2 plugins, including the @C0d3man’s DeeAxe7. I hope to include the @C0d3man’s Dexed-LV2 in the final release :wink:
  • Refactorized GUI that scale to any screen size. Customizable fonts (ttf) and colors.
  • NEW! Default snapshot that is loaded at startup => default.zss
  • NEW! Audio Test function (in Admin menu)
  • NEW! MIDI Test function (in Admin menu) => you have to load some synth before!!
  • Improved Network Info function
  • NEW! Auto-expand the SD partition on first startup => thanks, @C0d3man!!
  • Improved Setup Script that really works!!!
  • Lots of little improvements and fixes.

These are the instructions to build your new SD image:

  1. Download the minibian SD image => https://minibianpi.wordpress.com/download/
  2. “Burn” a SD card with the fresh minibian image. It’s only about 800MB.
  3. Boot up your zynthian/raspberry with the new SD and login as root: root, raspberry
  4. Download the setup script from the minibian terminal:
    # wget https://raw.githubusercontent.com/zynthian/zynthian-sys/master/scripts/setup_zynthian.sh
  5. Run the script. The script will reboot when it finish:
    # sh ./setup_zynthian.sh
  6. Login again and run the script again, this time, using screen (see note below):
    # screen -t setup -L sh ./setup_zynthian.sh
  7. This time it will take some hours to finish, so take a beer and relax. When it finish, you can boot with your brand-new Zynthian SD image :wink: Good luck!!

Note: If you get detached from the installation session (or detach by yourself with CTRL-A d), screen will continue the execution of the installation script in the background and you can re-attach with:

# screen -r setup

As i told you, the new image is not ready yet. This is what should be done before the final release:

  • Web configuration tool for a bunch of things, like system password, wifi passwords, soundcard model, wiring layout, color scheme, fonts, etc.
  • A initial set of MOD demo patches
  • Some nice zynthian snapshot demos
  • C0d3man’s Dexed LV2 Port, with a good amount of DX7 presets
  • Lot of testing and VERY IMPORTANT … don’t add more functionality to the list until the new release is out!!! :grin:

I will be waiting for your feedback!

Really Kind Regards!


Ive tried so much to get it working
New SD Image Update: "Gorgona Edge"
Using the synthian OS with different hardware
Ive tried so much to get it working
Building my Zynthian & Interested in PureData integration
#2

Hi @jofemodo,

very nice! Thanks a lot. I will try this tomorrow (hopefully).

I must say, that this software is written by the Team of MOD. I only have written “recipes” for using this software on a Raspi/Zynthian and ported some Plugins… more a job of trial and error (and understanding) than really creating something.

DeeAxe7 is the adapted version of the MSFA sound engine: a real nice DX7 compatible FM synth engine. It works but it needs some tuning. But when Dexed is running this engine may be obselete.

Dexed works and needs some slightly tuning - but there is a really strange thing: Sometimes the first instance does not create audio - but only on a Raspi. I hope I can fix this soon.

Regards, Holger


#4

The URL for wget gets the web-page and not the script :wink:. Better use:

wget https://raw.githubusercontent.com/zynthian/zynthian-sys/mod/scripts/setup_zynthian.sh

for downloading the initial installation script!

If your computer has the idea to go sleeping (as my has done) you should install screen and run the 2nd call of the installation script as the following:

apt-get install -y screen && screen -t setup sh setup_zynthian.sh

If you get detached from the installation session (or detach by yourself with CTRL-A d) it runs in the background and you can re-attach with

screen -r setup

@jofemodo: Maybe adding this to the setup procedure?

Regards, Holger


#5

mod-host didn´t worked for me, I sucesfully build the image, stopped /etc/init.d/zynthian, started manually qjackctl (with a UCA200) & mod-host.
It seems to start sucesfully, but i cant access from http (either ip nor “zynthian.local”).

some days ago I saw some recipes to manually start things… but I´ve lost them. Could you guide me to these, or some “recipe” to test things without having the full hardware (meaning, sound card or tft). I´d like to test the emulator also if possible. Thank you in advance!


#6

Fix for /zynthian/zynthian-sys/scripts/recipes:

Replace line 5 to:
cp phantomjs-on-raspberry/rpi-2-3/wheezy-jessie/v2.1.1/phantomjs phantomjs-raspberrypi/bin

Reason. repository file tree changed.

Regards, Holger


#7

Hi @C0d3man!

Thanks for your fixes. Both are right :wink:

  1. For the first one, I have fixed the download URL in my original post.
  2. For the second one, it’s now fixed in the repository.

Regarding “screen”, i also think it’s a good idea and i normally use it, but it can be confusing for not-sysadmin people. Anyway, people that knows what screen is and how to use it, quickly realizes that this is a good scenario to use it.

But let me think about it… Perhaps it should be included in the “standard” build instructions :wink:

Regards


#8

Hi @TontimerWeber!

The new script/instructions should work without problems. Please, try it again y dime que tal :wink:

Un abrazo!


#9

I know that screen is sometimes confusing. But for debuging it helps a lot, so I start my installation session for now with installing screen first and than using the following:

screen -d -m -L sh ./setup_zynthian

This has two advantages:

1.-d -m means that the session is detached in the background. If I want to go back to the session I only have to say screen -r and can see what’s going on. Going out of the session is done with CTRL-A d.
2. -L logs the output to the file screenlog.0 so I can look for errors or - if I don’t want to attach to the screen - I can type tail -f screenlog.0 and watch what’s currently done.

Regards, Holger


#10

Hi @jofemodo,

just tried again the full installation and got another (small) problem:

W: GPG error: http://www.deb-multimedia.org jessie InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 5C808C2B65558117

This can be solved inside ~/zynthian-sys/scripts/setup_system_rbpi_minibian_jessie.sh with adding the following line before calling apt-get update:

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 5C808C2B65558117

But it seems that nothing special is installed from this repository…

I checked my logfile an it seems that I get no other errors.

Regards, Holger


#11

Hi @jofemodo,

now I am testing playing on the system and have some problems with my encoders and MOD-UI:

  1. Where can I find the hardware-definition file for the encoders? I have to change the used pins becuase my encoders work reversed.
  2. Starting MOD-UI seems to start the web-ui but on the TFT only the waving moves some sconds and nothing else happens.
  3. Connecting to the web-ui and placing some plugins work, but I cannot connect any plugin to the audio outs on the right side.

Regards, Holger


#12

I haven´t any part from the kit, but after doing these changes I can start gui (no need to change fb1->fb0) simply ssh’ing, start qjack and running zynthian.sh (i´ve changed hw:0 to hw:CODEC in jackd line). ATM I didn´t manage to have any sound from MOD-HOST, due to audio card drops.

Very responsibe, I noticed I can use cursor keys and mouse to navigate up-down. There is, at least, some keys to ENTER and/or leave submenu?

BTW: even if you don´t change anything, thank you for your work!
(tios estoy como un niño chico el dia de reyes)


#13

Hi @TontimerWeber!

The Zynthian GUI is not intended to be used with a mouse and keyboard, so there are no keys for doing anything, only the standard keys associated by default by the GUI toolkit (tkinter).
Perhaps it’s a good idea to configure some keyabord’s keys… but also, you could test the emulator … or better, build a zynthian box :wink:

Enjoy!


#14

I´m a noobie, thanks for your understanding. Of course I´ll have one, just waiting for some aguinaldo (xmas gift in spanish)


#15

Jeje! Of course!! In the next revision i will create some standard keyboard shortcuts for the Zynthian GUI, so people can test the GUI from a standard terminal :wink:

Regards!


#16

Hi @C0d3man!

I have added your last fix to the setup script. Also, i’ve edited the original post and modified the second command to use screen.

Regards!


#17

Hi @C0d3man!

You have to put a “zynthian_hw_version.txt” with “PROTOTYPE-3H” in the “/zynthian” directory. Probably this will change in a few days :wink:

Yes. This happends because there is no pedalboards in the folder. I should copy some example pedalboards.

Yes. I’ve this problem too. I’m trying to figure what is the problem. I can’t see any problem in the installation process, o probably the problem is related to the last changes in the MOD software. Any help with this will be welcome :wink:

Regards!


#18

Hi @C0d3man and @all!

I’ve been tracing the audio output connection problem and i can see that mod-ui is trying to connect to “mod-monitor” instead of “playback”. And “mod-monitor” outputs doesn’t exist in zynthian, so this is the problem.
Searching in the mod-ui repository, i’ve seen that falktx has made, recently, some changes related to monitor outputs, so it should be easy to find the problem.

Regards!


#19

OK! The problem is solved now and the repository is updated :wink:


#20

Hi @jofemodo

many thanks for fixing!!!

Ahhh, ok - i thought it was a special problem on my installation. Just saw that there were much changes on mod-host. Hm - very strange what they have done. I currently have no idea for what the changes are needed - we will see. I think I will checkout an older version :wink:

Regards, Holger


#21

Better use the modified version from zynthian repository :wink: