No sound on usb-headset with zynthian+pisound

Hello, synthian is now running on my raspberry pi 4 with integrated pisound…i have configured pisound as soundcard, there is usb-headset from logitec connected, but can´t hear any sound.
As there are so many sound possibilities…i am not sure how it should works…i have also connected midi-keyboard oxygen61 to to raspberry pi4…the menu you can see on the original box from zynthian on their display isn´t shown on my pc -monitor…i only see zynthian.local as configuration tool…

documentation doesn´t show any solution for me, as i am a newbie on this.

thanks for help

To display the Zynthian GUI on your HDMI monitor, select HDMI from the Display option in webconf.

Hi Brian,
HDMI is activated, Pi is restarting…i suppose that zynthian gui isn´t that on the screenshot below.

Do i need to go to a terminal session and start zynthian gui with a command, and if yes, which one?

If you have seen HDMI in webconf, saved and restarted the Zynthian you should see the red and black interface on your HDMI screen plugged into the Zynthian (Raspberry Pi).

with webconf you mean the screenshot below or…a file somewhere?

on the hdmi-display which is attached to the pi, i just see for a second some information but nothing in red and black interface…it is to quick

maybe you have more details for me?

The usb headset will be a seperate audio interface which is why you’re not getting sound. You’ll need to switch the audio device from pisound to usb headset in the webconfig everytime you want to use it.

hm, ok, i have now configured usb-headset, but sorry…as i only get partial answers, it doesn´t help. Actually i only see configuration via zynthian.local, but i still didn´t find out, how to start the zynthian gui…i need a detailed instruction…


Plug an HDMI monitor into your zynthian Pi.

i did, but only see short that videosignal is connect to the pi, but can´t see details, only via connected pc i can see the webbased configtool…i need more support

select hdmi in the monitor selection.
it defaults to zyndisplay,.

my actual setting

Do you have an alternative hdmi monitor? or swap the cable? What you’ve done should absolutely work.

i have 2 other hdmi-monitors, but as this one works normal with the raspberry pi image, i didn´t thought about changing…will try tomorrow


Hi, i have put the hdmi cable on the first port next to the power supply, now synthian is shown with all features…when i have installed pisound…, but still no sound on the headset…will have to find out how to configure this, when pisound is activated… by changing on webconf to usb device, zynthian gui shows error, so i have configured to pisound again…and gui works…only sound missing, anybody in the world any idea? maybe i must add the usb-headset from logitec to a config file, but which and how? maybe one more information…the volume controls shows activity when i play on my keyboard, only sound is missing

Wich headset are you using ? the one from pisound (wich should work out if the box) or the one from the USB/audio adapter (wich should not work as is, cause zynthian and it’s audio streams management system -alsa/jackd- aren’t configured for such a use case).

Logitech usb Headset

You will need to identify the alsa device it represents itself as

aplay -l

on the zynthian command line should revela that. Then that will need putting into the webconf configuration as a custom device. If you search on Yeti in the forum you will see a similar process defined. . .

Just to clarify: running zynthian with two differents soundcards needs some tweakings and won’t work out if the box.

I only habe 1 soundcatd and 1 Headset

The zynthian needs careful routing when there are multiple, and their are in your case, audio input and output devices.
Indeed, it can be done but you need to use layers and careful input/output routing.