Official RBPi TouchScreen 7"


#9

Well I tried a few more images including the latest rasbian with pixel from january 11. There is no way I can make a single sound out of my sound card… obviously editing config.sys to enable the daq+ but then it seems the I2C times out and my sound card is not detected.

I tried it on rpi3 and an rpi2. do you need to enable the I2C specifically with or does the soundcard driver takes care of it…

I tried enabling and disabling those too…
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

but it still doesn’t work… It’s so frustrating…


#10

Some questions about your problem … :wink:
Could you send some photos of your setup? Have you soldered the 40-pin connector to the HB?
Have you investigated if there is some GPIO conflict between the HB and your display? Have you inspected the boot logs using the command “journalctl”? Have you checked that the drivers are loaded using the command “lsmod”? etc.

Kind Regards!


#11

Hi @jofemodo, @cryoshad,

I’m also working on this. Surfering the internet I’ve found Max2Play project. This project uses, among other devices, the Pi 7" Touchscreen and Hifiberry, so there should not be GPIO compatibility issues. By the way, it’s very interesting how this project deals with configurations through a web interface.

I downloaded and tested (without Hifiberry attached) M2P image. It worked (video and touch), obviously no sound at all. I tried this trying to find out the way to recreate the 7" touchscreen setup. No luck so far.

Regards, Jose.


#12

Hello just to report that I finally managed to make both the soundcard iqaudio and foundation 7’’ pi screen work together on my pi3.
It was apparently a power supply issue because as soon as I removed the screen …the card worked perfectly.

And when I connected my screen to the second (separate but common ground) port of my power supply I had both screen, pi and sound card work without a problem… :wink: so I can finally go back to trying to make the zynthian work…


#13

Congratulations! Hope to see (and hear) something from your Zynthian with a bigger display and audio input (V0c0der :robot:).

Regards, Holger


#14

Ok started with a new image
I did all what I stated above +

only left
99-fbturbo.conf in
/zynthian/zynthian-sys/etc/X11/xorg.conf.d
removing the 3.2 tft and the associatted touch

then added this file
sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf

Section "Device"
Identifier "touchscreen"
Driver "fbdev"
Option “fbdev” "/dev/fb0"
EndSection

and voila!!

now the middle (list section) is working and touch sensitive but the 4 side controllers do not :frowning:!

I am wondering if it has to do with

Wiring layout

hw_version=“PROTOTYPE-4”

since I don’t have any “physical” Zynthian hardware should I write sth else?

Thanks !


Introduce yourself!
#15

Hi @cryoshad!

Have you updated the zynthian software? You have to do it from command line, because you can’t access the admin menu:

cd /zynthian/zynthian-sys/scripts
./update_zynthian.sh
./update_zynthian_data.sh
systemctl stop zynthian
systemctl start zynthian

After that, the controller and topbar touch-areas should be enabled and you should be able to navigate without rotaries.

Regards


#16

Hi.

Nope… sry :wink: it seems that even after update only the central list is responsive no controller nor topbar…
update didn’t do error first time and now it says already up to date.

Sincerely…


#17

If “update_zynthian.sh” says “up to date”, then it should work. Have you restarted?
Have you modified some file inside “zynthian-ui” or “zynthian-sys” directories? In that case, you should restore to the original versions before updating:

cd /zynthian/zynthian-ui
git checkout .
cd /zynthian/zynthian-sys
git checkout .

Regards!


#18

Thank you I will try tomorow… I just got down in the menu and could try mod-ui from my computer. so much fun… and sound is great too!!

Cheers


#19

yep it works now…
I didn’t change those files except the last 2

but for some reasons the git “forced” pull did some magic and the controls now work and the top bar too.

Thank you so much!!!

here are the git changes I got…
Fast-forward
zyngine/zynthian_engine.py | 33 +±
zyngine/zynthian_engine_modui.py | 41 ++±
zyngine/zynthian_engine_zynaddsubfx.py | 8 ±
zynthian.sh | 15 –
zynthian_emu.sh | 76 ±----
zynthian_gui.py | 406 ++++++++++++++++++++++++++±-----
zynthian_gui_config.py | 6 ±
7 files changed, 418 insertions(+), 167 deletions(-)


#20

Hi @cryoshad, @jofemodo,

Finally I managed to get the engine selection window in my Pi 7" touchscreen. I think the step I missed is the file 99-fbdev.conf. However, I cannot make touch function to work properly.

I started with a fresh gorgona image, then updated (twice) manually using SSH. I did “git checkout” (just in case as it doesn’t hurt) and then changed all the files described above

I can select any item in the engine listbox by touch in it. I also can slide my finger (vertically or horizaontally) in the engine widget which cause the engine number in the widget to change. I noticed that, very often, when I select an engine in the listbox the engine number in the widget doesn’t change. The same happens the other way around…when I slide my finger in the widget to change the engine number the engine listbox doesn’t change.

But the main issue is the “enter switch” doesn’t work at all (unless me to do something wrong). That means I cannot move forward to the MIDI channel windows. Also, a long touch in the widget do nothing

At this point I wonder whether this behavior is software related or a configuration issue. I’m afraid it will be something I did wrong as @cryoshad has succed.

Any idea to light me up?

Regards, Jose


#21

Sry for my late reply… too busy playing with mod… :wink: I am not sure I understand the problem I can at least in mod change the controls and they would change realtime on my PC webbrowser and assign controls to my launchkey… so well it’s a dream to be honest… Since I am not musician I am having fun with beats and sounds so far… I am thinking of making a backup image of my working (modified sd card) if there is a simple way to send it to you since we seem to share the same hardware I would be happy to do so.
I am waiting for my audio injector to arrive tomorow and then what would be perfect would be to able to record midi and sound somehow on the zynthian…anyway just dreaming awake this thing is so much fun !!! thank you again Jofe!!!


#22

Hi @cryoshad,

Really it`s a good idea to have a modified working image. Perhaps, if you decide to do it, would be great to share with others Zynthiadicts through dropbox or other similar cloud storage. I also think that the final goal should be to give to @jofemodo the “magic recipe” to setup our rpi official touchscreen in order him to add to the new setup process he is working on.

Regards, Jose


#23

Hello José,

Here is my modified image (sry it has autoexpanded to 16Gb and I don’t really know how to reshrink it) I hope you have a large enough SD

Also about your question on pressing enter I am NOT sure this works because I don’t understand your problem sry about that.
What I can do is click any of the synths or mod application in the center panel and enter the instrument and then go down in selecting bank or else or slide the side controllers to change the values and that does work for me.

I never “needed” to click to the side controllers to do what I wanted but I mostly played with dexed and mod so I am not sure about the rest.

Anyway tell me what’s your experience with the image attached or if you could share a short 10 secs video of what doesn’t work so I can see if I have the same…

I received my audio injector and a 7’’ + rasp + iqaudio combined case from max2play.
It’s pretty good CNC machined and fits and protects the quite fragile 7’’ screen perfectly.
There is even an extra panel which was meant for another card which I will redrill to match with the audioinjector connectors. :wink:


#24

Hi @cryoshad,

Thanks for upload the image. I’ll be downloading and testing today. I’ll let you know my progress

By the way, good idea to use M2P case to build your “own” Zynthian Box.

Regards, Jose


#25

Hi @smespresati,

Just wanted to tell you that I removed my iqaudio and replaced it with the audioinjector card.
Without changing the image and: for some reason I can not go down the menus anymore or select any “engine”.
It seems that if zynthian doesn’t find a “working” sound card it would not let you enter the menus or “click” anything.
I can swipe and it would move from one engine to the next but not click anything…
It is the same problem when I remove the sound card so I don’t think it’s a conflict.

As soon as I put the IQaudio back it worked again…So stupid question maybe but did you check your sound card works?

with aplay -l

I am making a copy of my image right now to enable the audioinjector and see what happens.

Cheers,


#26

Hi @cryoshad,

Just downloaded your image from dropbox. No luck :disappointed:

Your question is not stupid: I was trying it without any soundcard. I just wanted to see how the touch interface worked, obviously I didn’t expect any sound at all. Now, I must assume the code @jofemodo did check for a working soundcard.

Conclusion, I have to move my Hifiberry from my main Zynthian Box to the new “testing device”.

Thanks a lot for your advices.

Regards, Jose


Hdmi to 1080i [solved]
#27

I am not surprised all my test from today seem to show that without a sound card working, there is no going down the menus.
Also I can’t seem to get sound out of the audio injector so far. the card is found in aplay -l
but the audio test fails. in zynthian and if I by systemctl stop zynthian and try speaker-test it tells me ressource is busy…


#28

Hi @cryoshad,

If I’m not wrong, @jofemodo code use a specific “card number”. Look at the file zynthian-ui/zynthian.sh and you will find:

function alsa_in_start() {
# Start alsa_in audio input
while [ 1 ]; do
/usr/bin/alsa_in -d hw:2 <<<<<<
sleep 1
done

I guess you have comment dtoverlay line for hifiberry and uncomment line for audioinjector.

I think your best bet is to investigate which card number is assigned to your audioinjector and try to match to @jofemodo code requirements.

Good luck.

Regards, Jose