Official RBPi TouchScreen 7"


#1

Hi I found in this forum the information to make the 7in “work”.

  1. get a fresh gorgona and UPDATE
  2. I am editting the files from windows using winscp editor and I sometimes have to edit multiple times and use the SYNC command otherwise the file is unchanged on the sd card… so SYNC and reboot a lot to commit…

you have to change the framebuffer from fb1 to fb0 in 3 config files.

HERE:

But for some reason I can’t the see the 2 left controller areas. My screen seems not correctly centered and the 2 leftmost areas are past the left side of my pi7’’.
Also how do you “enable” the touch controllers I can see that the touch in the middle of the screen works since I can press on “new” and then on the synth modules. But the 2 controllers area which I can see on the right seem not responsive…

I made a few pics from myscreen here: https://goo.gl/photos/7iq9WDAxaX8ZJeYa8
and here are some of the changes I did:

changed fb1 to fb0 in here:
/etc/systemd/system/zynthian.service
/zynthian/zynthian-sys/sbin/splash-screen.sh
/zynthian/zynthian-ui/zynthian.sh

/zynthian/zynthian-sys/boot/config.txt
changed res:
framebuffer_width=800
framebuffer_height=480

commented out piTFT (needed?)
#dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,fps=20
#dtoverlay=pitft28-resistive,rotate=90,speed=32000000,fps=20

/zynthian/zynthian-sys/etc/systemd/zynthian.service (needed?)
Environment=FRAMEBUFFER=/dev/fb0

Now I do have a a raspberry + pi 7 + iqaudiao dac+ and some usb-midi converters.
Do I need anymore hardware to make all this work?

Also I just ordered an audioinjector board so maybe I’ll be able to record or sample sounds and voices directly in the future.


New feature: full touchscreen navigation and control
#2

What you see is correct. The 4 controller areas are only displayed in the “control instrument” screen. All the other screens have a wider, left aligned select box. You have to select engine, channel, bank and instrument to reach the “intrument control” screen.

Anyway, you should know that configuring the “display” is not the same that configuring the “touch” device. Both are different devices, with different drivers and configurations.

The Gorgona SD image is configured for working with the “stmpe” touch device, that is included in the Adafruit TouchScreens (and clonics). If you are using a different one, you should follow the specific instructions for your touch device. Normaly you have to do 2 steps:

  1. Load the driver (boot/config.txt, /etc/modules, …)
  2. Configuring the X11 pointing device (/etc/X11/xorg.conf.d)

It shouldn’t be difficult, but depends of every device :wink:
I think that some HDMI screens with “USB” touch-devices work like a mouse, so probably no extra configuration should be done (perhaps some kind of calibration?)

Kind Regards!


#3

I suspect that there is a problem with configuring the LCD in config.txt. I see that you have 800 x 480 pixel resolution, so you probably have a display similar to this Adafruit device.

Take a look at the link. There are a few lines to add to config.txt to force 800 x 480 resolution since this isn’t a standard screen size:-

uncomment to force a specific HDMI mode (here we are forcing 800x480!)

hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt=800 480 60 6 0 0 0

max_usb_current=1

Hope this helps.


#4

Thank you so much for your reply.

It seems the “touch” is working because I could select new and then the elements from the list but the 2 controllers on the right do not seem to respond at all so I am a bit stuck.
Also I modified config.txt in the boot folder to enable my qaudio daq+ but it dosn’t seem to work somehow I suspect an I2C problem… Still investigating but it’s not that easy.
The Pi 7’’ touch seems to go through the DSI port (flex cable) so I don’t think it’s a USB port …
and I don’t think I need a calibration because I can click fine on the list…

Kind regards to you too.


#5

Hi @cryoshad,

Great to hear you managed the Pi 7" touchscreen to work. I’m trying too but unfortunatelly without success so far.

I changed fb1 to fb0 in the 3 files mentioned in this thread but it didn’t work for me. I started with a fresh Gorgona image but without any updates.

Did you do anything else to get it working?

Regards, Jose


#6

To be honest I am trying to replicate and take down notes but it doesn’t work anymore I think my Pi-DAC+ soundcard gets in the way now that I received it and installed it… it’s a mess… lost a few hours already… :wink:
jackd fails
aplay -l fails no hw0…pffff


#7

Thanks @cryoshad for your quick response.

If I’m not wrong, your current problem is related to audio. Do this mean your Pi 7" touchscreen works?

This “teaks” it’s taken me longer than I thought…but I’m not in a hurry, I’ll get it the sooner or later…:wink:

Regards, Jose


#8

Sorry but now the screen doesn-t work either… I had it working somehow… So I know it’s possible.(proof in the pics)
But now I added the soundcard and changed a few things and it’s not working anymore…


#9

Well I tried a few more images including the latest rasbian with pixel from january 11. There is no way I can make a single sound out of my sound card… obviously editing config.sys to enable the daq+ but then it seems the I2C times out and my sound card is not detected.

I tried it on rpi3 and an rpi2. do you need to enable the I2C specifically with or does the soundcard driver takes care of it…

I tried enabling and disabling those too…
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

but it still doesn’t work… It’s so frustrating…


#10

Some questions about your problem … :wink:
Could you send some photos of your setup? Have you soldered the 40-pin connector to the HB?
Have you investigated if there is some GPIO conflict between the HB and your display? Have you inspected the boot logs using the command “journalctl”? Have you checked that the drivers are loaded using the command “lsmod”? etc.

Kind Regards!


#11

Hi @jofemodo, @cryoshad,

I’m also working on this. Surfering the internet I’ve found Max2Play project. This project uses, among other devices, the Pi 7" Touchscreen and Hifiberry, so there should not be GPIO compatibility issues. By the way, it’s very interesting how this project deals with configurations through a web interface.

I downloaded and tested (without Hifiberry attached) M2P image. It worked (video and touch), obviously no sound at all. I tried this trying to find out the way to recreate the 7" touchscreen setup. No luck so far.

Regards, Jose.


#12

Hello just to report that I finally managed to make both the soundcard iqaudio and foundation 7’’ pi screen work together on my pi3.
It was apparently a power supply issue because as soon as I removed the screen …the card worked perfectly.

And when I connected my screen to the second (separate but common ground) port of my power supply I had both screen, pi and sound card work without a problem… :wink: so I can finally go back to trying to make the zynthian work…


#13

Congratulations! Hope to see (and hear) something from your Zynthian with a bigger display and audio input (V0c0der :robot:).

Regards, Holger


#14

Ok started with a new image
I did all what I stated above +

only left
99-fbturbo.conf in
/zynthian/zynthian-sys/etc/X11/xorg.conf.d
removing the 3.2 tft and the associatted touch

then added this file
sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf

Section "Device"
Identifier "touchscreen"
Driver "fbdev"
Option “fbdev” "/dev/fb0"
EndSection

and voila!!

now the middle (list section) is working and touch sensitive but the 4 side controllers do not :frowning:!

I am wondering if it has to do with

Wiring layout

hw_version=“PROTOTYPE-4”

since I don’t have any “physical” Zynthian hardware should I write sth else?

Thanks !


Introduce yourself!
#15

Hi @cryoshad!

Have you updated the zynthian software? You have to do it from command line, because you can’t access the admin menu:

cd /zynthian/zynthian-sys/scripts
./update_zynthian.sh
./update_zynthian_data.sh
systemctl stop zynthian
systemctl start zynthian

After that, the controller and topbar touch-areas should be enabled and you should be able to navigate without rotaries.

Regards


#16

Hi.

Nope… sry :wink: it seems that even after update only the central list is responsive no controller nor topbar…
update didn’t do error first time and now it says already up to date.

Sincerely…


#17

If “update_zynthian.sh” says “up to date”, then it should work. Have you restarted?
Have you modified some file inside “zynthian-ui” or “zynthian-sys” directories? In that case, you should restore to the original versions before updating:

cd /zynthian/zynthian-ui
git checkout .
cd /zynthian/zynthian-sys
git checkout .

Regards!


#18

Thank you I will try tomorow… I just got down in the menu and could try mod-ui from my computer. so much fun… and sound is great too!!

Cheers


#19

yep it works now…
I didn’t change those files except the last 2

but for some reasons the git “forced” pull did some magic and the controls now work and the top bar too.

Thank you so much!!!

here are the git changes I got…
Fast-forward
zyngine/zynthian_engine.py | 33 +±
zyngine/zynthian_engine_modui.py | 41 ++±
zyngine/zynthian_engine_zynaddsubfx.py | 8 ±
zynthian.sh | 15 –
zynthian_emu.sh | 76 ±----
zynthian_gui.py | 406 ++++++++++++++++++++++++++±-----
zynthian_gui_config.py | 6 ±
7 files changed, 418 insertions(+), 167 deletions(-)


#20

Hi @cryoshad, @jofemodo,

Finally I managed to get the engine selection window in my Pi 7" touchscreen. I think the step I missed is the file 99-fbdev.conf. However, I cannot make touch function to work properly.

I started with a fresh gorgona image, then updated (twice) manually using SSH. I did “git checkout” (just in case as it doesn’t hurt) and then changed all the files described above

I can select any item in the engine listbox by touch in it. I also can slide my finger (vertically or horizaontally) in the engine widget which cause the engine number in the widget to change. I noticed that, very often, when I select an engine in the listbox the engine number in the widget doesn’t change. The same happens the other way around…when I slide my finger in the widget to change the engine number the engine listbox doesn’t change.

But the main issue is the “enter switch” doesn’t work at all (unless me to do something wrong). That means I cannot move forward to the MIDI channel windows. Also, a long touch in the widget do nothing

At this point I wonder whether this behavior is software related or a configuration issue. I’m afraid it will be something I did wrong as @cryoshad has succed.

Any idea to light me up?

Regards, Jose