Official RBPi TouchScreen 7"


#21

Sry for my late reply… too busy playing with mod… :wink: I am not sure I understand the problem I can at least in mod change the controls and they would change realtime on my PC webbrowser and assign controls to my launchkey… so well it’s a dream to be honest… Since I am not musician I am having fun with beats and sounds so far… I am thinking of making a backup image of my working (modified sd card) if there is a simple way to send it to you since we seem to share the same hardware I would be happy to do so.
I am waiting for my audio injector to arrive tomorow and then what would be perfect would be to able to record midi and sound somehow on the zynthian…anyway just dreaming awake this thing is so much fun !!! thank you again Jofe!!!


#22

Hi @cryoshad,

Really it`s a good idea to have a modified working image. Perhaps, if you decide to do it, would be great to share with others Zynthiadicts through dropbox or other similar cloud storage. I also think that the final goal should be to give to @jofemodo the “magic recipe” to setup our rpi official touchscreen in order him to add to the new setup process he is working on.

Regards, Jose


#23

Hello José,

Here is my modified image (sry it has autoexpanded to 16Gb and I don’t really know how to reshrink it) I hope you have a large enough SD

Also about your question on pressing enter I am NOT sure this works because I don’t understand your problem sry about that.
What I can do is click any of the synths or mod application in the center panel and enter the instrument and then go down in selecting bank or else or slide the side controllers to change the values and that does work for me.

I never “needed” to click to the side controllers to do what I wanted but I mostly played with dexed and mod so I am not sure about the rest.

Anyway tell me what’s your experience with the image attached or if you could share a short 10 secs video of what doesn’t work so I can see if I have the same…

I received my audio injector and a 7’’ + rasp + iqaudio combined case from max2play.
It’s pretty good CNC machined and fits and protects the quite fragile 7’’ screen perfectly.
There is even an extra panel which was meant for another card which I will redrill to match with the audioinjector connectors. :wink:


#24

Hi @cryoshad,

Thanks for upload the image. I’ll be downloading and testing today. I’ll let you know my progress

By the way, good idea to use M2P case to build your “own” Zynthian Box.

Regards, Jose


#25

Hi @smespresati,

Just wanted to tell you that I removed my iqaudio and replaced it with the audioinjector card.
Without changing the image and: for some reason I can not go down the menus anymore or select any “engine”.
It seems that if zynthian doesn’t find a “working” sound card it would not let you enter the menus or “click” anything.
I can swipe and it would move from one engine to the next but not click anything…
It is the same problem when I remove the sound card so I don’t think it’s a conflict.

As soon as I put the IQaudio back it worked again…So stupid question maybe but did you check your sound card works?

with aplay -l

I am making a copy of my image right now to enable the audioinjector and see what happens.

Cheers,


#26

Hi @cryoshad,

Just downloaded your image from dropbox. No luck :disappointed:

Your question is not stupid: I was trying it without any soundcard. I just wanted to see how the touch interface worked, obviously I didn’t expect any sound at all. Now, I must assume the code @jofemodo did check for a working soundcard.

Conclusion, I have to move my Hifiberry from my main Zynthian Box to the new “testing device”.

Thanks a lot for your advices.

Regards, Jose


Hdmi to 1080i [solved]
#27

I am not surprised all my test from today seem to show that without a sound card working, there is no going down the menus.
Also I can’t seem to get sound out of the audio injector so far. the card is found in aplay -l
but the audio test fails. in zynthian and if I by systemctl stop zynthian and try speaker-test it tells me ressource is busy…


#28

Hi @cryoshad,

If I’m not wrong, @jofemodo code use a specific “card number”. Look at the file zynthian-ui/zynthian.sh and you will find:

function alsa_in_start() {
# Start alsa_in audio input
while [ 1 ]; do
/usr/bin/alsa_in -d hw:2 <<<<<<
sleep 1
done

I guess you have comment dtoverlay line for hifiberry and uncomment line for audioinjector.

I think your best bet is to investigate which card number is assigned to your audioinjector and try to match to @jofemodo code requirements.

Good luck.

Regards, Jose


#29

You are certainly right for the audio input hw:
my card being hw 0,0 from what I understand.

But I am actually more concerned about audio_out at this point.
I managed to hear the speaker test in the pixel raspberry image but not in this one yet… I’ll keep trying and surching the config files but any more hints like this one would definetly be welcome :grin:


#30

Well,

Changed the file but still no sound out… I seem to have an I2S problem:
here is the relevant part of my dmesg…

I do know the card works with screen on the rasbian pixel image so It must be a config issue.

[ 2.697121] audioinjector-audio soc:sound: ASoC: CPU DAI (null) not registere d
[ 2.698810] audioinjector-audio soc:sound: snd_soc_register_card failed (-517 )
[ 2.699052] wm8731 1-001a: Assuming static MCLK
[ 2.702201] audioinjector-audio soc:sound: ASoC: CPU DAI (null) not registere d
[ 2.703953] audioinjector-audio soc:sound: snd_soc_register_card failed (-517 )
[ 2.708251] audioinjector-audio soc:sound: wm8731-hifi <-> 3f203000.i2s mappi ng ok
[ 2.780857] smsc95xx 1-1.1:1.0 eth3: renamed from eth0
[ 2.813735] systemd-udevd[142]: renamed network interface eth0 to eth3
[ 2.945684] usbcore: registered new interface driver brcmfmac
[ 2.947455] brcmfmac_sdio mmc1:0001:1: Direct firmware load for brcm/brcmfmac 43430-sdio.bin failed with error -2
[ 3.953327] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x 50
[ 4.963336] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x 50
[ 8.088427] EXT4-fs (mmcblk0p2): re-mounted. Opts: errors=remount-ro,commit=1 20
[ 8.137164] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 8.290432] systemd-journald[112]: Received request to flush runtime journal from PID 1
[ 9.194795] smsc95xx 1-1.1:1.0 eth3: hardware isn’t capable of remote wakeup
[ 9.196157] IPv6: ADDRCONF(NETDEV_UP): eth3: link is not ready
[ 9.762220] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
[ 10.323897] random: nonblocking pool is initialized
[ 10.331252] uart-pl011 3f201000.uart: no DMA platform data
[ 10.765626] IPv6: ADDRCONF(NETDEV_CHANGE): eth3: link becomes ready
[ 10.767163] smsc95xx 1-1.1:1.0 eth3: link up, 100Mbps, full-duplex, lpa 0xCDE


#31

Hi @cryoshad,

I’m not a Linux Master, so take this as my own opinion…

Googling, I’ve found that :

[ 2.698810] audioinjector-audio soc:sound: snd_soc_register_card failed (-517 )
[ 2.699052] wm8731 1-001a: Assuming static MCLK
[ 2.702201] audioinjector-audio soc:sound: ASoC: CPU DAI (null) not registere d
[ 2.703953] audioinjector-audio soc:sound: snd_soc_register_card failed (-517 )
[ 2.708251] audioinjector-audio soc:sound: wm8731-hifi <-> 3f203000.i2s mappi ng ok <<<<<<<<<<<

this boot messages are normal…the soundcard was succesfully configured after 3 “retries”.

In the other hand the message:

[ 9.762220] bcm2835-i2s 3f203000.i2s: I2S SYNC error!

is the one to take care with. I’ve found many places treating this issue but, so far, I couldn’t find any clear solution. Obiously it’s a setup issue as the card works out of the box with Raspbian Pixel.

I’ve also found a nice blog expleaning very clearly how sound/midi works in Linux and how to trobleshoot common issues. I wish it will help you.

http://tedfelix.com/linux/linux-midi.html

I’d try to play some sound using ssh console commands as explained in the blog. Perhaps this will help to isolate what is causing the issue.

Regards, Jose


#32

Hi guys!

Have you tried to update the kernel & firmware? Perhaps this sequence could solve the problem:

apt-get -y update
apt-get -y upgrade
apt-get -y dist-upgrade
rpi-update
reboot

Kind Regards!


#33

@jofemodo, @smespresati

Thank you for your feed back I agree, and I followed the I2S sync error to some other website forums… They did indeed recomend kernel upgrade but it was for a hifi berry and it dated back 1 year on kernel 3.7 … so I thought (maybe wrongly) that the kernel would be fixed by now. And also that the kernel was “fine tuned” in zynthian for low latency and so I was “wrongly” afraid that updating the kernel would not be too good.
I am doing the update while writing this down and will update with my experience. I am sorry to ask all those questions… Still I hope the trace in the forum will help more people in the future.

UPDATE: upgrade as you recommended seems to have proceeded successfully, but unfortunately the I2S SYNC error is still there and no sound :sweat::

root@zynthian:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

root@zynthian:~# speaker-test

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Playback open error: -16,Device or resource busy

and it is still the same even if I systemctl stop zynthian.

I read in an other thread that you also have an audio-injector, but did you manage to make it work with zynthian yet?

Cheers,

@cryoshad


#34

Hi @cryoshad,

I’ve been doing some testings using my RBPI2 with my Hifiberry (which is working fine)

If I try speaker-test I get the same error: Playback open error: -16,Device or resource busy

Running the command:

sudo fuser -v /dev/snd/*

I’ve found that jackd is using the soundcard

Then I stopped jackd using command:

killall -9 jackd

Now speaker-test works (just noise it’s heard). Keep in mind that you can’t run speaker-test a second time until you run “killall -9 speaker-test” as it keeps running. Also you can try:

aplay -D hw:0 file.wav (any .wav filetype)

That way you can confirm whether or not Minibian is able to drive this card,

I also think the message “I2S SYNC error!” will cause some kind of noise or latency, but the sound card should work.

Good luck!!

Regards, Jose


#35

Just tried and yes!! it works on hw0 and now for some reason … I think I played with the alsamixer everything works fine in all engines… including mod I can distort my voice in real time all working finally thank you for your help!!!


#36

Yeahhhh! Really great news, @cryoshad!

Probably you are the first person using Zynthian as an effects proccessor (audio input). Congratulations!

I will be the second one :wink: My audioinjector is waiting for me …

Kind Regards!


#37

Congratulations!!! @cryoshad.

When I met Zynthian this was my goal: have a fully functional touch interface for a simplier build (avoiding enconders, pcb’s, etc). I just wanted my Zynthian to “enjoy myself” at home. I guess those who plan to use Zynthian on stage should feel more confortable with a pysical knob to play.

A few questions now…

Did “I2S SYN error!” message disappear? If not, do you hear something wrong (clicks, pops…)? what about latency?

How about sound quality? (compared to the iqaudio that you own)

Do you know if input and output gain can be controlled by sw instead of physical potentiometers? I gess the answer is yes.

Enjoy your new little toy!

Regards, Jose


#38

Congratulation for this new interesting way of using Zynthian…i am also interesting at the possibility of using Zynthian for a guitar processor (my son plays guitar…) …


#39

Hello @smespresati,

Q1: Yes the I2S SYNC is still there. But I do not notice any clicks or pops
Q2: Latency is to my ears very acceptable … I do admitedly notice a very small delay but for voice it is fine. Not sure about fast guitar picking… though…I might have time to plug my oscilloscope one day and get you a metrics.
Q3: Sound quality is good but if you do have the right levels in the alsamixer, But if you go louder you can definetely hear some white noise.
Q4: yes the alsamixer works fine and has a “MASTER” level as well as an "output mixer"
Q5: Also it seems that the audioinjector is much less sensitive to “low voltage” than the iqaudio.

As a mater of fact I can drive: raspberry pi3 + audio injector + 7’’ touchscreen + novation launchkey 25 + some basic speakers… all those powered from the the micro usb of the rasbperry pi with a single 2.4 Amp usb powersupply

Finally I enclosed the electronics tonight and I am pretty happy with the result. I’ll add some pics. :wink:

Cheers,


#40

Hello I have taken an oscilloscope and traced input vs output signal using mod with a direct connection and a detune module.
I get a latency about 10ms if I go direct in mod and 20ms with the detune.
Obviously I removed the line in-line out bypass in the alsamixer otherwise there was no measurable delay…

7 new photos added to shared album

I have also added pictures of my box connected to the zynthian headphone and ready to play.

It’s really an incredible toy and my kids are going crazy with the voice detune…

I guess the only thing which would be needed now is the ability to control from the launchpad a simple looper or a miniature sequencer like this one…
http://filter24.org/seq24/about.html

But maybe I am dreaming or simply a bit spoiled by now… :pensive:

Anyway I found my launchkey programmer’s reference manual here … so I could just start coding :fearful:
https://global.novationmusic.com/support/downloads/launchkey-mk2-programmers-reference-guide