Official RBPi TouchScreen 7"


#41

Hi Guys!

I’m having the same issues with AudioInjector.

I set up my Zynthian with a 7 "HDMI screen with the instructions this link:


and tried the settings placed here, but I did not succeed.

Any tips on how to make the audio injector work?

Thank you



#42

Hi @rod_amaral!

Note that audioinjector uses some GPIO pins that are already used by Zynthian default configuration (the last statement is incorrect and amended in another comment below …). Althought you have no rotary encoders in your setup, Zynthian UI will try to read from it. I’ve fixed this in the last software version, so you should try it:

When you have correctly updated the UI software, you should edit the config file “zynthian_gui_config.py” and configure the GPIO layout as “dummies”:

hw_version="DUMMIES"

This will prevent the zyncoder library to try to configure and read the rotary encoders & switches.

Kind Regards!


#43

Thank you @jofemodo! I’ll try it today!


#44

Excuse me, @rod_amaral!

I’ve checked the GPIO layout and there is no conflict. Audioinjector don’t use any GPIO pin currently used by Zynthian, so it shouldn’t be conflicts.

Just now, i’m trying to configure my audioinjector. I will give some feedback … :wink:

Regards!


#45

Whew, you almost made me nervous. I have the audioinjector working just fine for output, but I’m still waiting for a cheap Chinese lcd to arrive. The kids don’t really appreciate when I’m using the TV as hdmi display. :grin: In the meantime I’m trying my luck with toner transfer for the pcb’s. I haven’t etched a board since 8th grade :thinking:


#46

I’m burning a new image right now. I hope to give you feedback too! :+1: :+1:


#47

Good news! The audioinjector works perfectly, even without the zynthian-ui update.

I had forgotten to configure alsamixer to enable audio output. :frowning2:

However, for now, i can only use the audio output, the input still could not make it work.


#48

Audio Input Working too! :raised_hands:


#49

Greaaaaat! Can you explain how did you make it work?

Thanks!


#50

Here’s what I did, in order:

  1. I installed a clean image of the zynthian gongorna
  2. Run apt-get update, upgrade; Upadte-dist; Rpi-update and reboot
  3. Update Zynthian
  4. Since I’m using an HDMI screen, I followed the steps in this post
  5. On file /zynthian/zynthian-ui/zynthian.sh changed:

function alsa_in_start() {
Start alsa_in audio input
while [ 1 ]; do
/usr/bin/_alsa_in -d hw:0
sleep 1
done
6) Alsamixer Configuration:


And it worked perfectly!

Here a little set:

For guitar the line input of the audioinjector is not very good, so I’ll have to build a preamp to send a bigger signal.

As soon as i can organize the assembly a bit, I’ll create a post with the step by step and the results

Thanks again!


Zynthian Box with Audio-input (Audioinjector soundcard)
Zynthian Box with Audio-input (Audioinjector soundcard)
#51

Hi @rod_amaral!

Normally, this step is not needed and could break something, specially MIDI-IN, but if it worked, OK, it’s better to have an updated kernel and firmware :wink:

This is not needed, but. It’s intended for using an extra USB card, but i think it wouldn’t be needed never more.
Better to ignore. I will remove this function in the next release.

The key part is alsa mixer :wink:

Regards!


#53

To be honest I am trying to replicate and take down notes but it doesn’t
work anymore I think my daq+ soundcard gets in the way now that I received
it… it’s a mess… lost a few hours already… :wink:


#54

Hey all,
So i have a RapsberryPi official 7 inch display and an audioinjector. And I found that if I connect it to the SPI interface the audio injector stops working, but if I only connect the ribbon cable and the power it works. Strangely enough the touch screen also works.


#55

I’ve got a 7" touch screen working with an audio injector on it’s back. No knobs.