ORAM 2024-05-22: RPI5 does not boot

It happened to me twice:

flashed a new SD,
updated it
set up the SW for my HW (5" touch screen, NXEZ audio card)
loaded all my SF2
played
switch off the power

The day after I switch on and system does not boot:
green led on Raspberry
screen off,
system does not respond to zynthian.local
nothing happens as if there is not OS in the SD

Do you have suggestions?

1 Like

Green led with no blinking in the RPi?
I doesn’t look like a system problem. It looks more like a hardware issue. Defective SD or dirty contacts, bad power, etc.

Regards,

Green led with no blinking

I doesn’t look like a system problem. It looks more like a hardware issue

I tought the same the first time it happened to me. When it happened first time I changed the SD switching on the HW with a SD card where I installed UBUNTU: no issues.

Later I reflashed ORAM May22 and used half day without issues.

I flashed another SD card and keep checked.
How is it possible to inspect with WIN11 the previous not working SD?

P.S.
could it be caused by overheating of RPI5? I do not have any cooler, but RPi5 is not closed in a case
how could I realize that?

Of course! A cooler is almost mandatory with Pi5. Default Zynthian configuration disables dynamic CPU freq and run at maximum freq all the time, except when sleeped.
But it should boot at less …

1 Like

Hi @jofemodo, what do you mean by sleeped ?

I mean the Zynthian enters power save mode after some time without activity. Display is turned off, CPU frequency is reduced, LEDs are lighted off, etc.

1 Like

Hey there,
After several attempts (and re-downloads) to get the image going on various SD cards, I keep hitting the same brick wall. My Pi5 throws a tantrum, goes completely kaput, and I end up having to do the Pi5 EEPROM recovery to bring it back to life. Any idea what’s going wrong here? The same thing. Three long flashes and one short. After the recovery, I can boot all other sd cards, but not this one.
So it is not contact problem, it is EEPROM failure, every time.

is it possible that sleep mode is kept and so affects the boot?
how to awake the system without mouse and keyboard?

1 Like

No. Boot is done at full speed. Power save mode is managed by the ui, so it can enter power save mode before the ui is completely up.

Any CUIA or MIDI activity will wake up the Zynthian.

Regards

For me it’s still not working. I tried a lot of times, every time I put the new Oram SD card it block after the firs message on the screen so I must to do the eeprom reset. What am I doing wrong? :((

I couldn’t say. I tested with several Pi5 boards here and they all work fine.
Do you have a heatsink in your board? Note that zynthian disables CPU frequency scaling so it could get hot very quickly without a heatsink.

Anyway, i will do extra tests …

Regards,

1 Like

Sure, have a normal heatsink and everything. It cannot overheat, because it happens in 2sec, so when the first message arrives it stucks. Thank you, patience is our biggest friend. :-))

It happened to me the 3rd time, this time RPI5 has active cooler:
it was working,
I updated and switch off

now I switch on
cooler fan goes fast
RPI led is green
but it does not boot:
touch screen completely black, even the retroillumination is off

I tried to pull off the sd: same behaviour.
At boot it is like to don’t have the SD in Zynthian

I believe something happens with update
zyncoder: oram (b5c87b7)
zynthian-ui: oram (c030c6c)
zynthian-sys: oram (ce896ec)
zynthian-data: oram (db0355a)
zynthian-webconf: oram (c27fea2)

HARDWARE

Raspberry Pi 5 Model B Rev 1.0
Audio: JustBoom DAC
Display: Generic HDMI Display
Wiring: DUMMIES
I2C: Not detected
Profile:

SYSTEM

Debian GNU/Linux 12 (bookworm)
Build Date: 2024-05-21
Memory: 19% (792M/4045M)
SD Card: 58% (33G/58G)
Temperature: 49.4ºC
Overclock: None

1 Like

What is your audio configuration and hardware?

Regards

5" touch screen, NXEZ audio card configured as

before problem, audio card worked perfectly
last update that created the issue was lauched from webconf

This system doesn’t seem to be updated. Anyway, try:

-r 48000 -p 128 -n 2

And replace the “-t 2000” by “-S”.

Regards

do I have to reflash? no other chances?

No need to reflash. Update again and make the changes I suggested

Regards

the system does not boot
it is like id don’t have SD