ORAM 2024-05-22: RPI5 does not boot

But you show the webconf dashboard. How do you get it?

is the last save I have before issue: I took note of last working status

Try reflashing then :wink:

It will be my 4th time: what do you think it causes this status?

No idea. I’ve tested with several pi5 boards and it works. Tomorrow I will try again.

Regards

1 Like

Maybe it would be helpful inspect the content of SD to see if there is something wrong.
I installed Freeware Linux Reader™ for Windows so I can see the SD
@jofemodo : could I give you more details about missed boot watching the content of SD?

What is the size of this SD card? Brand and model too, please.

Regards

64 GB Sandisk Ultra

1 Like

@piattica, i was testing again with a fresh burned Oram Bookworm image. I used “sandisk Ultra 32GB”. No issues. I tested in 3 different RPI5 boards, connecting the SD card directly and using a SD card extender. Everything worked as expected. The Pi5 booted without issues and it displayed the first booting splash in the DSI display i was using No other hardware apart from the display.

Please, could you verify that it’s not an issue with the bootloader? Although the RPi team says it’s difficult to corrupt the bootloader, in the latest weeks i had to recover 2 of my RPi5 boards because of the bootloader being corrupted. I never suffered this issue with RPi4, but RPi5 is different.

For recovering from a corrupted bootloader, you simply have to burn this image on a SD-card:

https://github.com/raspberrypi/rpi-eeprom/releases/download/v2023.12.06-2712/rpi-boot-eeprom-recovery-2023-12-06-2712-sd.zip

Then boot your RPI5 with it and wait until the green led start to blink fast. Then power-off, remove the SD-card and boot with the Oram Bookworm SD image.

Regards,

3 Likes

following with your hypothesis, why Zynthian works after reflashing the SD?

I can’t reproduce the issue. My RPI5 boot always. The first, the second and all the others. I suspect my bootloader corruption episodes were due to incomplete or bad rpi-update.Strange, but i can’t say more.
After restoring the bootloader, everything is working perfectly OK.

Regards,

tomorrow I will follow you suggestion to rebiild the bootloader and if your idea is correct after fixing the bootloader
the SD should work immediately

what do you think?

@jofemodo
I recovered bootloader
then I tried a boot with the SD working before failed boot, but no changes: system still does not boot.

So I am reflashing once more the SD.
I am not expert but the problem IMHO is connected with OS SD: probably an update corrupts some files.
Mind that it happened to me 3 times so there is something happening during update.

To be clear, I have fixed my bootloader multiple times on my Pi5 this week, and what causes it to break again is booting the Oram image. I have it running raspbian right now out in the garage, it is definitely something on your image.

I do not have $30 to order their fancy terminal cable unfortunately, and I cannot seem to make the thing talk to my old-style uart adapters.

1 Like

[quote=“jtode, post:34, topic:9601”]their fancy terminal cable
[/quote]

could you show me a pict. of that?

these are the two cables I have - note the standard breadboard-size pins.

All Pis up to 4 used pins 14+15 for UART. No problem. Pi has changed their default UART for serial to this “EZ” connector, between the two HDMI ports (says “UART” on the screenprint):

image

You can enable them by modifying the bootloader, which I did, but I cannot get a peep of communication off them, with any image at all.

I could spend $20 but I don’t have $20 (last time I looked it was $30 - possibly Amazon turned the price down when I came back a second time, not sure).

you can enable kernel boot log on regular GPIO/UART console :

https://www.raspberrypi.com/documentation/computers/raspberry-pi.html#BOOT_UART

Like I said, spent yesterday trying. I’m not always competent and the docs aren’t always worth a turd.

1 Like

Yeah sometimes it looks like the RaspberryPi folks are in a pure “less is more” mood with their documentation :thinking: .

1 Like

I tried the image “2024-05-22-zynthianos-bookworm-aarch64-oram-2405.zip” with my new raspi 5 yesterday, without having anything attatched than an USB Mouse, a HDMI Display and an active cooler. Same problems here. It starts blinking 3x long and 1x short, which from the documantation stands for “SPI EEPROM error - Pi 4 and Pi 5”.
Made a bootloader recovery and tried the test version from 2024-05-05, there the blinking code strangely is 4x long and 5x short, which stands for “Fatal firmware error”.
After recovering the bootlaoder i installed the official raspberry pi os, works like a charme.