Periodic cliking noise [SOLVED!]

#1

Hi all,

Since I updated to the last version, I noticed some regular cliking noise (every 2 seconds or so).
the noise is not very loud but still audible and It happens with any synth.
Here are my settings:
jackd options: -P 70 -t 2000 -s -d alsa -d hw:0 -r 44100 -p 256 -n 2 -X raw
Soundcard: [HifiBerry DAC+]

I also noticed periodic messages “JACK connection graph change.” within Jackd logs.
It seems to correspond to the interval that the noise is heard.

Attached to this topic is the Jackd debug log file.
We can see that every 2 seconds, the python process performs multiple connections: “startx[610]: Jack: JackClient::Connect src = system:XXXX dst = ZynMidiRouter:main_in” (with XXXX being each midi source).

Are those connections loops normal ?

Does anybody else face this issue ?

Cheers,
Claude

zynthian-jackd.log (30.7 KB)

#2

Does it appear on recordings or playings of recordings…?

#3

On playing. I haven’t tried recording yet.

#4

The auto-connection loop is normal, but it shouldn’t have any audible effect or see any warning message. The log you send is not normal at all …

I would recommend to try with a fresh Gorgona+Update or try with the new Aruk RC-1 image.

Regards,

#5

You were going to tell is when Aruk is fixed!

#6

Hi @claudev, have a look here A weird noise is driving me mad [SOLVED] maybe it’s just the same click…
Ciao!
Andrea

#7

Thank you very much for the quick feedback.
@sadkermit, the Mute parameter ON. I switched them to OFF. But still had the issue with the click (without reboot). Then, I changed the DSP program to something else.
After I reboot, the problem was gone.
Then I tried to set again the old parameters (Mute ON + DSP program), reboot again. But the cliking noise did not come back.
Maybe going through alsamixer settings reseted the audio layer somehow.
Subject solved ! thank you guys again.